summaryrefslogtreecommitdiff
path: root/user/yaml-cpp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/yaml-cpp/APKBUILD')
-rw-r--r--user/yaml-cpp/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/yaml-cpp/APKBUILD b/user/yaml-cpp/APKBUILD
new file mode 100644
index 000000000..4f7e7bfa9
--- /dev/null
+++ b/user/yaml-cpp/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=yaml-cpp
+pkgver=0.6.3
+pkgrel=0
+pkgdesc="A YAML parser and emitter in C++"
+url="https://github.com/jbeder/yaml-cpp"
+arch="all"
+license="MIT"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DYAML_BUILD_SHARED_LIBS=ON \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="68b9ce987cabc1dec79382f922de20cc2c222cb9c090ecb93dc686b048da5c917facf4fce6d8f72feea44b61e5a6770ed3b0c199c4cd4e6bde5b6245c09f8e49 yaml-cpp-0.6.3.tar.gz"