summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/py3-setuptools/APKBUILD44
-rw-r--r--user/py3-setuptools/pythonpath.patch11
2 files changed, 0 insertions, 55 deletions
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
deleted file mode 100644
index 9081ae0b5..000000000
--- a/user/py3-setuptools/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Max Rees <maxcrees@me.com>
-# Maintainer: Max Rees <maxcrees@me.com>
-pkgname=py3-setuptools
-_pkgname=setuptools
-pkgver=39.2.0
-pkgrel=0
-pkgdesc="A collection of enhancements to the Python distutils"
-url="http://pypi.python.org/project/setuptools"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="python3-dev"
-checkdepends="py3-tox"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
-subpackages="py3-easy_install:easy_install"
-source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/1a/04/d6f1159feaccdfc508517dba1929eb93a2854de729fa68da9d5c6b48fa00/setuptools-39.2.0.zip
- pythonpath.patch"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python3 bootstrap.py
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- PYTHONPATH="$builddir" TOXENV="py36" tox
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-easy_install() {
- pkgdesc="Python easy_install tool (deprecated)"
- depends="$pkgname python3"
- mkdir -p "$subpkgdir/usr/bin"
- mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
-}
-
-sha512sums="46baf6a48f93279d541ca10e0d71005565a7c9fbe4a8fe6b6378455edc57e5246bad3000ae9c9c47503a04e37816f9fa02e6c4328955ad16939c01c89c65d6b2 py3-setuptools-39.2.0.zip
-ee248df4174240e90a35190e0a47bf0fa4cc5601adc64eff5fd585c8919e47c3a2bb6191b8333800016567d8a0f0f71b7c2306779ea7e4ab7c8951bdee28ef5e pythonpath.patch"
diff --git a/user/py3-setuptools/pythonpath.patch b/user/py3-setuptools/pythonpath.patch
deleted file mode 100644
index d9d78a861..000000000
--- a/user/py3-setuptools/pythonpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setuptools-39.1.0/tox.ini 2018-04-28 07:07:00.000000000 -0400
-+++ setuptools-39.1.0/tox.ini 2018-05-22 00:25:02.969163171 -0400
-@@ -12,7 +12,7 @@
- setenv=COVERAGE_FILE={toxworkdir}/.coverage.{envname}
- # TODO: The passed environment variables came from copying other tox.ini files
- # These should probably be individually annotated to explain what needs them.
--passenv=APPDATA HOMEDRIVE HOMEPATH windir APPVEYOR APPVEYOR_* CI CODECOV_* TRAVIS TRAVIS_*
-+passenv=APPDATA HOMEDRIVE HOMEPATH windir APPVEYOR APPVEYOR_* CI CODECOV_* TRAVIS TRAVIS_* PYTHONPATH
- commands=pytest --cov-config={toxinidir}/tox.ini --cov-report= {posargs}
- usedevelop=True
-