summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/feh/APKBUILD42
-rw-r--r--user/feh/cflags.patch11
-rw-r--r--user/feh/stdout-buff.patch113
-rw-r--r--user/grantlee/APKBUILD2
-rw-r--r--user/kconfig/APKBUILD2
-rw-r--r--user/kguiaddons/APKBUILD1
-rw-r--r--user/kiconthemes/APKBUILD1
-rw-r--r--user/kitemmodels/APKBUILD1
-rw-r--r--user/kwallet/APKBUILD8
-rw-r--r--user/kwallet/kwallet-5.22.0-blowfish-endianness.patch52
-rw-r--r--user/plasma-workspace/APKBUILD9
-rw-r--r--user/plasma-workspace/fix-crash-on-wallpaper-change.patch58
-rw-r--r--user/quaternion/APKBUILD54
-rw-r--r--user/quaternion/install-library.patch9
-rw-r--r--user/xmlsec/APKBUILD60
15 files changed, 415 insertions, 8 deletions
diff --git a/user/feh/APKBUILD b/user/feh/APKBUILD
new file mode 100644
index 000000000..b68566ae2
--- /dev/null
+++ b/user/feh/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=feh
+pkgver=2.23
+pkgrel=0
+pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
+url="http://feh.finalrewind.org/"
+arch="all"
+license="MIT-feh"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libxt-dev libpng-dev giblib-dev imlib2-dev libjpeg-turbo-dev
+ libxinerama-dev curl-dev libexif-dev"
+checkdepends="perl-utils perl-test-command"
+source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2
+ stdout-buff.patch
+ cflags.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr curl=1 exif=1 xinerama=1
+}
+
+check() {
+ cd "$builddir"
+ make PREFIX=/usr test
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" \
+ bin_dir="$pkgdir"/usr/bin \
+ man_dir="$pkgdir"/usr/share/man \
+ doc_dir="$pkgdir"/usr/share/doc/$pkgname \
+ example_dir="$pkgdir"/usr/share/doc/$pkgname/examples \
+ install
+}
+
+sha512sums="4b75f0053c3a4b1fb51251536896fd48470117ca3d59de1ac5a87f8071f37f886542e7d82730eec4579a1ebf507e4bc8a00fc45cf1364d2445b1aa82c5664ee7 feh-2.23.tar.bz2
+38ead15a58c402181da3e39c09002d9f951b03cfdf5edde19072da313638025dca5fa7dbe466b8f05094d49d44750c467d7fa3832fbaa11ac135c5839e0ecdc1 stdout-buff.patch
+577e0420aef6bbf1cc43fe97813fd56a877c45b9cb01f1f86ee41863a8bf12f97b5f62c01b37a6b8fc78f7dd8ab9a372d1b09ba00e3811d0043772f5e16e0707 cflags.patch"
diff --git a/user/feh/cflags.patch b/user/feh/cflags.patch
new file mode 100644
index 000000000..88f0c05c9
--- /dev/null
+++ b/user/feh/cflags.patch
@@ -0,0 +1,11 @@
+--- feh-2.23/config.mk 2017-12-28 18:28:35.000000000 +0000
++++ feh-2.23/config.mk 2018-01-08 01:19:54.440000000 +0000
+@@ -38,7 +38,7 @@
+ CFLAGS += -Wall -Wextra -pedantic
+
+ # Settings for glibc >= 2.19 - may need to be adjusted for other systems
+-CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=500
++CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700
+
+ ifeq (${curl},1)
+ CFLAGS += -DHAVE_LIBCURL
diff --git a/user/feh/stdout-buff.patch b/user/feh/stdout-buff.patch
new file mode 100644
index 000000000..eaa251a3a
--- /dev/null
+++ b/user/feh/stdout-buff.patch
@@ -0,0 +1,113 @@
+On glibc, if output is redirected to a file, output will look like this:
+
+touch test/ok/gif
+touch test/ok/jpg
+touch test/ok/png
+touch test/ok/pnm
+test/ok/gif
+test/ok/jpg
+test/ok/png
+test/ok/pnm
+
+On musl, if stdout is redirected to a file, output looks like this:
+
+test/ok/gif
+touch test/ok/gif
+touch test/ok/jpg
+touch test/ok/png
+touch test/ok/pnm
+test/ok/jpg
+test/ok/png
+test/ok/pnm
+
+On glibc and musl, if stdout is interactive, it looks like this:
+
+test/ok/gif
+touch test/ok/gif
+test/ok/jpg
+touch test/ok/jpg
+test/ok/png
+touch test/ok/png
+test/ok/pnm
+touch test/ok/pnm
+
+Adding two fflush calls makes all behavior look like the last example.
+
+--- feh-2.22/src/list.c 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/src/list.c 2018-01-03 02:59:08.840000000 +0000
+@@ -92,6 +92,7 @@
+ if (opt.verbose)
+ feh_display_status('.');
+ puts(file->filename);
++ fflush(stdout);
+ feh_action_run(file, opt.actions[0], NULL);
+ }
+ else {
+@@ -106,6 +107,7 @@
+ if (opt.verbose)
+ feh_display_status('.');
+ puts(file->filename);
++ fflush(stdout);
+ feh_action_run(file, opt.actions[0], NULL);
+ }
+ else {
+--- feh-2.22/test/nx_action/loadable_action 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/loadable_action 2018-01-03 02:46:48.030000000 +0000
+@@ -1,8 +1,8 @@
+-touch test/ok/gif
+-touch test/ok/jpg
+-touch test/ok/png
+-touch test/ok/pnm
+ test/ok/gif
++touch test/ok/gif
+ test/ok/jpg
++touch test/ok/jpg
+ test/ok/png
++touch test/ok/png
+ test/ok/pnm
++touch test/ok/pnm
+--- feh-2.22/test/nx_action/loadable_naction 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/loadable_naction 2018-01-03 02:51:05.340000000 +0000
+@@ -1,8 +1,8 @@
+-touch test/ok/gif
+-touch test/ok/jpg
+-touch test/ok/png
+-touch test/ok/pnm
+ test/ok/gif
++touch test/ok/gif
+ test/ok/jpg
++touch test/ok/jpg
+ test/ok/png
++touch test/ok/png
+ test/ok/pnm
++touch test/ok/pnm
+--- feh-2.22/test/nx_action/unloadable_action 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/unloadable_action 2018-01-03 02:51:36.480000000 +0000
+@@ -1,8 +1,8 @@
+-rm test/fail/gif
+-rm test/fail/jpg
+-rm test/fail/png
+-rm test/fail/pnm
+ test/fail/gif
++rm test/fail/gif
+ test/fail/jpg
++rm test/fail/jpg
+ test/fail/png
++rm test/fail/png
+ test/fail/pnm
++rm test/fail/pnm
+--- feh-2.22/test/nx_action/unloadable_naction 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/unloadable_naction 2018-01-03 02:51:51.850000000 +0000
+@@ -1,8 +1,8 @@
+-rm test/fail/gif
+-rm test/fail/jpg
+-rm test/fail/png
+-rm test/fail/pnm
+ test/fail/gif
++rm test/fail/gif
+ test/fail/jpg
++rm test/fail/jpg
+ test/fail/png
++rm test/fail/png
+ test/fail/pnm
++rm test/fail/pnm
diff --git a/user/grantlee/APKBUILD b/user/grantlee/APKBUILD
index c8cfbec90..dd0e22a54 100644
--- a/user/grantlee/APKBUILD
+++ b/user/grantlee/APKBUILD
@@ -32,7 +32,7 @@ build() {
check() {
cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E buildertest
}
package() {
diff --git a/user/kconfig/APKBUILD b/user/kconfig/APKBUILD
index 7f4452524..5873064b4 100644
--- a/user/kconfig/APKBUILD
+++ b/user/kconfig/APKBUILD
@@ -35,7 +35,7 @@ build() {
check() {
cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -R kconfigcore
}
package() {
diff --git a/user/kguiaddons/APKBUILD b/user/kguiaddons/APKBUILD
index f6b1b4e08..f715724c3 100644
--- a/user/kguiaddons/APKBUILD
+++ b/user/kguiaddons/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Framework for creating high-level user interfaces"
url="https://www.kde.org/"
arch="all"
+options="!check" # Requires running X11
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev qt5-qtx11extras-dev libxcb-dev libx11-dev"
diff --git a/user/kiconthemes/APKBUILD b/user/kiconthemes/APKBUILD
index f4a15d494..737a01d40 100644
--- a/user/kiconthemes/APKBUILD
+++ b/user/kiconthemes/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Framework for icon theming"
url="https://www.kde.org/"
arch="all"
+options="!check" # requires X11 running
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev qt5-qtsvg-dev karchive-dev ki18n-dev
diff --git a/user/kitemmodels/APKBUILD b/user/kitemmodels/APKBUILD
index 1513e9359..fe22417ac 100644
--- a/user/kitemmodels/APKBUILD
+++ b/user/kitemmodels/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Framework for sorting and searching objects"
url="https://www.kde.org/"
arch="all"
+options="!check" # Test suite requires X11
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev"
diff --git a/user/kwallet/APKBUILD b/user/kwallet/APKBUILD
index 53cda14f4..9ff904ab5 100644
--- a/user/kwallet/APKBUILD
+++ b/user/kwallet/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kwallet
pkgver=5.41.0
-pkgrel=0
+pkgrel=1
pkgdesc="Secure storage system for passwords built atop Qt"
url="https://www.kde.org/"
arch="all"
@@ -14,7 +14,8 @@ depends_dev="qt5-qtbase-dev kcoreaddons-dev kconfig-dev kwindowsystem-dev
makedepends="$depends_dev cmake extra-cmake-modules kdoctools-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/${pkgver%.*}/kwallet-$pkgver.tar.xz"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/kwallet-$pkgver.tar.xz
+ kwallet-5.22.0-blowfish-endianness.patch"
builddir="$srcdir/kwallet-$pkgver"
build() {
@@ -43,4 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="572b1d145f7092ed8ca581a00ced425f6a6fa4d153853ec591bbe6f91c5851c8476356b907ea1808e93f881a9e24797e894e7621f5627eadaf086a7f92e89e74 kwallet-5.41.0.tar.xz"
+sha512sums="572b1d145f7092ed8ca581a00ced425f6a6fa4d153853ec591bbe6f91c5851c8476356b907ea1808e93f881a9e24797e894e7621f5627eadaf086a7f92e89e74 kwallet-5.41.0.tar.xz
+edca12963a5db9db05b3b4d581c1b970569f3b96dc672422e561c189c9024b69710732281f054514ce3d596688a5b0ba512766f4fd768eea8e00a18dcfd59179 kwallet-5.22.0-blowfish-endianness.patch"
diff --git a/user/kwallet/kwallet-5.22.0-blowfish-endianness.patch b/user/kwallet/kwallet-5.22.0-blowfish-endianness.patch
new file mode 100644
index 000000000..9d76cc25c
--- /dev/null
+++ b/user/kwallet/kwallet-5.22.0-blowfish-endianness.patch
@@ -0,0 +1,52 @@
+--- kwallet-5.29.0/src/runtime/kwalletd/backend/blowfish.cc.old 2016-12-03 21:12:17.000000000 +0000
++++ kwallet-5.29.0/src/runtime/kwalletd/backend/blowfish.cc 2017-01-29 18:02:10.193293280 +0000
+@@ -31,9 +31,7 @@
+
+ #include "blowfishtables.h"
+
+-// DO NOT INCLUDE THIS. IT BREAKS KWALLET.
+-// We need to live with -Wundef until someone really figures out the problem.
+-//#include <QtCore/qglobal.h> // for Q_BYTE_ORDER and friends
++#include <QtGlobal> // for Q_BYTE_ORDER and friends
+
+ BlowFish::BlowFish()
+ {
+@@ -135,7 +133,7 @@
+ return init();
+ }
+
+-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ #define shuffle(x) do { \
+ uint32_t r = x; \
+ x = (r & 0xff000000) >> 24; \
+@@ -154,12 +152,12 @@
+ }
+
+ for (int i = 0; i < len / _blksz; i++) {
+-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ shuffle(*d);
+ shuffle(*(d + 1));
+ #endif
+ encipher(d, d + 1);
+-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ shuffle(*d);
+ shuffle(*(d + 1));
+ #endif
+@@ -178,12 +176,12 @@
+ }
+
+ for (int i = 0; i < len / _blksz; i++) {
+-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ shuffle(*d);
+ shuffle(*(d + 1));
+ #endif
+ decipher(d, d + 1);
+-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ shuffle(*d);
+ shuffle(*(d + 1));
+ #endif
diff --git a/user/plasma-workspace/APKBUILD b/user/plasma-workspace/APKBUILD
index c018eef8c..c6b4dc276 100644
--- a/user/plasma-workspace/APKBUILD
+++ b/user/plasma-workspace/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=plasma-workspace
pkgver=5.8.7
-pkgrel=7
+pkgrel=8
pkgdesc="KDE Plasma 5 workspace"
url="https://www.kde.org/plasma-desktop"
arch="all"
@@ -30,7 +30,9 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/Attic/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
plasma-workspace-5.8-cmake-update.patch
plasma-workspace-5.8.7-disable-broken-test.patch
- plasma-workspace-5.8-honour-uint.patch"
+ plasma-workspace-5.8-honour-uint.patch
+ fix-crash-on-wallpaper-change.patch
+ "
builddir="$srcdir/plasma-workspace-$pkgver"
build() {
@@ -62,4 +64,5 @@ package() {
sha512sums="ba35a050384e0bf410097027bfb70ca7594cd5352fd6470228d537f4e876ec72ec26bac3be9a6750f306b1d2937ff53c267c2246f191c93a13972a0cf33b4faf plasma-workspace-5.8.7.tar.xz
3d7cfb1c7c54bcbca47c5c01497c776d54d1e2327bc0a3777cfaf001f44ec7c1863f15ab0586c00db6d7194f759b91d0a86e47ae99e7fa23782dd7deda264e47 plasma-workspace-5.8-cmake-update.patch
2151dab30716e0b2b6a9146fd6262f4f134884961bebe9cf9baee269f35b1b3955ed07dcee2602b5adc2fc93aa15d37cb72d6983f026a2b504feb451d944d965 plasma-workspace-5.8.7-disable-broken-test.patch
-48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch"
+48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch
+52ac2f37a7e1fde97385a372a4c198b573fb51fe1334bddf340c034ba0fbd2a97174d9bab9f9c8446048deb3a2c9ea3c571b0adcdb1f710b513b311c824ab88a fix-crash-on-wallpaper-change.patch"
diff --git a/user/plasma-workspace/fix-crash-on-wallpaper-change.patch b/user/plasma-workspace/fix-crash-on-wallpaper-change.patch
new file mode 100644
index 000000000..078a48e3a
--- /dev/null
+++ b/user/plasma-workspace/fix-crash-on-wallpaper-change.patch
@@ -0,0 +1,58 @@
+From a44d84ef47492ca60ee608996b5ab1f2849ef16e Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Mon, 14 Aug 2017 10:04:19 +0100
+Subject: Don't change fillMode of image just before deleting it
+
+It is still set for when a source is applied for the next
+transistion.
+
+Summary:
+This saves evaluating a new paintedSize and doing a bunch of evaluations
+which are not used.
+
+More importantly it works round a Qt animation crash.
+
+fadeAnim.running is bound to otherImage.status !== loading
+
+with the intention of delaying animations until the images are really
+loaded.
+
+By setting the fill mode and then the source, we go to loading and back,
+effectively restarting the animation from within the animation.
+This leads to a crash.
+
+CCBUG: 381105
+
+Test Plan:
+End user result is the same.
+
+Reviewers: #plasma, broulik, mart
+
+Reviewed By: #plasma, broulik, mart
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D7248
+---
+ wallpapers/image/imagepackage/contents/ui/main.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wallpapers/image/imagepackage/contents/ui/main.qml b/wallpapers/image/imagepackage/contents/ui/main.qml
+index fc22176..0539f37 100644
+--- a/wallpapers/image/imagepackage/contents/ui/main.qml
++++ b/wallpapers/image/imagepackage/contents/ui/main.qml
+@@ -193,8 +193,8 @@ Item {
+ }
+ ScriptAction {
+ script: {
+- otherImage.fillMode = fillMode;
+ otherImage.source = "";
++ otherImage.fillMode = fillMode;
+ }
+ }
+ }
+--
+cgit v0.11.2
+
diff --git a/user/quaternion/APKBUILD b/user/quaternion/APKBUILD
new file mode 100644
index 000000000..370e68900
--- /dev/null
+++ b/user/quaternion/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=quaternion
+pkgver=0.0.5
+_libver=0.2
+pkgrel=0
+pkgdesc="Qt5-based Matrix chat client"
+url="https://matrix.org/docs/projects/client/quaternion.html"
+arch="all"
+license="GPL-3.0"
+makedepends="cmake qt5-qtbase-dev qt5-qtdeclarative-dev"
+subpackages=""
+source="quaternion-$pkgver.tar.gz::https://github.com/QMatrixClient/Quaternion/archive/v$pkgver.tar.gz
+ libqmatrixclient-$_libver.tar.gz::https://github.com/QMatrixClient/libqmatrixclient/archive/v0.2-q0.0.5.tar.gz
+ install-library.patch
+ "
+builddir="$srcdir/Quaternion-$pkgver"
+
+unpack() {
+ default_unpack
+ mv "$srcdir"/libqmatrixclient-$_libver-q$pkgver/* "$builddir"/lib/
+}
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ for i in "$builddir" "$builddir"/lib; do
+ cd $i
+ make DESTDIR="$pkgdir" install
+ done
+}
+
+sha512sums="ec4a6196ff687d08de49f47141a7869e8d0c56eee142a70682bd9880eb5ae8fb96c38616eec0d61b250a3f0a4cf358debeaa7c001f8dc88c58367bd0d125cb93 quaternion-0.0.5.tar.gz
+3065793171ee60b5bc325756b9c82a57db0e4993b608d080ed6f54e9c55a835a594cf519681aede3063d0126c6f778ac885ab301569d25970aa22b7aa85bdadb libqmatrixclient-0.2.tar.gz
+a814970d408bf43706c20f01a39b1503c5054efc5e8c36aadae36fd7a028e9ed286c79b846d960ca0c4791be463a5aa33ecf7a09d5dd6e87268af79b791fe58d install-library.patch"
diff --git a/user/quaternion/install-library.patch b/user/quaternion/install-library.patch
new file mode 100644
index 000000000..66fb1615c
--- /dev/null
+++ b/user/quaternion/install-library.patch
@@ -0,0 +1,9 @@
+--- Quaternion-0.0.5/lib/CMakeLists.txt.old 2017-12-21 00:41:34.000000000 -0600
++++ Quaternion-0.0.5/lib/CMakeLists.txt 2017-12-30 16:33:32.858838009 -0600
+@@ -100,3 +100,6 @@
+ install (FILES mime/packages/freedesktop.org.xml
+ DESTINATION mime/packages)
+ endif (WIN32)
++
++install (TARGETS qmatrixclient
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/user/xmlsec/APKBUILD b/user/xmlsec/APKBUILD
new file mode 100644
index 000000000..4a3b752ed
--- /dev/null
+++ b/user/xmlsec/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname="xmlsec"
+pkgver=1.2.25
+pkgrel=0
+pkgdesc="C-based XML signature and encryption syntax and processing library"
+url="https://github.com/lsh123/${pkgname}/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="${depends_dev} libxml2-dev libxslt-dev openssl-dev nss-dev
+ autoconf automake libtool"
+install=""
+options="libtool"
+subpackages="$pkgname-nss $pkgname-dev $pkgname-doc"
+source="${url}/archive/${pkgname}-${pkgver//./_}.tar.gz"
+builddir="${srcdir}/${pkgname}-${pkgname}-${pkgver//./_}"
+
+prepare() {
+ cd "${builddir}"
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ cd "${builddir}"
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix='/usr' \
+ --disable-static \
+ --enable-pkgconfig \
+ --with-openssl=/usr \
+ --without-gnutls \
+ --without-gcrypt \
+ --with-default-crypto='openssl'
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make -k check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+nss() {
+ pkgdesc="xmlsec NSS plugin"
+ install_if="$pkgname=$pkgver-r$pkgrel nss"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libxmlsec1-nss.so* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz"