summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/analitza/APKBUILD8
-rw-r--r--user/analitza/pmmx-test-failure.patch14
-rw-r--r--user/apache-httpd/APKBUILD3
-rw-r--r--user/dosbox/APKBUILD36
-rw-r--r--user/dosbox/asmfix.patch11
-rw-r--r--user/dosbox/porttalk-fix.patch15
-rw-r--r--user/dosbox/posix-headers.patch10
-rw-r--r--user/glfw/APKBUILD49
-rw-r--r--user/ktorrent/APKBUILD1
-rw-r--r--user/libktorrent/APKBUILD1
-rw-r--r--user/mac-fdisk/APKBUILD8
-rw-r--r--user/mac-fdisk/mac-fdisk-0.1-debian.patch15
-rw-r--r--user/mac-fdisk/mac-fdisk-0.1-more-arches.patch67
-rw-r--r--user/mac-fdisk/mac-fdisk-amd64.patch29
-rw-r--r--user/minivmac/APKBUILD29
-rw-r--r--user/thunderbird/APKBUILD2
-rw-r--r--user/thunderbird/stackwalk-x86-ppc.patch16
17 files changed, 262 insertions, 52 deletions
diff --git a/user/analitza/APKBUILD b/user/analitza/APKBUILD
index 2c562f252..f2d0dde57 100644
--- a/user/analitza/APKBUILD
+++ b/user/analitza/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=analitza
pkgver=17.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="Mathematical object library"
url="https://api.kde.org/4.x-api/kdeedu-apidocs/analitza/html/index.html"
arch="all"
@@ -12,7 +12,8 @@ depends_dev="qt5-qtbase-dev qt5-qtsvg-dev qt5-qtdeclarative-dev eigen-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev"
install=""
subpackages="$pkgname-dev $pkgname-lang"
-source="http://download.kde.org/stable/applications/$pkgver/src/analitza-$pkgver.tar.xz"
+source="http://download.kde.org/stable/applications/$pkgver/src/analitza-$pkgver.tar.xz
+ pmmx-test-failure.patch"
build() {
cd "$builddir"
@@ -40,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e326d397db3193492258f156cd71f63e4544abd9724b58769a1593ff57242b18de09291a433ea37658015bd57f75e430ed95bdf99d3863fccfc4b546a9686933 analitza-17.12.2.tar.xz"
+sha512sums="e326d397db3193492258f156cd71f63e4544abd9724b58769a1593ff57242b18de09291a433ea37658015bd57f75e430ed95bdf99d3863fccfc4b546a9686933 analitza-17.12.2.tar.xz
+c38ce1f8265224aebfa8dcf8ef93a83bb2abd4eb757add3a7578660753bf9f16cbd497c9d696f22a6345602585a06bf4bad2bd89b2ea75e70baf9f8739198da9 pmmx-test-failure.patch"
diff --git a/user/analitza/pmmx-test-failure.patch b/user/analitza/pmmx-test-failure.patch
new file mode 100644
index 000000000..6e1bce2d4
--- /dev/null
+++ b/user/analitza/pmmx-test-failure.patch
@@ -0,0 +1,14 @@
+diff --git a/analitza/commands/listcommands.cpp b/analitza/commands/listcommands.cpp
+index b77f49a9..2885169a 100644
+--- a/analitza/commands/listcommands.cpp
++++ b/analitza/commands/listcommands.cpp
+@@ -69,8 +69,9 @@ Expression RangeCommand::operator()(const QList<Analitza::Expression >& args)
+
+ Analitza::List *seq = new Analitza::List;
+
+- for (double x = a; x <= b; x += h)
++ for (double x = a; x < b || qFuzzyCompare(x, b); x += h) {
+ seq->appendBranch(new Analitza::Cn(x));
++ }
+
+ ret.setTree(seq);
diff --git a/user/apache-httpd/APKBUILD b/user/apache-httpd/APKBUILD
index f156f7094..4f4ea3414 100644
--- a/user/apache-httpd/APKBUILD
+++ b/user/apache-httpd/APKBUILD
@@ -66,7 +66,7 @@ build() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -j1 install
# apache-provided configuration is awful
rm "$pkgdir"/etc/apache2/*.conf
@@ -85,7 +85,6 @@ package() {
install -Dm644 "$srcdir"/apache-httpd.confd "$pkgdir"/etc/conf.d/apache-httpd
install -Dm644 "$srcdir"/apache-httpd.logrotate "$pkgdir"/etc/logrotate.d/apache-httpd
- install -d "$pkgdir"/var/www
install -dm2750 -g wheel "$pkgdir"/var/log/apache2
}
diff --git a/user/dosbox/APKBUILD b/user/dosbox/APKBUILD
new file mode 100644
index 000000000..88436520d
--- /dev/null
+++ b/user/dosbox/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=dosbox
+pkgver=0.82.7
+pkgrel=0
+pkgdesc="an emulator for MS-DOS games"
+url="https://github.com/joncampbell123/dosbox-x/"
+arch="all !s390x"
+options="!check" # dosbox does not ship tests
+subpackages=""
+license="GPL-2.0-only"
+depends=""
+makedepends="ncurses-dev zlib-dev libxkbfile-dev libpng-dev libpcap-dev fluidsynth-dev sdl2-dev alsa-lib-dev"
+source="https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-wip-20180513-1316.tar.gz
+ porttalk-fix.patch
+ asmfix.patch
+ posix-headers.patch
+ "
+builddir="$srcdir/dosbox-x-dosbox-x-wip-20180513-1316"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-debug --enable-core-inline --enable-sdl2
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="38b7423b695f3b0dfd26f8c8913f26afba73ea6235bb205ec3a5d7f08ef3c74a9b6ce2577f0ea8eb49724b548e3386332256d13f27469b165986702650638992 dosbox-x-wip-20180513-1316.tar.gz
+daf0efea03d6295f5a20d8d197f7d0ba38e0608edcfe8be19fc6091b783885d523557674f0f7df83b88186b77794723106cf7a0e02125d2cc75ecfd7d51fa91d porttalk-fix.patch
+266ede57d21030f7752287f18660b47e9185a9aef9d022337dded9c9ce93e572691b41aca878f8a28c67bf5d217c7e84912336c21aacf594085dc31d99862ebf asmfix.patch
+462e84d5bac8fb2c1317b303d1bdda72a50e9eedfb5251450cb8d0f98f4297d6a483eb2c95624cbc8d25e917788032dd1e7d8b0d06d82dad6600f8bd6eec85f4 posix-headers.patch"
diff --git a/user/dosbox/asmfix.patch b/user/dosbox/asmfix.patch
new file mode 100644
index 000000000..db341e42c
--- /dev/null
+++ b/user/dosbox/asmfix.patch
@@ -0,0 +1,11 @@
+--- dosbox-x-dosbox-x-wip-20180513-1316/src/cpu/core_dyn_x86/risc_x86.h 2018-05-13 19:52:17.000000000 +0000
++++ dosbox-x-dosbox-x-wip-20180513-1316/src/cpu/core_dyn_x86/risc_x86.h 2018-05-16 12:02:44.329617468 +0000
+@@ -130,7 +130,7 @@
+ #else
+ register Bit32u tempflags=reg_flags & FMASK_TEST;
+ __asm__ volatile (
+- "pushl $(run_return_adress) \n"
++ "call 1f ; 1: addl $run_return_adress-.,(%%esp) \n"
+ "pushl %2 \n"
+ "jmp *%3 \n"
+ "run_return_adress: \n"
diff --git a/user/dosbox/porttalk-fix.patch b/user/dosbox/porttalk-fix.patch
new file mode 100644
index 000000000..4cb4a6a0e
--- /dev/null
+++ b/user/dosbox/porttalk-fix.patch
@@ -0,0 +1,15 @@
+diff -Naur dosbox-x-dosbox-x-wip-20180513-1316/src/libs/porttalk/porttalk.cpp dosbox-x-dosbox-x-wip-20180513-1316-porttalk-fix/src/libs/porttalk/porttalk.cpp
+--- dosbox-x-dosbox-x-wip-20180513-1316/src/libs/porttalk/porttalk.cpp 2018-05-13 19:52:17.000000000 +0000
++++ dosbox-x-dosbox-x-wip-20180513-1316-porttalk-fix/src/libs/porttalk/porttalk.cpp 2018-05-16 12:40:17.232921780 +0000
+@@ -233,7 +233,11 @@
+ #ifdef LINUX
+ # if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
+ // This Linux ioperm only works up to port 0x3FF
++#if (__GNU_LIBRARY__ >= 6)
+ #include <sys/perm.h>
++#elif defined(__linux__) && !defined(__GLIBC__)
++#include <sys/io.h>
++#endif
+
+ bool initPorttalk() {
+ if(ioperm(0x3da,1,1) < 0) return false;
diff --git a/user/dosbox/posix-headers.patch b/user/dosbox/posix-headers.patch
new file mode 100644
index 000000000..3ed6bb07a
--- /dev/null
+++ b/user/dosbox/posix-headers.patch
@@ -0,0 +1,10 @@
+--- dosbox/src/dos/drive_local.cpp 2018-05-13 14:52:17.000000000 -0500
++++ dosbox/src/dos/drive_local.cpp 2018-05-27 02:24:20.057150551 -0500
+@@ -22,6 +22,7 @@
+ #include <string.h>
+ #include <time.h>
+ #include <errno.h>
++#include <limits.h>
+
+ #include "dosbox.h"
+ #include "dos_inc.h"
diff --git a/user/glfw/APKBUILD b/user/glfw/APKBUILD
new file mode 100644
index 000000000..f060ef75e
--- /dev/null
+++ b/user/glfw/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=glfw
+pkgver=3.2.1
+pkgrel=0
+pkgdesc="OpenGL desktop development library"
+url="http://www.glfw.org/"
+arch="all"
+options="!check" # Tests require X11, GL, and manual intervention.
+license="Zlib"
+depends=""
+depends_dev="mesa-dev"
+makedepends="$depends_dev cmake doxygen libx11-dev libxrandr-dev libxcursor-dev
+ libxinerama-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/glfw/glfw/releases/download/3.2.1/glfw-$pkgver.zip"
+sha512sums="73dd6d4a8d28a2b423f0fb25489659c1a845182b7ef09848d4f442cdc489528aea90f43ac84aeedb9d2301c4487f39782b647ee4959e67e83babb838372b980c glfw-3.2.1.zip"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_SHARED_LIBS=ON \
+ -DGLFW_BUILD_TESTS=OFF \
+ -DGLFW_BUILD_EXAMPLES=OFF \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -D -d "$builddir"/docs/html "$pkgdir"/usr/share/doc/$pkgname/
+}
+
diff --git a/user/ktorrent/APKBUILD b/user/ktorrent/APKBUILD
index 7a401cac9..610907026 100644
--- a/user/ktorrent/APKBUILD
+++ b/user/ktorrent/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="BitTorrent client by KDE"
url="https://www.kde.org/applications/internet/ktorrent/"
arch="all"
+options="!check" # Test requires X11.
license="GPL-2.0-only"
depends=""
makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtscript-dev kio-dev
diff --git a/user/libktorrent/APKBUILD b/user/libktorrent/APKBUILD
index 39d2b0cb7..3912b9a57 100644
--- a/user/libktorrent/APKBUILD
+++ b/user/libktorrent/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Torrent handling library for KDE"
url="https://www.kde.org/"
arch="all"
+options="!check" # All tests require X11
license="LGPL-2.1+"
depends=""
depends_dev="qt5-qtbase-dev karchive-dev kcrash-dev kio-dev solid-dev gmp-dev
diff --git a/user/mac-fdisk/APKBUILD b/user/mac-fdisk/APKBUILD
index 24d668c07..471279968 100644
--- a/user/mac-fdisk/APKBUILD
+++ b/user/mac-fdisk/APKBUILD
@@ -3,7 +3,7 @@
pkgname=mac-fdisk
pkgver=0.1.16
_pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc="68K and PowerPC fixed disk partitioning utility"
url="https://adelielinux.org/"
arch="all"
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc"
source="https://distfiles.adelielinux.org/source/mac-fdisk_0.1.orig.tar.gz
mac-fdisk-0.1-debian.patch
mac-fdisk-0.1-headers.patch
+ mac-fdisk-0.1-more-arches.patch
mac-fdisk-0.1_p16-ppc64.patch
mac-fdisk-0.1_p16-proper-inline.patch
mac-fdisk-amd64.patch
@@ -42,11 +43,12 @@ package() {
}
sha512sums="1263e60a18111162f5ef439b5f9615cef9de94e7836cb998782a6e6d3bcf92a69e49566b33c7330bdea05de5e6ca83f7920c6707f342ce515440160695f07120 mac-fdisk_0.1.orig.tar.gz
-64261af8f98ccae559d070545ad2bd1e09dd4538e6646913ffa9030a4594667498bf430896971a9de8116e445c698368eecaa9be77e44d539f1935af45eb461a mac-fdisk-0.1-debian.patch
+1d1073c4bbb6ff403130254d1ff8e1b045933c9b09e032a278bba47c50ccf1806d3c3280a818937e36942392da7b03091f00063d2bcf9f4f33cb57a8bb1166f0 mac-fdisk-0.1-debian.patch
7d16300c02b293de87101e3ef83a8b7778d15123c261d562f0129704b74d0c3d7ca18730c52d37b599ff57c0b70dacd41aeefe99cf235aea4abd4b569e3d601e mac-fdisk-0.1-headers.patch
+ddee905f118d4ffa2bae0c849470f45d31baa955ae344241496863f742f7b5e00a2d458e20542138be53472f4b396461ffbcd724e98c10ca155ef38c2d39f94b mac-fdisk-0.1-more-arches.patch
e521009d628934fe3925085c941d2bb3fba9c3322ccaaa6dd650ecbc6b990056f9bf186adb3a645dc8593efdb44611b69a7b6bf4e87d262870bbb515581e0ef3 mac-fdisk-0.1_p16-ppc64.patch
73b28195539a3e71b37e955f5f1e5cdc566ecf1c43a235b7689df235d84dec9d3807d3b5b49a506f758d7a1ff528388052bebfea58916381f2f0045eee350bac mac-fdisk-0.1_p16-proper-inline.patch
-241576f64dd334f98e8c9cb9e0b17b6366e208f2d0af47ddb4659cf2d8e25ca8f44a84d1f7fa2e5f6215f4be42668f43f034074ac981a0d87ca8483505a3623c mac-fdisk-amd64.patch
+162c5036e404519e57b63e1aee440bec4edca7fb7348efe985feeb37df9221d6829eaa601c8feb52c1ffd99cb8daf037dc93e161bb23c96927a65dd5e8b186d4 mac-fdisk-amd64.patch
d558d66fb91d845e09cca7c3832d2ec078581ed09574fb38d9476f0417901794ae70e4a284379977a5c50599ce9570da8359e321de91f9f77263601c090e501d mac-fdisk-fdisk-header-musl.patch
c9abc952f1ce618b085a134145fa99efa9c10b55f3fa773fb6b74a66468537bc3567ec632fe6e464c5158383135c858c171d8d94d7142d38beff39a17e31187a mac-fdisk-large-disk-support.patch
b5988eb6aa64324421398461396b0fdd0b55d7643094c042bea7264ec0f9913e8a793f3f550c15928419e697a14f2932f483c4b98a54618af99b35aa7ceae757 mac-fdisk-largerthan2gb.patch
diff --git a/user/mac-fdisk/mac-fdisk-0.1-debian.patch b/user/mac-fdisk/mac-fdisk-0.1-debian.patch
index 73a31354b..617dd8e70 100644
--- a/user/mac-fdisk/mac-fdisk-0.1-debian.patch
+++ b/user/mac-fdisk/mac-fdisk-0.1-debian.patch
@@ -403,21 +403,6 @@
+.\" Jakub Jelinek (jj@sunsite.mff.cuni.cz)
+.\" Andreas Neuper (ANeuper@GUUG.de)
+.\" and many others.
---- mac-fdisk-0.1.orig/fdisklabel.h
-+++ mac-fdisk-0.1/fdisklabel.h
-@@ -52,6 +52,12 @@
- #define BSD_LABELOFFSET 0
- #define BSD_BBSIZE 0
- #define BSD_SBSIZE 0
-+#elif defined (__mc68000__)
-+/* LABELSECTOR, LABELOFFSET, BBSIZE & SBSIZE are undefined for __powerpc__ */
-+#define BSD_LABELSECTOR 0
-+#define BSD_LABELOFFSET 0
-+#define BSD_BBSIZE 0
-+#define BSD_SBSIZE 0
- #else
- #error unknown architecture
- #endif
--- mac-fdisk-0.1.orig/fdisk.c
+++ mac-fdisk-0.1/fdisk.c
@@ -62,7 +62,6 @@
diff --git a/user/mac-fdisk/mac-fdisk-0.1-more-arches.patch b/user/mac-fdisk/mac-fdisk-0.1-more-arches.patch
new file mode 100644
index 000000000..086362844
--- /dev/null
+++ b/user/mac-fdisk/mac-fdisk-0.1-more-arches.patch
@@ -0,0 +1,67 @@
+--- mac-fdisk-0.1.orig/fdisklabel.h.old 1997-01-14 20:34:13.000000000 +0000
++++ mac-fdisk-0.1.orig/fdisklabel.h 2018-06-01 06:13:09.065722112 +0000
+@@ -35,27 +35,23 @@
+ #define BSD_MAXPARTITIONS 8
+ #define BSD_LINUX_BOOTDIR "/usr/ucb/mdec"
+
+-#if defined (i386)
++/* Thanks, util-linux! */
++#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__)
+ #define BSD_LABELSECTOR 1
+ #define BSD_LABELOFFSET 0
+-#define BSD_BBSIZE 8192 /* size of boot area, with label */
+-#define BSD_SBSIZE 8192 /* max size of fs superblock */
+-#elif defined (__alpha__)
+-#error LABELSECTOR, LABELOFFSET, BBSIZE & SBSIZE are undefined for __alpha__
+-#define BSD_LABELSECTOR 0
+-#define BSD_LABELOFFSET 0
+-#define BSD_BBSIZE 0
+-#define BSD_SBSIZE 0
+-#elif defined (__powerpc__)
+-/* LABELSECTOR, LABELOFFSET, BBSIZE & SBSIZE are undefined for __powerpc__ */
++#elif defined (__alpha__) || defined (__powerpc__) || defined (__ia64__) || defined (__hppa__)
+ #define BSD_LABELSECTOR 0
++#define BSD_LABELOFFSET 64
++#elif defined (__s390__) || defined (__s390x__)
++#define BSD_LABELSECTOR 1
+ #define BSD_LABELOFFSET 0
+-#define BSD_BBSIZE 0
+-#define BSD_SBSIZE 0
+ #else
+ #error unknown architecture
+ #endif
+
++#define BSD_BBSIZE 8192 /* size of boot area, with label */
++#define BSD_SBSIZE 8192 /* max size of fs superblock */
++
+ struct disklabel {
+ u_long d_magic; /* the magic number */
+ short d_type; /* drive type */
+--- mac-fdisk-0.1.orig/fdisklabel.c.old 2018-06-01 06:19:35.113347714 +0000
++++ mac-fdisk-0.1.orig/fdisklabel.c 2018-06-01 06:20:36.734576024 +0000
+@@ -82,10 +82,8 @@
+
+ static struct disklabel bsd_dlabel;
+ static char buffer[BSD_BBSIZE];
+-#if defined (i386)
+ static struct partition *bsd_part;
+ static int bsd_part_index;
+-#endif
+
+ void
+ bmenu (void)
+@@ -373,10 +371,11 @@
+ while (1)
+ if ((c = tolower (read_char ("Do you want to create a disklabel? (y/n) "))) == 'y')
+ {
+-#if defined (i386)
+- if (bsd_initlabel (bsd_part, &bsd_dlabel, bsd_part_index) == 1)
+-#elif defined (__alpha__) || defined (__powerpc__) || defined (__mc68000__)
++#if defined (__alpha__) || defined (__powerpc__) || defined (__hppa__) || \
++ defined (__s390__) || defined (__s390x__) || defined(__mc68000__)
+ if (bsd_initlabel (NULL, &bsd_dlabel, 0) == 1)
++#else
++ if (bsd_initlabel (bsd_part, &bsd_dlabel, bsd_part_index) == 1)
+ #endif
+ {
+ bsd_print_disklabel (1);
diff --git a/user/mac-fdisk/mac-fdisk-amd64.patch b/user/mac-fdisk/mac-fdisk-amd64.patch
index 8658ba9a6..236b037d9 100644
--- a/user/mac-fdisk/mac-fdisk-amd64.patch
+++ b/user/mac-fdisk/mac-fdisk-amd64.patch
@@ -9,15 +9,6 @@
static int bsd_translate_fstype (int linux_type);
static void bsd_link_part (void);
#endif
-@@ -82,7 +82,7 @@
-
- static struct disklabel bsd_dlabel;
- static char buffer[BSD_BBSIZE];
--#if defined (i386)
-+#if defined (i386) || defined (__amd64)
- static struct partition *bsd_part;
- static int bsd_part_index;
- #endif
@@ -99,13 +99,13 @@
" n add a new BSD partition\n"
" p print BSD partition table\n"
@@ -88,15 +79,6 @@
fprintf (stderr, "%s%d contains no disklabel.\n",
disk_device, bsd_part_index+1);
#elif defined (__alpha__) || defined (__powerpc__)
-@@ -376,7 +376,7 @@
- while (1)
- if ((c = tolower (read_char ("Do you want to create a disklabel? (y/n) "))) == 'y')
- {
--#if defined (i386)
-+#if defined (i386) || defined(__amd64)
- if (bsd_initlabel (bsd_part, &bsd_dlabel, bsd_part_index) == 1)
- #elif defined (__alpha__) || defined (__powerpc__) || defined (__mc68000__)
- if (bsd_initlabel (NULL, &bsd_dlabel, 0) == 1)
@@ -507,7 +507,7 @@
bcopy (&dl, d, sizeof (struct disklabel));
@@ -160,17 +142,6 @@
static int
bsd_translate_fstype (int linux_type)
{
---- a/fdisklabel.h
-+++ b/fdisklabel.h
-@@ -35,7 +35,7 @@
- #define BSD_MAXPARTITIONS 8
- #define BSD_LINUX_BOOTDIR "/usr/ucb/mdec"
-
--#if defined (i386)
-+#if defined (i386) || defined(__amd64)
- #define BSD_LABELSECTOR 1
- #define BSD_LABELOFFSET 0
- #define BSD_BBSIZE 8192 /* size of boot area, with label */
--- a/kernel-defs.h
+++ b/kernel-defs.h
@@ -15,8 +15,14 @@
diff --git a/user/minivmac/APKBUILD b/user/minivmac/APKBUILD
new file mode 100644
index 000000000..56e7814f4
--- /dev/null
+++ b/user/minivmac/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=minivmac
+pkgver=3.5.8
+pkgrel=1
+pkgdesc="a simple and accurate emulator of early Macintosh computers"
+url="http://www.gryphel.com/c/minivmac/"
+arch="all !s390x"
+options="!check" # minivmac does not ship a test suite
+license="GPL-2.0-only"
+depends=""
+makedepends="libx11-dev libxcb-dev libxau-dev libbsd-dev libxdmcp-dev"
+source="http://oddball.tech/code/emu_pkg/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ CARCH=$CARCH ./configure
+ cd "$builddir"/mnvmplus
+ make -j1
+ cd "$builddir"/mnvmII
+ make -j1
+}
+
+package() {
+ install -D -m755 "$builddir"/mnvmplus/minivmac "$pkgdir"/usr/bin/minivmac
+ install -m755 "$builddir"/mnvmII/minivmac "$pkgdir"/usr/bin/minivmacII
+}
+
+sha512sums="ff28266641dd37df74c84c16c8bf32282729d55ae6512d4a98abf92ba40692f9fc107b501f072755ba0f8a0322d4f755915d9be74a407ce89af94bfd24d11043 minivmac-3.5.8.tar.xz"
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 782061ea3..f516c34be 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -32,6 +32,7 @@ source="https://archive.mozilla.org/pub/thunderbird/releases/$pkgver/source/thun
profiler.patch
proper-system-hunspell.patch
stab.h
+ stackwalk-x86-ppc.patch
thunderbird.desktop
"
somask="liblgpllibs.so
@@ -87,4 +88,5 @@ sha512sums="80742c95ed61d1cb2e72b71bb23bdd211a40240ab4393e9f028a38f902547372084a
7e72b96196f51cc02478f1802a10b1c1754db09d7d35aef697c5dcaace107e7a45a1b97256cc98b4aa728845694be093b148b61868e8ebfc8317fea19d6c71fa profiler.patch
63b09028262a109e3a02f928c12323793df65dbd6d5605ddc315978b50ff4b50f6d1af410dc7c00538c80009a8721900c6320b166c8aa9bc6dce170ebcd6fc91 proper-system-hunspell.patch
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+d620a1efa4b079ce082a27cfacbae275aceb3d268fd44bfd3f4b742b8098c8e1b1733edd360404c5109137c508b8426ed9e1ca1036b11752de8d1f429bf14844 stackwalk-x86-ppc.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"
diff --git a/user/thunderbird/stackwalk-x86-ppc.patch b/user/thunderbird/stackwalk-x86-ppc.patch
new file mode 100644
index 000000000..9428e7238
--- /dev/null
+++ b/user/thunderbird/stackwalk-x86-ppc.patch
@@ -0,0 +1,16 @@
+--- thunderbird-52.6.0/mozilla/mozglue/misc/StackWalk.cpp
++++ thunderbird-52.6.0/mozilla/mozglue/misc/StackWalk.cpp
+@@ -41,13 +41,7 @@ static CriticalAddress gCriticalAddress;
+ #define MOZ_STACKWALK_SUPPORTS_MACOSX 0
+ #endif
+
+-#if (defined(linux) && \
+- ((defined(__GNUC__) && (defined(__i386) || defined(PPC))) || \
+- defined(HAVE__UNWIND_BACKTRACE)))
+-#define MOZ_STACKWALK_SUPPORTS_LINUX 1
+-#else
+ #define MOZ_STACKWALK_SUPPORTS_LINUX 0
+-#endif
+
+ #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
+ #define HAVE___LIBC_STACK_END 1