summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/xhost/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/xhost/APKBUILD b/user/xhost/APKBUILD
new file mode 100644
index 000000000..f263a2a79
--- /dev/null
+++ b/user/xhost/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=xhost
+pkgver=1.0.7
+pkgrel=1
+pkgdesc="Controls host and/or user access to a running X server"
+url="https://www.X.Org/"
+arch="all"
+options="!check" # No test suite.
+license="MIT X11"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libx11-dev libxmu-dev libxau-dev util-macros"
+source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="670a8c97291565f6c36c94e135f7bd60a572bb42b4fca9d2460823db0d0576187c64f9b876ed60d348029d3f74a732862eea4ce889a6b6b9c97665746a38b1d7 xhost-1.0.7.tar.bz2"