summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/py3-pyphen/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/py3-pyphen/APKBUILD b/user/py3-pyphen/APKBUILD
new file mode 100644
index 000000000..247ae0827
--- /dev/null
+++ b/user/py3-pyphen/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+pkgname=py3-pyphen
+pkgver=0.9.5
+pkgrel=0
+pkgdesc="Pure-Python library for hyphenation"
+url="http://pyphen.org"
+arch="noarch"
+license="GPL-2.0+ AND LGPL-2.1+ AND MPL-1.1"
+depends="python3"
+makedepends=""
+source="py3-pyphen-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
+builddir="$srcdir/Pyphen-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="049a62b226e90e568c8f56e756f8fa6fbc74f3bc40d61af8eb05ff2d4404a7b29cef14d4f144d68ed2f2b11eb128491de64536240ba7b76a2d04010c76e10346 py3-pyphen-0.9.5.tar.gz"