summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/btrfs-progs/APKBUILD4
-rw-r--r--user/horizon/APKBUILD11
-rw-r--r--user/horizon/bootloader.patch94
-rw-r--r--user/imlib2/APKBUILD8
-rw-r--r--user/mbuffer/APKBUILD36
-rw-r--r--user/mbuffer/test-static-file-instead.patch11
6 files changed, 57 insertions, 107 deletions
diff --git a/user/btrfs-progs/APKBUILD b/user/btrfs-progs/APKBUILD
index e8412ef96..c2c423ff8 100644
--- a/user/btrfs-progs/APKBUILD
+++ b/user/btrfs-progs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=btrfs-progs
-pkgver=5.7
+pkgver=5.9
pkgrel=0
pkgdesc="File system utilities for Btrfs"
url="https://btrfs.wiki.kernel.org/index.php/Main_Page"
@@ -31,4 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="72c3af13ca589f2e0b96cb7602319035ef8aab6ee224fff3544a5d0bfc013a66552dde4533ec5e64696d404b8905431cd0f25367c40fd34ea39be7c0ed8c2d16 btrfs-progs-v5.7.tar.xz"
+sha512sums="38db047198ab0467d3fe235f7e8e1fd14ade00dd0b182588220c5f5e4b598efbdcd30a3d5d56cf0a0ed8a902d2374af0927eb7f3720cd761172c7291a2a65c94 btrfs-progs-v5.9.tar.xz"
diff --git a/user/horizon/APKBUILD b/user/horizon/APKBUILD
index b49640561..8d2e480c2 100644
--- a/user/horizon/APKBUILD
+++ b/user/horizon/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=horizon
-pkgver=0.9.5
-pkgrel=1
+pkgver=0.9.6
+pkgrel=0
pkgdesc="Installation tools for Adélie Linux"
url="https://horizon.adelielinux.org/"
arch="all"
@@ -17,9 +17,7 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages="$pkgname-image $pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-qt5
$pkgname-tools $pkgname-wizard $pkgname-boot"
-source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz
- bootloader.patch
- "
+source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -158,5 +156,4 @@ GLOBALS
"$subpkgdir"/usr/share/xsessions/horizon.desktop
}
-sha512sums="373cbf87aa468d0ea41abad07f61cdaa6088cfdcba13c0beff245dbd8e270aa42c3e301a22913299d148e829114bd0b5aa746541c4b4b0c7286da35015c54d88 horizon-0.9.5.tar.xz
-88e7c6df4dc2c8c7f6befd5f96f82267fefccb98d0c5e6c26c611323e505f7ee964dcfd2128dbe165c064d953e7afef2787ab49a6c4a834ffe8fd50c00eb26ae bootloader.patch"
+sha512sums="d5ffe9bd423e98272ca780c59e6e32c42b284c68f3a0bace07bd693d457e2edcd68d7fc03f638b545960154ea26b7c09feee083dbffa986da2a7cd418be9500f horizon-0.9.6.tar.xz"
diff --git a/user/horizon/bootloader.patch b/user/horizon/bootloader.patch
deleted file mode 100644
index a09b4a603..000000000
--- a/user/horizon/bootloader.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 3658104dcc622e69a64cf97fbc9ed477f3faed6c Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Wed, 30 Sep 2020 19:19:59 -0500
-Subject: [PATCH] meta: Run update-boot when bootloader requested
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-If the user chooses no-boot or isn't installing Adélie, this will fail
-quietly. But if the user is installing Adélie, this is necessary to
-generate bootloader configuration.
----
- hscript/meta.cc | 26 ++++++++++++++++++++------
- 1 file changed, 20 insertions(+), 6 deletions(-)
-
-diff --git a/hscript/meta.cc b/hscript/meta.cc
-index 4efdc80..84e851a 100644
---- a/hscript/meta.cc
-+++ b/hscript/meta.cc
-@@ -823,7 +823,7 @@ bool Bootloader::execute() const {
- << std::endl
- << "chroot " << script->targetDirectory()
- << " grub-install " << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -851,8 +851,8 @@ bool Bootloader::execute() const {
- mount(nullptr, efipath.c_str(), nullptr,
- MS_REMOUNT | MS_BIND | MS_RDONLY | MS_NOEXEC | MS_NODEV |
- MS_NOSUID | MS_RELATIME, nullptr);
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
- else if(method == "grub-bios") {
- if(script->options().test(Simulate)) {
-@@ -861,7 +861,7 @@ bool Bootloader::execute() const {
- << std::endl
- << "chroot " << script->targetDirectory()
- << " grub-install " << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -876,8 +876,8 @@ bool Bootloader::execute() const {
- output_error(pos, "bootloader: failed to install GRUB");
- return false;
- }
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
- else if(method == "iquik") {
- output_error(pos, "bootloader: iQUIK is not yet supported");
-@@ -891,7 +891,7 @@ bool Bootloader::execute() const {
- << "chroot " << script->targetDirectory()
- << " grub-install --macppc-directory=/boot/grub "
- << _device << std::endl;
-- return true;
-+ goto updateboot;
- }
- #ifdef HAS_INSTALL_ENV
- if(run_command("/sbin/apk",
-@@ -907,9 +907,23 @@ bool Bootloader::execute() const {
- output_error(pos, "bootloader: failed to install GRUB");
- return false;
- }
-+ goto updateboot;
- #endif /* HAS_INSTALL_ENV */
-- return true; /* LCOV_EXCL_LINE */
- }
-
- return false; /* LCOV_EXCL_LINE */
-+
-+updateboot:
-+ /* We ignore if update-boot fails, in case the user has chosen no-boot. */
-+ if(script->options().test(Simulate)) {
-+ std::cout << "chroot " << script->targetDirectory()
-+ << " /usr/sbin/update-boot || true" << std::endl;
-+ }
-+#ifdef HAS_INSTALL_ENV
-+ else {
-+ run_command("chroot",
-+ {script->targetDirectory(), "/usr/sbin/update-boot"});
-+ }
-+#endif /* HAS_INSTALL_ENV */
-+ return true;
- }
---
-2.25.4
-
diff --git a/user/imlib2/APKBUILD b/user/imlib2/APKBUILD
index 09733a11b..918ffcf07 100644
--- a/user/imlib2/APKBUILD
+++ b/user/imlib2/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Nathan <ndowens@artixlinux.org>
pkgname=imlib2
-pkgver=1.6.1
-pkgrel=2
+pkgver=1.7.0
+pkgrel=0
pkgdesc="Image manipulation library"
url="https://sourceforge.net/projects/enlightenment"
arch="all"
@@ -41,4 +41,4 @@ package() {
make DESTDIR=$pkgdir install
}
-sha512sums="ecdbdbfe8767ec2b1f22ce664cbab5e1d3f75be7a3c8f37488f5243b3c31dbc433414b8d50d2d1b70c67a80e31e42cc5398161991ce3955e991c114c82ddd58f imlib2-1.6.1.tar.bz2"
+sha512sums="078126269565b55f4b167608ee65d558711e37c34283fb6193752b27f7fc59c738cbd38839b17203273defee20c2ffc41a495e44364089deebffbd39c67e6d72 imlib2-1.7.0.tar.bz2"
diff --git a/user/mbuffer/APKBUILD b/user/mbuffer/APKBUILD
new file mode 100644
index 000000000..fbcaeaeb9
--- /dev/null
+++ b/user/mbuffer/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: CyberLeo <cyberleo@cyberleo.net>
+# Maintainer: CyberLeo <cyberleo@cyberleo.net>
+pkgname=mbuffer
+pkgver=20200929
+pkgrel=0
+pkgdesc="mbuffer is a tool for buffering data streams."
+url="http://www.maier-komor.de/mbuffer.html"
+arch="all"
+license="GPL-3.0-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="http://www.maier-komor.de/software/mbuffer/mbuffer-$pkgver.tgz
+ test-static-file-instead.patch"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="332106205ea8743c9cf47529106c04ac15801a02b116d8e0c0fd3baadad51331c9f4ba1c8fa125edb42940cf401048a45ba23e2dac0e5189671bcf0ecee36996 mbuffer-20200929.tgz
+28b7c7c7ee2b2130315cd6c4765d492e9d29376670a03ab0a1ab862a1ec5dea93e91e9de5e08604db69fe4139370eedb2a0754f16e5ebec3de9b48dc2a1dbea7 test-static-file-instead.patch"
diff --git a/user/mbuffer/test-static-file-instead.patch b/user/mbuffer/test-static-file-instead.patch
new file mode 100644
index 000000000..9c549bfaa
--- /dev/null
+++ b/user/mbuffer/test-static-file-instead.patch
@@ -0,0 +1,11 @@
+--- mbuffer-20200929/Makefile.in.orig 2020-11-08 07:47:44.512670020 +0000
++++ mbuffer-20200929/Makefile.in 2020-11-08 07:48:33.032115323 +0000
+@@ -101,7 +101,7 @@
+ test.tar test.md5 mbuffer.md5 idev.so tapetest.so have-af
+
+ test.tar:
+- $(TAR) cf test.tar --ignore-failed-read $(TESTTREE)
++ truncate -s 10M test.tar
+
+ test.md5: test.tar
+ openssl md5 < test.tar > test.md5