summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/ae_fonts/APKBUILD27
-rw-r--r--user/alegreya-sans/APKBUILD4
-rw-r--r--user/alegreya/APKBUILD22
-rw-r--r--user/andika/APKBUILD22
-rw-r--r--user/anonymous-pro/APKBUILD22
-rw-r--r--user/baekmuk-ttf/APKBUILD21
-rw-r--r--user/boost/APKBUILD2
-rw-r--r--user/cantarell-fonts/APKBUILD10
-rw-r--r--user/cardo/APKBUILD22
-rw-r--r--user/cdrtools/APKBUILD2
-rw-r--r--user/cifs-utils/APKBUILD53
-rw-r--r--user/cifs-utils/musl-fix-includes.patch11
-rw-r--r--user/cifs-utils/xattr_size_max.patch32
-rw-r--r--user/clearsans/APKBUILD22
-rw-r--r--user/cm-unicode/APKBUILD21
-rw-r--r--user/comic-neue/APKBUILD22
-rw-r--r--user/courier-prime/APKBUILD21
-rw-r--r--user/dialog/APKBUILD2
-rw-r--r--user/faad2/APKBUILD2
-rw-r--r--user/fltk/APKBUILD4
-rw-r--r--user/freecell-solver/APKBUILD4
-rw-r--r--user/hyphen/APKBUILD2
-rw-r--r--user/i3wm/APKBUILD4
-rw-r--r--user/ido/APKBUILD2
-rw-r--r--user/imake/APKBUILD2
-rw-r--r--user/kolourpaint/APKBUILD2
-rw-r--r--user/libart-lgpl/APKBUILD2
-rw-r--r--user/libtirpc/APKBUILD2
-rw-r--r--user/lynx/APKBUILD2
-rw-r--r--user/nmap/APKBUILD87
-rw-r--r--user/ode/APKBUILD2
-rw-r--r--user/openal-soft/APKBUILD4
-rw-r--r--user/perl-extutils-depends/APKBUILD4
-rw-r--r--user/plasma-desktop/APKBUILD2
-rw-r--r--user/qps/APKBUILD2
-rw-r--r--user/talloc/APKBUILD53
-rw-r--r--user/talloc/waf-location.patch10
-rw-r--r--user/trojita/APKBUILD2
38 files changed, 498 insertions, 34 deletions
diff --git a/user/ae_fonts/APKBUILD b/user/ae_fonts/APKBUILD
new file mode 100644
index 000000000..c5f66b6ab
--- /dev/null
+++ b/user/ae_fonts/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=ae_fonts
+pkgver=2.0
+pkgrel=0
+pkgdesc="Arabeyes fonts"
+url="https://www.arabeyes.org/Khotot"
+arch="noarch"
+options="!check" # No test suite.
+license="GPL-2.0-only WITH Font-exception-2.0"
+depends=""
+makedepends=""
+subpackages=""
+source="https://downloads.sourceforge.net/arabeyes/ae_fonts_$pkgver.tar.bz2"
+builddir="$srcdir"/${pkgname}_$pkgver
+
+package() {
+ cd "$builddir"
+ local _fontdir
+ for _fontdir in AAHS AGA FS Kasr MCS Shmookh; do
+ pushd $_fontdir
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+ popd
+ done
+}
+
+sha512sums="46c94aa1ce872aa1ad4dd01d698d4691a6301786f8be681723df9bdcdfb86db12b15bef2a6acfed704b29867e9c01e385b4c2c490548ce68f7994b8127a9270e ae_fonts_2.0.tar.bz2"
diff --git a/user/alegreya-sans/APKBUILD b/user/alegreya-sans/APKBUILD
index e0649ef1e..f14a5f467 100644
--- a/user/alegreya-sans/APKBUILD
+++ b/user/alegreya-sans/APKBUILD
@@ -15,8 +15,8 @@ source="Alegreya-Sans-$pkgver.tar.gz::https://github.com/huertatipografica/Alegr
builddir="$srcdir/Alegreya-Sans-$pkgver"
package() {
- cd "$builddir"/fonts/ttf
- install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF *.ttf
+ cd "$builddir"/fonts/otf
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ *.otf
}
sha512sums="8052fe15717ecdfd301d878b03282ff4fd472a7e13a1e581c84d6f3993780897354d103aeda2f027350d9e56466914be38e97417fe450ec32e5823769015d0a4 Alegreya-Sans-2.008.tar.gz"
diff --git a/user/alegreya/APKBUILD b/user/alegreya/APKBUILD
new file mode 100644
index 000000000..12e45aa4f
--- /dev/null
+++ b/user/alegreya/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=alegreya
+pkgver=2.007
+pkgrel=0
+pkgdesc="Alegreya serif typeface"
+url="https://www.huertatipografica.com/en/fonts/alegreya-ht-pro"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="Alegreya-$pkgver.tar.gz::https://github.com/huertatipografica/Alegreya/archive/v$pkgver.tar.gz"
+builddir="$srcdir/Alegreya-$pkgver"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ fonts/otf/*.otf
+}
+
+sha512sums="7220aaf9f9861ed4f3104aeb16f33267b5cc2139b91ddafbd7ff86f94faeb37bca558c642a03108094d0a60f9db77167c19996fdaeeca3fcac0346205ba4e785 Alegreya-2.007.tar.gz"
diff --git a/user/andika/APKBUILD b/user/andika/APKBUILD
new file mode 100644
index 000000000..5d385c71b
--- /dev/null
+++ b/user/andika/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=andika
+pkgver=5.000
+pkgrel=0
+pkgdesc="Sans-serif typeface designed for literacy and beginning readers"
+url="https://software.sil.org/andika/"
+arch="noarch"
+options="!check" # No test suite
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://software.sil.org/downloads/r/andika/Andika-5.000.zip"
+builddir="$srcdir/Andika-5.000"
+
+package() {
+ cd "$builddir"
+ install -D -m644 Andika-R.ttf "$pkgdir"/usr/share/fonts/X11/TTF/Andika-R.ttf
+}
+
+sha512sums="e1cf195a523aa70b464889bdcee0c9606c82eef0da658861329c4c142ae25f14f1e3feea1118219fe7e9b5c13965c4ed09ac7507d746a1f2c77e402957c7d3d5 Andika-5.000.zip"
diff --git a/user/anonymous-pro/APKBUILD b/user/anonymous-pro/APKBUILD
new file mode 100644
index 000000000..5d4ece60c
--- /dev/null
+++ b/user/anonymous-pro/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=anonymous-pro
+pkgver=1.002
+pkgrel=0
+pkgdesc="Fixed-width (monospace) font designed for programming"
+url="https://www.marksimonson.com/fonts/view/anonymous-pro"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://www.marksimonson.com/assets/content/fonts/AnonymousPro-$pkgver.zip"
+builddir="$srcdir/AnonymousPro-1.002.001"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+}
+
+sha512sums="7606d520ad79fbf4e13d676c1aff61b764dce74e170f8783b8e606f7907c4b8db0871e5568504d15aa23ca26e925ada4eb6b60fcf27171dccee0d3d32d9a92a1 AnonymousPro-1.002.zip"
diff --git a/user/baekmuk-ttf/APKBUILD b/user/baekmuk-ttf/APKBUILD
new file mode 100644
index 000000000..28b840f6b
--- /dev/null
+++ b/user/baekmuk-ttf/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=baekmuk-ttf
+pkgver=2.2
+pkgrel=0
+pkgdesc="'Baekmuk' (Chalk) Korean typeface"
+url="http://kldp.net/baekmuk/"
+arch="noarch"
+options="!check" # No test suite.
+license="BSD-1-Clause"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="http://kldp.net/baekmuk/release/865-baekmuk-ttf-$pkgver.tar.gz"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ ttf/*.ttf
+}
+
+sha512sums="779e0bef5fe17e08e0e08ccdad9ad0e91123a5d5cbcb3d66256d517a0903c5fd91c4a8c75eb42f82fcb0d82e26455cf13aeec5ba3a04002133dbbaf1357ec14b 865-baekmuk-ttf-2.2.tar.gz"
diff --git a/user/boost/APKBUILD b/user/boost/APKBUILD
index e526129df..87bbc0827 100644
--- a/user/boost/APKBUILD
+++ b/user/boost/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.62.0
_pkgver="${pkgver//./_}"
pkgrel=7
pkgdesc="Free peer-reviewed portable C++ source libraries"
-url="http://www.boost.org/"
+url="https://www.boost.org/"
arch="all"
license="BSL-1.0"
options="!check" # No test suite.
diff --git a/user/cantarell-fonts/APKBUILD b/user/cantarell-fonts/APKBUILD
index 1d0aa9876..b5fec057f 100644
--- a/user/cantarell-fonts/APKBUILD
+++ b/user/cantarell-fonts/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=cantarell-fonts
pkgver=0.111
-pkgrel=0
-pkgdesc="Humanist sans-serif typeface from GNOME"
+pkgrel=1
+pkgdesc="Humanist sans-serif typeface, designed for GNOME Shell"
url=" "
arch="noarch"
options="!check" # Impossible to test font
@@ -15,12 +15,8 @@ replaces="ttf-cantarell"
source="https://download.gnome.org/sources/cantarell-fonts/$pkgver/cantarell-fonts-$pkgver.tar.xz"
package() {
- local _otf
cd "$builddir"/prebuilt
- mkdir -p "$pkgdir"/usr/share/fonts/$pkgname
- for _otf in *.otf; do
- install -m644 "$_otf" "$pkgdir"/usr/share/fonts/$pkgname/$_otf
- done
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ *.otf
}
sha512sums="638298a6381a3ede862d1b100fcfea943bebb5e1c0dc4f1597ab2f841e933b484436b139090a669c770c02483a24f2b92bbd12bce71d7a40eb4c325573e3df9e cantarell-fonts-0.111.tar.xz"
diff --git a/user/cardo/APKBUILD b/user/cardo/APKBUILD
new file mode 100644
index 000000000..7af7e9f04
--- /dev/null
+++ b/user/cardo/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=cardo
+pkgver=1.04
+pkgrel=0
+pkgdesc="Unicode font designed for scholars and linguists"
+url="http://scholarsfonts.net/cardofnt.html"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="http://scholarsfonts.net/cardo104.zip"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+}
+
+sha512sums="559d91528dfebba1c0668ab0116e7cc8d481c88727cf01848978d920d625ee32c893d6abff3170e5365e136fa6f603c4f34390e17383409bc3db01611c42eefb cardo104.zip"
diff --git a/user/cdrtools/APKBUILD b/user/cdrtools/APKBUILD
index 0145aa351..39a3021c8 100644
--- a/user/cdrtools/APKBUILD
+++ b/user/cdrtools/APKBUILD
@@ -4,7 +4,7 @@ pkgname=cdrtools
pkgver=3.01
pkgrel=1
pkgdesc="Highly portable CD/DVD/Blu-Ray command line recording software"
-url="http://cdrecord.sourceforge.net/private/cdrecord.html"
+url="http://schilytools.sourceforge.net/"
arch="all"
options="suid"
license="CDDL-1.0"
diff --git a/user/cifs-utils/APKBUILD b/user/cifs-utils/APKBUILD
new file mode 100644
index 000000000..f5987a037
--- /dev/null
+++ b/user/cifs-utils/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=cifs-utils
+pkgver=6.8
+pkgrel=0
+pkgdesc="CIFS filesystem user-space tools"
+url="https://wiki.samba.org/index.php/LinuxCIFS_utils"
+arch="all"
+options="!check suid" # No test suite.
+license="GPL-3.0+ AND GPL-2.0+ AND LGPL-3.0+"
+depends=""
+makedepends="keyutils-dev krb5-dev libcap-ng-dev linux-pam-dev
+ py3-docutils talloc-dev"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://ftp.samba.org/pub/linux-cifs/$pkgname/$pkgname-$pkgver.tar.bz2
+ musl-fix-includes.patch
+ xattr_size_max.patch"
+
+build() {
+ cd "$builddir"
+ # --enable-cifsidmap and --enable-cifsacl require libwbclient (samba)
+
+ autoreconf -i
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-cifsidmap=no \
+ --enable-cifsacl=no
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+ # Allow unprivileged mount
+ chmod u+s "$pkgdir"/sbin/mount.cifs
+}
+
+sha512sums="54a094f78c9e07acc997adfe0c8d4c2fb8e15c18adcc1805450e2180f8539aaec8619e781e985b289e097932637e2de3e6815e32f59ec2fc06cfc3762b832e13 cifs-utils-6.8.tar.bz2
+99a2fab05bc2f14a600f89526ae0ed2c183cfa179fe386cb327075f710aee3aed5ae823f7c2f51913d1217c2371990d6d4609fdb8d80288bd3a6139df3c8aebe musl-fix-includes.patch
+2a9366ec1ddb0389c535d2fa889f63287cb8374535a47232de102c7e50b6874f67a3d5ef3318df23733300fd8459c7ec4b11f3211508aca7800b756119308e98 xattr_size_max.patch"
diff --git a/user/cifs-utils/musl-fix-includes.patch b/user/cifs-utils/musl-fix-includes.patch
new file mode 100644
index 000000000..c7b9b004f
--- /dev/null
+++ b/user/cifs-utils/musl-fix-includes.patch
@@ -0,0 +1,11 @@
+--- cifs-utils-6.2.orig/mount.h
++++ cifs-utils-6.2/mount.h
+@@ -20,6 +20,8 @@
+ #ifndef _MOUNT_H_
+ #define _MOUNT_H_
+
++#include <paths.h>
++
+ /* exit status - bits below are ORed */
+ #define EX_USAGE 1 /* incorrect invocation or permission */
+ #define EX_SYSERR 2 /* out of memory, cannot fork, ... */
diff --git a/user/cifs-utils/xattr_size_max.patch b/user/cifs-utils/xattr_size_max.patch
new file mode 100644
index 000000000..041041a61
--- /dev/null
+++ b/user/cifs-utils/xattr_size_max.patch
@@ -0,0 +1,32 @@
+diff --git a/getcifsacl.c b/getcifsacl.c
+index f08cdea..5c46999 100644
+--- a/getcifsacl.c
++++ b/getcifsacl.c
+@@ -38,6 +38,11 @@
+ #include "cifsacl.h"
+ #include "idmap_plugin.h"
+
++#ifdef __linux__
++#include <linux/limits.h> /* for XATTR_SIZE_MAX */
++#include <endian.h> /* le16toh, le32toh etc */
++#endif
++
+ static void *plugin_handle;
+ static bool plugin_loaded;
+
+diff --git a/setcifsacl.c b/setcifsacl.c
+index ba34403..64e6eaa 100644
+--- a/setcifsacl.c
++++ b/setcifsacl.c
+@@ -39,6 +39,11 @@
+ #include "cifsacl.h"
+ #include "idmap_plugin.h"
+
++#ifdef __linux__
++#include <linux/limits.h> /* for XATTR_SIZE_MAX */
++#include <endian.h> /* le16toh, le32toh etc */
++#endif
++
+ enum setcifsacl_actions {
+ ActUnknown = -1,
+ ActDelete,
diff --git a/user/clearsans/APKBUILD b/user/clearsans/APKBUILD
new file mode 100644
index 000000000..2f8f486d0
--- /dev/null
+++ b/user/clearsans/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=clearsans
+pkgver=1.00
+pkgrel=0
+pkgdesc="Typeface designed for screen and Web"
+url="https://01.org/clear-sans"
+arch="noarch"
+options="!check" # No test suite.
+license="Apache-2.0"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://01.org/sites/default/files/downloads/clear-sans/clearsans-$pkgver.zip"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ TTF/*.ttf
+}
+
+sha512sums="83faebae8b1041ab16bb3c6586574374f70ad1da406ad5d20f07f14b65e00e8645c5393471cea0194b14f2c2d926d6de814f745299062a4dccef2581e6de332d clearsans-1.00.zip"
diff --git a/user/cm-unicode/APKBUILD b/user/cm-unicode/APKBUILD
new file mode 100644
index 000000000..30a09c8a0
--- /dev/null
+++ b/user/cm-unicode/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=cm-unicode
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="The default TeX typeface, Computer Modern"
+url="http://cm-unicode.sourceforge.net/"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://downloads.sourceforge.net/cm-unicode/cm-unicode-$pkgver-ttf.tar.xz"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+}
+
+sha512sums="6340b7c6b220c8c887a4b77e77a01a43bedf13d08dd1d62570de70866d0bff908adf3fcb7907149ab2f5ab060650b39eaad3c01c1e8d028bbeb879b058190e70 cm-unicode-0.7.0-ttf.tar.xz"
diff --git a/user/comic-neue/APKBUILD b/user/comic-neue/APKBUILD
new file mode 100644
index 000000000..8b731ab10
--- /dev/null
+++ b/user/comic-neue/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=comic-neue
+pkgver=2.3
+pkgrel=0
+pkgdesc="Casual typeface"
+url="http://comicneue.com/"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="http://comicneue.com/comic-neue-$pkgver.zip"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/OTF/ OTF/*.otf
+}
+
+sha512sums="37adcc314f6d4bdc888e056488b209c4a8f3ee5f51618960a733e9d88ee513bafb2abf2b3d9d5bc4d2106297cf38645a8ab56c0fe79974b2ee6e0528aebaf4f5 comic-neue-2.3.zip"
diff --git a/user/courier-prime/APKBUILD b/user/courier-prime/APKBUILD
new file mode 100644
index 000000000..94cdce083
--- /dev/null
+++ b/user/courier-prime/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=courier-prime
+pkgver=1.203
+pkgrel=0
+pkgdesc="Redesigned Courier typeface made for screenwriters"
+url="https://www.quoteunquoteapps.com/courierprime/"
+arch="noarch"
+options="!check" # No test suite.
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+subpackages=""
+source="https://dev.gentoo.org/~jstein/dist/courier-prime-$pkgver.tar.xz"
+
+package() {
+ cd "$builddir"
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+}
+
+sha512sums="fef9d7f09dafbdb9d8626cb06cac617319d5ec43aef29fe7f6ee25156b380f9ec9684715d6012f05cb40d9511d44cf36a9ed1951281218b2c545e6ce4e7cdbda courier-prime-1.203.tar.xz"
diff --git a/user/dialog/APKBUILD b/user/dialog/APKBUILD
index a7dc72010..cc5e3e668 100644
--- a/user/dialog/APKBUILD
+++ b/user/dialog/APKBUILD
@@ -5,7 +5,7 @@ _realver=1.3-20181107
pkgver=${_realver/-/.}
pkgrel=0
pkgdesc="Script interpreter providing curses widgets"
-url="http://invisible-island.net/dialog/dialog.html"
+url="https://invisible-island.net/dialog/dialog.html"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1-only"
diff --git a/user/faad2/APKBUILD b/user/faad2/APKBUILD
index 061255a83..c76894b27 100644
--- a/user/faad2/APKBUILD
+++ b/user/faad2/APKBUILD
@@ -3,7 +3,7 @@ pkgname=faad2
pkgver=2.8.8
pkgrel=0
pkgdesc="ISO AAC audio decoder"
-url="http://www.audiocoding.com/"
+url="https://www.audiocoding.com/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
diff --git a/user/fltk/APKBUILD b/user/fltk/APKBUILD
index fa5f5702c..fe5c3d55f 100644
--- a/user/fltk/APKBUILD
+++ b/user/fltk/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.3.4.2
_realver=1.3.4-2
pkgrel=0
pkgdesc="Cross-platform C++ GUI toolkit"
-url="http://www.fltk.org/"
+url="https://www.fltk.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0-only WITH FLTK-exception"
@@ -13,7 +13,7 @@ depends=""
depends_dev="libx11-dev libxext-dev libxft-dev mesa-dev"
makedepends="$depends_dev libjpeg-turbo-dev libpng-dev libxinerama-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-fluid"
-source="http://fltk.org/pub/fltk/1.3.4/$pkgname-$_realver-source.tar.gz"
+source="https://fltk.org/pub/fltk/1.3.4/$pkgname-$_realver-source.tar.gz"
builddir="$srcdir"/$pkgname-$_realver
build() {
diff --git a/user/freecell-solver/APKBUILD b/user/freecell-solver/APKBUILD
index abf6ae301..78c1eadb5 100644
--- a/user/freecell-solver/APKBUILD
+++ b/user/freecell-solver/APKBUILD
@@ -4,7 +4,7 @@ pkgname=freecell-solver
pkgver=4.20.0
pkgrel=0
pkgdesc="Library for solving card games"
-url="http://fc-solve.shlomifish.org/"
+url="https://fc-solve.shlomifish.org/"
arch="all"
license="MIT"
depends="python3"
@@ -13,7 +13,7 @@ makedepends="gperf perl perl-task-freecellsolver-testing python3 py3-random2
checkdepends="gmp-dev libtap-dev perl-dev py3-cffi py3-pycotap the_silver_searcher
valgrind"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://fc-solve.shlomifish.org/downloads/fc-solve/freecell-solver-$pkgver.tar.xz"
+source="https://fc-solve.shlomifish.org/downloads/fc-solve/freecell-solver-$pkgver.tar.xz"
build() {
cd "$builddir"
diff --git a/user/hyphen/APKBUILD b/user/hyphen/APKBUILD
index eb37c9a1b..a4d891e72 100644
--- a/user/hyphen/APKBUILD
+++ b/user/hyphen/APKBUILD
@@ -4,7 +4,7 @@ pkgname=hyphen
pkgver=2.8.8
pkgrel=1
pkgdesc="Library for high quality word hyphenation and justification"
-url="https://hunspell.sourceforge.net/"
+url="https://hunspell.github.io/"
arch="all"
license="LGPL-2.1+ OR LGPL-2.0+ OR MPL-1.0 or GPL-2.0+"
subpackages="$pkgname-dev"
diff --git a/user/i3wm/APKBUILD b/user/i3wm/APKBUILD
index 197cbd45f..59c94e802 100644
--- a/user/i3wm/APKBUILD
+++ b/user/i3wm/APKBUILD
@@ -5,7 +5,7 @@ pkgname=i3wm
pkgver=4.15
pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
-url="http://i3wm.org"
+url="https://i3wm.org"
arch="all"
license="BSD-3-Clause"
options="!check" # The test suite requires X
@@ -15,7 +15,7 @@ makedepends="bison flex libxcb-dev xcb-util-cursor-dev xcb-util-keysyms-dev
checkdepends="perl-x11-xcb perl-anyevent perl-json-xs perl-ipc-run
perl-inline-c perl-dev libxcb-dev xcb-util-dev xorg-server-xephyr"
subpackages="$pkgname-doc"
-source="http://i3wm.org/downloads/i3-$pkgver.tar.bz2
+source="https://i3wm.org/downloads/i3-$pkgver.tar.bz2
i3wm-musl-glob-tilde.patch
i3wm-test-fix-off_t.patch
i3wm-test-disable-branch-check.patch"
diff --git a/user/ido/APKBUILD b/user/ido/APKBUILD
index a2714b183..9f858605e 100644
--- a/user/ido/APKBUILD
+++ b/user/ido/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ido
pkgver=12.10.2
pkgrel=0
pkgdesc="Library for indicator display objects"
-url="https://launchpad.net/libido"
+url="https://launchpad.net/ido"
arch="all"
options="!check" # broken testsuite
license="(LGPL-2.1-only OR LGPL-3.0-only) AND GPL-3.0-only AND LGPL-2.0+"
diff --git a/user/imake/APKBUILD b/user/imake/APKBUILD
index ba5585c32..b2eb2284b 100644
--- a/user/imake/APKBUILD
+++ b/user/imake/APKBUILD
@@ -4,7 +4,7 @@ pkgname=imake
pkgver=1.0.7
pkgrel=0
pkgdesc="X Windows make utility"
-url="http://www.x.org"
+url="https://www.x.org"
arch="all"
license="X11"
options="!check" # No testsuite
diff --git a/user/kolourpaint/APKBUILD b/user/kolourpaint/APKBUILD
index 086b99da6..2cfeb26e9 100644
--- a/user/kolourpaint/APKBUILD
+++ b/user/kolourpaint/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kolourpaint
pkgver=18.08.3
pkgrel=0
pkgdesc="Simple painting program for KDE"
-url="https://www.kolourpaint.org/"
+url="https://kolourpaint.org/"
arch="all"
# yes, there is 2 only *and* 2+ code here.
license="BSD-2-Clause AND LGPL-2.0-only AND LGPL-2.0+"
diff --git a/user/libart-lgpl/APKBUILD b/user/libart-lgpl/APKBUILD
index e234aeced..8eb73fdb3 100644
--- a/user/libart-lgpl/APKBUILD
+++ b/user/libart-lgpl/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libart-lgpl
pkgver=2.3.21
pkgrel=6
pkgdesc="Library for high-performance 2D graphics"
-url="http://www.levien.com/libart/"
+url="https://www.levien.com/libart/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0+"
diff --git a/user/libtirpc/APKBUILD b/user/libtirpc/APKBUILD
index 64124563a..5231ff63d 100644
--- a/user/libtirpc/APKBUILD
+++ b/user/libtirpc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libtirpc
pkgver=1.1.4
pkgrel=1
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
-url="http://libtirpc.sourceforge.net/"
+url="https://sourceforge.net/projects/libtirpc/"
arch="all"
options="!check" # No test suite.
license="BSD-3-Clause"
diff --git a/user/lynx/APKBUILD b/user/lynx/APKBUILD
index 14d35db09..d19215e41 100644
--- a/user/lynx/APKBUILD
+++ b/user/lynx/APKBUILD
@@ -7,7 +7,7 @@ _relver=${pkgver/_p/rel.}
_v=${_relver%rel.*}
pkgrel=0
pkgdesc="Cross-platform text-based browser"
-url="http://lynx.invisible-island.net/"
+url="https://lynx.invisible-island.net/"
arch="all"
license="GPL-2.0-only"
depends="gzip"
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
new file mode 100644
index 000000000..9be34874f
--- /dev/null
+++ b/user/nmap/APKBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=nmap
+pkgver=7.70
+pkgrel=0
+pkgdesc="A network exploration tool and security/port scanner"
+url="http://nmap.org"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+options="!checkroot"
+subpackages="
+ $pkgname-doc
+ $pkgname-scripts::noarch
+ $pkgname-nselibs::noarch
+ $pkgname-nping
+ $pkgname-ncat"
+source="https://nmap.org/dist/$pkgname-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ # zenmap and ndiff require python 2
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-zenmap \
+ --without-ndiff \
+ --with-openssl=yes \
+ --with-libpcap=yes \
+ --with-libpcre=yes \
+ --with-libz=yes \
+ --with-libssh2=yes \
+ --with-liblua=/usr/lua5.3
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+scripts() {
+ depends="$pkgname-nselibs"
+ pkgdesc="$pkgdesc (scripts)"
+
+ mkdir -p "$subpkgdir"/usr/share/nmap/
+ mv "$pkgdir"/usr/share/nmap/scripts \
+ "$subpkgdir"/usr/share/nmap/
+}
+
+nselibs() {
+ pkgdesc="$pkgdesc (nselibs)"
+
+ mkdir -p "$subpkgdir"/usr/share/nmap/
+ mv "$pkgdir"/usr/share/nmap/nse_main.lua \
+ "$pkgdir"/usr/share/nmap/nselib \
+ "$subpkgdir"/usr/share/nmap/
+}
+
+ncat() {
+ pkgdesc="$pkgdesc (ncat tool)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/ncat "$subpkgdir"/usr/bin
+}
+
+nping() {
+ pkgdesc="$pkgdesc (nping tool)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/nping "$subpkgdir"/usr/bin
+}
+
+sha512sums="084c148b022ff6550e269d976d0077f7932a10e2ef218236fe13aa3a70b4eb6506df03329868fc68cb3ce78e4360b200f5a7a491d3145028fed679ef1c9ecae5 nmap-7.70.tar.bz2"
diff --git a/user/ode/APKBUILD b/user/ode/APKBUILD
index f21ef2b42..7a55d53cb 100644
--- a/user/ode/APKBUILD
+++ b/user/ode/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ode
pkgver=0.14
pkgrel=0
pkgdesc="High performance library for simulating rigid body dynamics"
-url="https://www.ode-wiki.org/wiki/index.php?title=Main_Page"
+url="https://ode.org/"
arch="all"
options="!check" # Fails 48/52 tests
license="LGPL-2.1+ OR BSD-3-Clause"
diff --git a/user/openal-soft/APKBUILD b/user/openal-soft/APKBUILD
index fe3cbda8b..d5d32afe3 100644
--- a/user/openal-soft/APKBUILD
+++ b/user/openal-soft/APKBUILD
@@ -4,14 +4,14 @@ pkgname=openal-soft
pkgver=1.19.1
pkgrel=0
pkgdesc="Software implementation of OpenAL API"
-url="http://kcat.strangesoft.net/openal.html"
+url="https://kcat.strangesoft.net/openal.html"
arch="all"
license="LGPL-2.0+"
depends=""
depends_dev="alsa-lib-dev"
makedepends="$depends_dev cmake linux-headers pulseaudio-dev"
subpackages="$pkgname-dev"
-source="http://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
+source="https://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
prepare() {
default_prepare
diff --git a/user/perl-extutils-depends/APKBUILD b/user/perl-extutils-depends/APKBUILD
index 3947f7667..2d62635f2 100644
--- a/user/perl-extutils-depends/APKBUILD
+++ b/user/perl-extutils-depends/APKBUILD
@@ -4,7 +4,7 @@ pkgname=perl-extutils-depends
pkgver=0.405
pkgrel=0
pkgdesc="Easily build XS extensions that depend on XS extensions"
-url="https://metacpan.org/release/ExtUtils::Depends"
+url="https://metacpan.org/release/ExtUtils-Depends"
arch="noarch"
license="Artistic-1.0-Perl AND GPL-2.0"
depends="perl"
@@ -12,7 +12,6 @@ makedepends="perl-dev"
install=""
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/X/XA/XAOC/ExtUtils-Depends-$pkgver.tar.gz"
-sha512sums="b9983ad763ff0cb81c899bc24f3152f13c69e608304b6e4446bd07b9b13d039650f3f87544c0bdd29c67246ea2973f04a1ce0fccbffb566fe89fdbe0bb03f11b ExtUtils-Depends-0.405.tar.gz"
builddir="$srcdir/ExtUtils-Depends-$pkgver"
build() {
@@ -32,3 +31,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
+sha512sums="b9983ad763ff0cb81c899bc24f3152f13c69e608304b6e4446bd07b9b13d039650f3f87544c0bdd29c67246ea2973f04a1ce0fccbffb566fe89fdbe0bb03f11b ExtUtils-Depends-0.405.tar.gz"
diff --git a/user/plasma-desktop/APKBUILD b/user/plasma-desktop/APKBUILD
index 4b06e92d6..963cfc1dd 100644
--- a/user/plasma-desktop/APKBUILD
+++ b/user/plasma-desktop/APKBUILD
@@ -4,7 +4,7 @@ pkgname=plasma-desktop
pkgver=5.12.7
pkgrel=0
pkgdesc="Modern, functional, integrated libre desktop environment"
-url="https://www.kde.org/info/plasma-desktop"
+url="https://www.kde.org/plasma-desktop"
arch="all"
options="!check" # Test suite fails due to keyboard layouts
license="GPL-2.0 LGPL-2.1"
diff --git a/user/qps/APKBUILD b/user/qps/APKBUILD
index 814b96ed7..cdcc140e8 100644
--- a/user/qps/APKBUILD
+++ b/user/qps/APKBUILD
@@ -4,7 +4,7 @@ pkgname=qps
pkgver=1.10.19
pkgrel=0
pkgdesc="Qt-based task manager"
-url="https://github.com/QtDesktop"
+url="https://lxqt.org"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
diff --git a/user/talloc/APKBUILD b/user/talloc/APKBUILD
new file mode 100644
index 000000000..82ba9d682
--- /dev/null
+++ b/user/talloc/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=talloc
+pkgver=2.1.15
+pkgrel=0
+pkgdesc="Memory pool management library"
+url="https://talloc.samba.org"
+arch="all"
+license="LGPL-3.0+ AND GPL-3.0+ AND ISC AND LGPL-2.1+ AND BSD-3-Clause AND PostgreSQL"
+replaces="samba-common"
+depends=""
+makedepends="docbook-xsl libxslt python3-dev"
+subpackages="$pkgname-dev py3-$pkgname:py3 $pkgname-doc"
+source="https://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz
+ waf-location.patch"
+
+build() {
+ cd "$builddir"
+ PYTHON=python3 ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --disable-rpath \
+ --disable-rpath-install
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+py3() {
+ pkgdesc="Python 3 binding for libtalloc"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libpytalloc-util.cpython* \
+ "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="41896f8877e9a52e70b9881c41667dc52d7c1b03c3b248020fd909b794a4c5a4addee3eb944aa80ecfa3b03e6e5e1f67a62b5f3a5dcdc412b3e975352057ff40 talloc-2.1.15.tar.gz
+d19553fae679b5db10ab77a86f9fa0525ccba37a3ef30e530cd96245ee5fc94d4570079bbfe0271c32fbc84a3556c4bf86cc1cab6ffb61863cbce3f5a911efec waf-location.patch"
diff --git a/user/talloc/waf-location.patch b/user/talloc/waf-location.patch
new file mode 100644
index 000000000..a5ca47f44
--- /dev/null
+++ b/user/talloc/waf-location.patch
@@ -0,0 +1,10 @@
+--- talloc-2.1.15/Makefile 2019-01-14 17:24:45.000000000 -0500
++++ talloc-2.1.15/Makefile 2019-01-27 22:57:15.919981283 -0500
+@@ -1,6 +1,6 @@
+ # simple makefile wrapper to run waf
+
+-WAF_BINARY=$(PYTHON) ../../buildtools/bin/waf
++WAF_BINARY=$(PYTHON) buildtools/bin/waf
+ WAF=PYTHONHASHSEED=1 WAF_MAKE=1 $(WAF_BINARY)
+
+ all:
diff --git a/user/trojita/APKBUILD b/user/trojita/APKBUILD
index 2c92fc0fd..429226f42 100644
--- a/user/trojita/APKBUILD
+++ b/user/trojita/APKBUILD
@@ -4,7 +4,7 @@ pkgname=trojita
pkgver=0.7
pkgrel=0
pkgdesc="Qt-based IMAP email client"
-url="https://trojita.flaska.net/"
+url="http://trojita.flaska.net/"
arch="all"
options="!check"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1 WITH Nokia-Qt-exception-1.1 OR GPL-3.0-only) AND BSD-3-Clause AND GPL-2.0-only AND GPL-2.0+ AND LGPL-2.0-only AND LGPL-2.0+ AND LGPL-2.1+"