summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/kcachegrind/APKBUILD43
-rw-r--r--user/tellico/APKBUILD55
-rw-r--r--user/tellico/btparse-strcasecmp.patch20
-rw-r--r--user/unrar/APKBUILD33
-rw-r--r--user/unrar/makefile.patch27
-rw-r--r--user/weechat/APKBUILD5
-rw-r--r--user/weechat/fix-unsigned-char.patch37
-rw-r--r--user/xf86-video-fbdev/APKBUILD34
-rw-r--r--user/youtube-dl/APKBUILD68
9 files changed, 261 insertions, 61 deletions
diff --git a/user/kcachegrind/APKBUILD b/user/kcachegrind/APKBUILD
new file mode 100644
index 000000000..68dc6519c
--- /dev/null
+++ b/user/kcachegrind/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kcachegrind
+pkgver=18.08.3
+pkgrel=0
+pkgdesc="Profile data visualisation tool and call graph viewer"
+url="https://kcachegrind.github.io/html/Home.html"
+arch="all"
+license="GPL-2.0-only"
+depends="binutils graphviz"
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qttools-dev
+ karchive-dev kconfig-dev kcoreaddons-dev kdoctools-dev ki18n-dev kio-dev
+ kwidgetsaddons-dev kxmlgui-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/applications/$pkgver/src/kcachegrind-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="abbbf7ba539da1fa71d31e4603d1b8a76178a48bf503c735ebce9bbc9887e9ec64b2338ce77de2f38114faa27dee51e19af61cf4d3e9fbbe942a417edf2558c1 kcachegrind-18.08.3.tar.xz"
diff --git a/user/tellico/APKBUILD b/user/tellico/APKBUILD
new file mode 100644
index 000000000..a38fa7618
--- /dev/null
+++ b/user/tellico/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=tellico
+pkgver=3.1.3
+pkgrel=0
+pkgdesc="Collection manager"
+url="http://tellico-project.org/"
+arch="all"
+license="GPL-2.0-only OR GPL-3.0-only"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev libxml2-dev libxslt-dev
+ karchive-dev kcodecs-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev
+ kcrash-dev kdoctools-dev kguiaddons-dev khtml-dev ki18n-dev
+ kiconthemes-dev kio-dev kitemmodels-dev kjobwidgets-dev kwallet-dev
+ kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev solid-dev
+
+ kfilemetadata-dev knewstuff-dev libcdio-dev libksane-dev poppler-dev
+ poppler-qt5-dev taglib-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://tellico-project.org/files/tellico-$pkgver.tar.xz
+ btparse-strcasecmp.patch
+ "
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS -std=gnu99" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ # imagejob: needs running X11
+ # htmlexporter: needs plasma desktop
+ # filelisting: needs dbus
+ # tellicoread: needs network
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(filelisting|imagejob|htmlexporter|tellicoread)test'
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9024f423f0685e834ed46e7038c5b95fab5b684aaac00d6298e23493fb4290daeda994faf36a0f04973093a477be5506591e6b0e7f57ef5591fb10953ad8ec5e tellico-3.1.3.tar.xz
+4627e717d67340de6d88f7a21604a66ba236c651a0ae38d9d3569b76ad58c79f046cfd5686dd688de86d6acafc17ba3959902babdc7f00ab8e9d65717c4fab4a btparse-strcasecmp.patch"
diff --git a/user/tellico/btparse-strcasecmp.patch b/user/tellico/btparse-strcasecmp.patch
new file mode 100644
index 000000000..2afd4dec3
--- /dev/null
+++ b/user/tellico/btparse-strcasecmp.patch
@@ -0,0 +1,20 @@
+--- tellico-3.1.3/src/3rdparty/btparse/lex_auxiliary.c.old 2018-09-03 00:35:39.883417043 +0000
++++ tellico-3.1.3/src/3rdparty/btparse/lex_auxiliary.c 2018-11-25 06:07:20.260000000 +0000
+@@ -32,6 +32,7 @@
+ #include "bt_debug.h"
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <ctype.h>
+ #include <stdarg.h>
+ #include <assert.h>
+--- tellico-3.1.3/src/3rdparty/btparse/sym.c.old 2018-09-03 00:35:39.887417131 +0000
++++ tellico-3.1.3/src/3rdparty/btparse/sym.c 2018-11-25 06:07:11.570000000 +0000
+@@ -110,6 +110,7 @@
+ /*#include "bt_config.h"*/
+ #include <stdio.h>
+ #include <string.h>
++#include <strings.h>
+ #include <stdlib.h>
+ #ifdef MEMCHK
+ #include "trax.h"
diff --git a/user/unrar/APKBUILD b/user/unrar/APKBUILD
deleted file mode 100644
index f50447699..000000000
--- a/user/unrar/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Dan Theisen <djt@hxx.in>
-pkgname=unrar
-pkgver=5.6.8
-pkgrel=0
-pkgdesc="The RAR uncompression program"
-url="https://www.rarlab.com"
-arch="all"
-options="!check" # No test suite.
-license="custom:UnRAR"
-depends=""
-makedepends=""
-subpackages="$pkgname-doc"
-source="https://www.rarlab.com/rar/unrarsrc-$pkgver.tar.gz
- makefile.patch"
-builddir="$srcdir"/$pkgname
-
-build() {
- cd "$builddir"
- make CXX="${CXX:-g++}" CXXFLAGS="$CXXFLAGS" \
- LDFLAGS="$LDFLAGS" STRIP=: -f makefile
-}
-
-package() {
- cd "$builddir"
- install -Dm755 unrar "$pkgdir"/usr/bin/unrar
- install -Dm644 license.txt \
- "$pkgdir/usr/share/licenses/$pkgname/license.txt"
-}
-
-sha512sums="5410308d7f462824bc10087cdc4515c58aaad776cc09eb6491864a338ae00ff35e3b54d1e7250c0a9576554ea382383155be718a0b95d7af00f27d5df04f4f56 unrarsrc-5.6.8.tar.gz
-7da30d8454a67999e7052ed2c0ee8d29627b1d47bfdf36e8cf1e24f3c36ee58b17f7e7a6505a4b38e0ca3162067368a1bf554829fd824f7c17a3a2a5b35ca29c makefile.patch"
diff --git a/user/unrar/makefile.patch b/user/unrar/makefile.patch
deleted file mode 100644
index 1892dab24..000000000
--- a/user/unrar/makefile.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -upr unrar.orig/makefile unrar/makefile
---- unrar.orig/makefile 2017-06-30 21:34:46.228703991 +0200
-+++ unrar/makefile 2017-06-30 21:35:07.535424717 +0200
-@@ -3,12 +3,12 @@
-
- # Linux using GCC
- CXX=c++
--CXXFLAGS=-O2 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
-+CXXFLAGS?=-O2 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
- LIBFLAGS=-fPIC
- DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DRAR_SMP
- STRIP=strip
- AR=ar
--LDFLAGS=-pthread
-+LDFLAGS+=-pthread
- DESTDIR=/usr
-
- # Linux using LCC
-@@ -140,7 +140,7 @@ uninstall: uninstall-unrar
- clean:
- @rm -f *.o *.bak *~
-
--unrar: clean $(OBJECTS) $(UNRAR_OBJ)
-+unrar: $(OBJECTS) $(UNRAR_OBJ)
- @rm -f unrar
- $(LINK) -o unrar $(LDFLAGS) $(OBJECTS) $(UNRAR_OBJ) $(LIBS)
- $(STRIP) unrar
diff --git a/user/weechat/APKBUILD b/user/weechat/APKBUILD
index 3cca9f41a..6f8bb3701 100644
--- a/user/weechat/APKBUILD
+++ b/user/weechat/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=weechat
pkgver=2.3
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, light, extensible ncurses-based chat client"
url="https://www.weechat.org"
arch="all"
@@ -16,6 +17,7 @@ subpackages="$pkgname-dev $pkgname-aspell:_plugin $pkgname-lua:_plugin
$pkgname-perl:_plugin $pkgname-python:_plugin $pkgname-lang"
source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
fix-python-linking.patch
+ fix-unsigned-char.patch
libintl-fix.patch
"
@@ -63,4 +65,5 @@ check() {
sha512sums="3315eb672d099dec041a6ece268e3efac9f766fe8273b13810c9ed6bc9129ed0db9730a027db6cdf157338472caf99d60aaf3de9b096a3c395fdf889b106aaea weechat-2.3.tar.gz
95f6d1405141421fae70288ec560a6d61f0bde1ce0bfa6e522e24a9673e699099594e83511b39e413aff28010ea1f7f1672af051ac370b152c732d6ca36a9056 fix-python-linking.patch
+e9dddc914f08660c49fd3331ebdca73a3df7e165b284d8b19e0487974ec2d8d75d03cd6d07da6ba9783015ddb19d6c118b697a830dcbea13f078ca7826223370 fix-unsigned-char.patch
59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca libintl-fix.patch"
diff --git a/user/weechat/fix-unsigned-char.patch b/user/weechat/fix-unsigned-char.patch
new file mode 100644
index 000000000..d4acd1986
--- /dev/null
+++ b/user/weechat/fix-unsigned-char.patch
@@ -0,0 +1,37 @@
+This patch is backported from the upcoming 2.4 release. It corrects
+highlighting behavior for plugins such as urlserver.py.
+
+See-Also: https://github.com/weechat/weechat/issues/1277
+Patch-Author: Sébastien Helleu <flashcode@flashtux.org>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0ae69ea0f..1d7738af5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,8 +27,8 @@ project(weechat C)
+ set(CMAKE_VERBOSE_MAKEFILE OFF)
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
+ set(CMAKE_SKIP_RPATH ON)
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
+-set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
+
+ # version
+ execute_process(COMMAND ${CMAKE_SOURCE_DIR}/version.sh devel-major OUTPUT_VARIABLE VERSION_MAJOR)
+diff --git a/configure.ac b/configure.ac
+index d267ca10f..a0bf00078 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1330,7 +1330,7 @@ AC_DEFINE_UNQUOTED(WEECHAT_SHAREDIR, "$WEECHAT_SHAREDIR")
+ weechat_libdir=${libdir}/weechat
+ AC_SUBST(weechat_libdir)
+
+-COMMON_CFLAGS="-Wall -Wextra -Werror-implicit-function-declaration"
++COMMON_CFLAGS="-fsigned-char -Wall -Wextra -Werror-implicit-function-declaration"
+ AC_MSG_CHECKING([whether we have GNU assembler])
+ GAS=`as --version < /dev/null 2>/dev/null | grep GNU`
+ if test "$GAS"; then
+--
+2.19.1
+
diff --git a/user/xf86-video-fbdev/APKBUILD b/user/xf86-video-fbdev/APKBUILD
new file mode 100644
index 000000000..628551019
--- /dev/null
+++ b/user/xf86-video-fbdev/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xf86-video-fbdev
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="X.Org driver for video over framebuffers"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libxi-dev util-macros xorgproto-dev xorg-server-dev"
+source="https://www.X.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="c1217b943bbe3301b3c2a8649ed1004c3c67b02607bd56bbc14f6dfa05e7f0184332c81a6a19595514745501ed88526aee932e555779b7c3a8233646b0979448 xf86-video-fbdev-0.5.0.tar.bz2"
diff --git a/user/youtube-dl/APKBUILD b/user/youtube-dl/APKBUILD
new file mode 100644
index 000000000..af5d02712
--- /dev/null
+++ b/user/youtube-dl/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=youtube-dl
+pkgver=2018.11.23
+pkgrel=0
+pkgdesc="Command-line program to download videos from YouTube and many other sites"
+url="https://youtube-dl.org"
+arch="noarch"
+options="!check" # Takes way too long, and uses network
+license="Unlicense AND Public-Domain"
+depends="ffmpeg python3"
+subpackages="$pkgname-doc
+ $pkgname-zsh-completion:zshcomp
+ $pkgname-bash-completion:bashcomp
+ $pkgname-fish-completion:fishcomp"
+source="https://github.com/rg3/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname"
+
+prepare() {
+ default_prepare
+ sed -i \
+ -e 's|etc/bash_completion.d|share/bash-completion/completions|' \
+ -e 's|etc/fish/completions|share/fish/completions|' \
+ "$builddir/setup.py"
+}
+
+check() {
+ cd "$builddir"
+ python3 -m unittest discover
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+zshcomp() {
+ pkgdesc="Zsh completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir/$pkgname.zsh" \
+ "$subpkgdir/usr/share/zsh/site-functions/_$pkgname"
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir/usr/share/bash-completion/completions/"
+ mv "$pkgdir/usr/share/bash-completion/completions/$pkgname.bash-completion" \
+ "$subpkgdir/usr/share/bash-completion/completions/$pkgname"
+}
+
+fishcomp() {
+ pkgdesc="Fish completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ mkdir -p "$subpkgdir/usr/share/fish/completions/"
+ mv "$pkgdir/usr/share/fish/completions/$pkgname.fish" \
+ "$subpkgdir/usr/share/fish/completions/"
+}
+
+sha512sums="d4d2813657972c37d3493743a44055d7a776aeb5c5a97902e07caa317a3b2db30332507c37b56b3d8554e0bdc2a0ec6a9862977b449b363343a4de2df12bf059 youtube-dl-2018.11.23.tar.gz"