summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/xisxwayland/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/xisxwayland/APKBUILD b/user/xisxwayland/APKBUILD
new file mode 100644
index 000000000..70c570c5a
--- /dev/null
+++ b/user/xisxwayland/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xisxwayland
+pkgver=2
+pkgrel=0
+pkgdesc="Determine if an X server is Xwayland"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="meson ninja libx11-dev libxrandr-dev"
+subpackages="$pkgname-doc"
+source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ . build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="b89e19c85a5cd7e62a52e22772f80f03bfea069e31412ca11ac38174c4a2994be559e9d5fb49e6d1921b3f1b06ee71b50ede48990a1e7804a96207b08fc7827f xisxwayland-2.tar.xz"