summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/distcc/APKBUILD3
-rw-r--r--user/fts/APKBUILD2
-rw-r--r--user/gtkspell/APKBUILD15
-rw-r--r--user/gtkspell/enchant-2.patch89
-rw-r--r--user/libbsd/APKBUILD2
-rw-r--r--user/libcanberra/APKBUILD2
-rw-r--r--user/libical/APKBUILD5
-rw-r--r--user/libidl/APKBUILD5
-rw-r--r--user/libnih/APKBUILD2
-rw-r--r--user/libqrencode/APKBUILD2
-rw-r--r--user/makedepend/APKBUILD8
-rw-r--r--user/opencv/APKBUILD1
-rw-r--r--user/py3-six/APKBUILD2
-rw-r--r--user/sane/APKBUILD7
14 files changed, 117 insertions, 28 deletions
diff --git a/user/distcc/APKBUILD b/user/distcc/APKBUILD
index c81035ef7..9584cab67 100644
--- a/user/distcc/APKBUILD
+++ b/user/distcc/APKBUILD
@@ -34,7 +34,8 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --without-avahi
+ --without-avahi \
+ --disable-Werror
make
}
diff --git a/user/fts/APKBUILD b/user/fts/APKBUILD
index 0e7d81cf1..2864ee250 100644
--- a/user/fts/APKBUILD
+++ b/user/fts/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=fts
pkgver=1.2.7
pkgrel=1
diff --git a/user/gtkspell/APKBUILD b/user/gtkspell/APKBUILD
index 6ed3ffdcc..cd7b8f100 100644
--- a/user/gtkspell/APKBUILD
+++ b/user/gtkspell/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gtkspell
pkgver=2.0.16
-pkgrel=9
+pkgrel=10
pkgdesc="Highlighting and replacement of misspelled words in Gtk software"
url="http://gtkspell.sourceforge.net/"
arch="all"
@@ -9,16 +9,16 @@ license="GPL-2.0-only"
makedepends="gtk+2.0-dev enchant-dev intltool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
langdir="/usr/lib/locale"
-source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz
+ enchant-2.patch
+ "
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,13 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz"
+sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz
+0071d81b7dabcf1bb4be76c13c453724606a3d030ea13a7bb87fe4e96b1dc40118110e470f5f4044c55e49c49ff0d6761ef3db7091228ef52225ac35fba42f6d enchant-2.patch"
diff --git a/user/gtkspell/enchant-2.patch b/user/gtkspell/enchant-2.patch
new file mode 100644
index 000000000..e6dd3298b
--- /dev/null
+++ b/user/gtkspell/enchant-2.patch
@@ -0,0 +1,89 @@
+--- gtkspell-2.0.16/configure.ac.old 2009-10-23 02:52:31.000000000 +0000
++++ gtkspell-2.0.16/configure.ac 2019-03-18 16:16:30.890000000 +0000
+@@ -12,12 +12,12 @@
+ AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+ AC_CONFIG_HEADERS([config.h])
+
+-SPELLER_LIB=-lenchant
++SPELLER_LIB=
+
+ AC_SUBST(SPELLER_LIB)
+ GTKSPELL_PACKAGES=gtk+-2.0
+ AC_SUBST(GTKSPELL_PACKAGES)
+-PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant >= 0.4.0 )
++PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant-2 )
+ AC_SUBST(GTKSPELL_CFLAGS)
+ AC_SUBST(GTKSPELL_LIBS)
+
+--- gtkspell-2.0.16/gtkspell/gtkspell.c.old 2009-10-09 19:01:47.000000000 +0000
++++ gtkspell-2.0.16/gtkspell/gtkspell.c 2019-03-18 16:17:15.140000000 +0000
+@@ -277,7 +277,7 @@
+ get_word_extents_from_mark(spell->buffer, &start, &end, spell->mark_click);
+ word = gtk_text_buffer_get_text(spell->buffer, &start, &end, FALSE);
+
+- enchant_dict_add_to_pwl( spell->speller, word, strlen(word));
++ enchant_dict_add( spell->speller, word, strlen(word));
+
+ gtkspell_recheck_all(spell);
+
+--- gtkspell-2.0.16/configure.old 2009-10-23 02:57:15.000000000 +0000
++++ gtkspell-2.0.16/configure 2019-03-18 16:20:29.900000000 +0000
+@@ -2715,12 +2715,12 @@
+ pkg_cv_GTKSPELL_CFLAGS="$GTKSPELL_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2733,12 +2733,12 @@
+ pkg_cv_GTKSPELL_LIBS="$GTKSPELL_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2757,14 +2757,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ else
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$GTKSPELL_PKG_ERRORS" >&5
+
+- { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++ { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+
+@@ -2775,7 +2775,7 @@
+ and GTKSPELL_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+
diff --git a/user/libbsd/APKBUILD b/user/libbsd/APKBUILD
index 015d71295..3c5cb2cf1 100644
--- a/user/libbsd/APKBUILD
+++ b/user/libbsd/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libbsd
pkgver=0.9.1
pkgrel=0
diff --git a/user/libcanberra/APKBUILD b/user/libcanberra/APKBUILD
index bd41ad019..756f8e3f7 100644
--- a/user/libcanberra/APKBUILD
+++ b/user/libcanberra/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libcanberra
pkgver=0.30
pkgrel=4
diff --git a/user/libical/APKBUILD b/user/libical/APKBUILD
index 513674394..7a27c56d4 100644
--- a/user/libical/APKBUILD
+++ b/user/libical/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer:
pkgname=libical
pkgver=3.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Reference implementation of the iCalendar format"
url="https://libical.github.io/libical/"
arch="all"
#options="!check" # Test suite is very broken.
license="MPL-2.0 OR LGPL-2.1-only"
depends=""
-makedepends="cmake glib-dev icu-dev libxml2-dev perl"
+depends_dev="db-dev"
+makedepends="$depends_dev cmake glib-dev icu-dev libxml2-dev perl"
subpackages="$pkgname-dev"
source="https://github.com/libical/libical/releases/download/v$pkgver/libical-$pkgver.tar.gz"
diff --git a/user/libidl/APKBUILD b/user/libidl/APKBUILD
index e3a95ff98..b3143333c 100644
--- a/user/libidl/APKBUILD
+++ b/user/libidl/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
pkgname=libidl
pkgver=0.8.14
pkgrel=3
@@ -8,9 +8,8 @@ url="https://www.gnome.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.0-only"
-depends=
+depends=""
makedepends="bison flex glib-dev"
-install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/libIDL/${pkgver%.*}/libIDL-$pkgver.tar.bz2"
builddir="$srcdir"/libIDL-$pkgver
diff --git a/user/libnih/APKBUILD b/user/libnih/APKBUILD
index 5a1e91495..9636f2a1a 100644
--- a/user/libnih/APKBUILD
+++ b/user/libnih/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libnih
pkgver=1.0.3
pkgrel=6
diff --git a/user/libqrencode/APKBUILD b/user/libqrencode/APKBUILD
index dc3f6eee7..12690b8d7 100644
--- a/user/libqrencode/APKBUILD
+++ b/user/libqrencode/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libqrencode
pkgver=4.0.2
pkgrel=0
diff --git a/user/makedepend/APKBUILD b/user/makedepend/APKBUILD
index 280e7b41b..da9da0ee9 100644
--- a/user/makedepend/APKBUILD
+++ b/user/makedepend/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=makedepend
pkgver=1.0.5
pkgrel=1
@@ -7,10 +7,8 @@ pkgdesc="Utility for making makefile dependencies"
url="https://www.freedesktop.org/"
arch="all"
license="MIT"
-depends=
-depends_dev=
-makedepends="$depends_dev util-macros xorgproto-dev"
-install=""
+depends=""
+makedepends="util-macros xorgproto-dev"
subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/util/${pkgname}-${pkgver}.tar.bz2"
diff --git a/user/opencv/APKBUILD b/user/opencv/APKBUILD
index d899f30f1..0745f8a6a 100644
--- a/user/opencv/APKBUILD
+++ b/user/opencv/APKBUILD
@@ -23,6 +23,7 @@ prepare() {
*/carotene*) continue;;
*/protobuf*) continue;;
*/ittnotify) continue;; # Else FTBFS on x86_64
+ */quirc) continue;;
esac
rm -rf "$i"
done
diff --git a/user/py3-six/APKBUILD b/user/py3-six/APKBUILD
index 3b5c00d34..b1c4ffadd 100644
--- a/user/py3-six/APKBUILD
+++ b/user/py3-six/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
pkgname=py3-six
_pkgname=six
pkgver=1.11.0
diff --git a/user/sane/APKBUILD b/user/sane/APKBUILD
index 87ad4deb5..1d7322866 100644
--- a/user/sane/APKBUILD
+++ b/user/sane/APKBUILD
@@ -4,14 +4,15 @@
pkgname=sane
_pkgname=sane-backends
pkgver=1.0.27
-pkgrel=3
+pkgrel=4
pkgdesc="Scanner access library"
url="http://www.sane-project.org/"
arch="all"
license="GPL-2.0+ AND GPL-2.0+-with-sane-exception AND Public-Domain"
depends=""
-makedepends="diffutils file libtool libusb-dev v4l-utils-dev net-snmp-dev libpng-dev
- libjpeg-turbo-dev tiff-dev libgphoto2-dev libieee1284-dev linux-headers"
+makedepends="diffutils file libtool libusb-dev v4l-utils-dev net-snmp-dev
+ libpng-dev libjpeg-turbo-dev tiff-dev libgphoto2-dev libieee1284-dev
+ linux-headers ncurses-dev"
install="saned.pre-install $pkgname.pre-install"
pkgusers="saned"
pkggroups="scanner"