summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/qt5-qtxmlpatterns/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/qt5-qtxmlpatterns/APKBUILD b/user/qt5-qtxmlpatterns/APKBUILD
new file mode 100644
index 000000000..7db73f263
--- /dev/null
+++ b/user/qt5-qtxmlpatterns/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtxmlpatterns
+_pkgname=qtxmlpatterns-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Support for XPath, XQuery, XSLT, and XML schema validation"
+url="https://doc.qt.io/qt-5/qtxmlpatterns-index.html"
+arch="all"
+license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="c1b7983725cd208b207e366f3fcaedf073768cbe11d6c54c4569b8155e2c97e4af889792600d86769b7e6828409e0333ad7c66b8459d07c5c1a06268d28d6788 qtxmlpatterns-opensource-src-5.9.6.tar.xz"