summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/libwacom/APKBUILD12
-rw-r--r--user/libwacom/fix-database.patch15
-rw-r--r--user/wine/APKBUILD11
-rw-r--r--user/wine/no-pie.patch21
-rw-r--r--user/wine/nopie.patch10
-rw-r--r--user/xfce4-session/APKBUILD7
6 files changed, 40 insertions, 36 deletions
diff --git a/user/libwacom/APKBUILD b/user/libwacom/APKBUILD
index 52326df1f..56464b2a0 100644
--- a/user/libwacom/APKBUILD
+++ b/user/libwacom/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libwacom
pkgver=0.33
-pkgrel=0
+pkgrel=1
pkgdesc="Tablet description library"
url="http://linuxwacom.sourceforge.net/"
arch="all"
@@ -11,7 +11,9 @@ depends=""
makedepends="libgudev-dev"
checkdepends="bash findutils"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/linuxwacom/libwacom/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2"
+source="https://github.com/linuxwacom/libwacom/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2
+ fix-database.patch
+ "
build() {
./configure \
@@ -20,9 +22,6 @@ build() {
--prefix=/usr \
--disable-static
make
- # conflicts with TS-6610 tablet
- rm "$builddir"/data/huion-h420.tablet
- rm "$builddir"/data/layouts/huion-h420.svg
}
check() {
@@ -36,4 +35,5 @@ package() {
> "$pkgdir"/usr/lib/udev/rules.d/65-libwacom.rules
}
-sha512sums="de4d9cf3b5f4d87a159ba8ee617bafce9d13b67dc23d9dc67efd57317b0df2079dd0de328bc800de47f14ee49ea82bb842e34297cef23ba336c1ddca3afa826d libwacom-0.33.tar.bz2"
+sha512sums="de4d9cf3b5f4d87a159ba8ee617bafce9d13b67dc23d9dc67efd57317b0df2079dd0de328bc800de47f14ee49ea82bb842e34297cef23ba336c1ddca3afa826d libwacom-0.33.tar.bz2
+d1ac1176aa4a95991330e23fb84868d65a1b2e81d68173c990f885af1ce591de7aca16e21db8128e4f1975bca22b8014a6fa2ca8c0458dce464568239d75263c fix-database.patch"
diff --git a/user/libwacom/fix-database.patch b/user/libwacom/fix-database.patch
new file mode 100644
index 000000000..d367ca997
--- /dev/null
+++ b/user/libwacom/fix-database.patch
@@ -0,0 +1,15 @@
+https://github.com/linuxwacom/libwacom/issues/85
+
+Awful, cheesy hack.
+
+--- libwacom-0.33/libwacom/libwacom-database.c.old 2019-04-12 03:10:21.000000000 +0000
++++ libwacom-0.33/libwacom/libwacom-database.c 2019-06-01 06:24:56.290159726 +0000
+@@ -152,7 +152,7 @@
+
+ memset(namestr, 0, sizeof(namestr));
+
+- rc = sscanf(str, "%63[^:]:%x:%x:%63c", busstr, vendor_id, product_id, namestr);
++ rc = sscanf(str, "%63[^:]:%x:%x:%63[^\b]", busstr, vendor_id, product_id, namestr);
+ if (rc == 4) {
+ *name = g_strdup(namestr);
+ } else if (rc == 3) {
diff --git a/user/wine/APKBUILD b/user/wine/APKBUILD
index 99cf1f2dd..ea9384603 100644
--- a/user/wine/APKBUILD
+++ b/user/wine/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Martell Malone <martell@marinelayer.io>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=wine
-pkgver=3.0.2
+pkgver=4.0.1
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
@@ -20,7 +20,7 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
libxcomposite-dev libxrender-dev libxinerama-dev zlib-dev
cups-dev alsa-lib-dev libxml2-dev dbus-dev libxi-dev
gnutls-dev tiff-dev v4l-utils-dev udisks2-dev autoconf automake
- openal-soft-dev pulseaudio-dev sane-dev eudev-dev
+ openal-soft-dev pulseaudio-dev sane-dev eudev-dev mpg123-dev
"
source="http://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$pkgver.tar.xz
no-pie.patch
@@ -53,6 +53,7 @@ build() {
--with-fontconfig \
--with-freetype \
--with-jpeg \
+ --with-mpg123 \
--with-openal \
--with-opengl \
--with-png \
@@ -64,7 +65,7 @@ build() {
--with-xcomposite \
--with-xinerama \
--with-xslt \
- $_win64
+ $_win64
make
}
@@ -129,6 +130,6 @@ libs() {
done
}
-sha512sums="dbd0f242c5eace297ad16e314b8ad139e7d430de7eb8ca52b2006d0b80db4809e28a0e785d404a65ea1acdb56e7f06ebfc9a50071db1edaa6180c8835e7c4b13 wine-3.0.2.tar.xz
-d853875f7d659617bdfba364704abd75b760d12977f1f13acc73acb3c8fefec0549677fb79a4f8955e073d64078b3071d63d97262522e22b7832a66d3d820a9c no-pie.patch
+sha512sums="dd240525e389f841123a569fd2f9b8da698b7707bc0de408dfd60ae73c5e24d522abb42b76571c840df52c686fdeae56e0a9c69db2cd31f04cdb345feeacf1dc wine-4.0.1.tar.xz
+a96b1e248447912ba522067b67fc920063f355f326eaf3fec760c79a1c6e46019fbdcfa8b95b9d389959a7e3d3ab794f9aaf78913ad6a73be32b5d34ca8a2267 no-pie.patch
522a94a31fc459e80ea7dd05f7aee64f6ae666ec05236d06614acde118d5c60002e0f253ae75edb5f02164f22937ca89578504b690d1a5611bd60f703c8f0c00 winhlp32-flex.patch"
diff --git a/user/wine/no-pie.patch b/user/wine/no-pie.patch
index 5fb5d87b6..2874e0af8 100644
--- a/user/wine/no-pie.patch
+++ b/user/wine/no-pie.patch
@@ -1,14 +1,11 @@
-diff --git a/loader/Makefile.in b/loader/Makefile.in
-index 8190037..437d4d9 100644
---- a/loader/Makefile.in
-+++ b/loader/Makefile.in
-@@ -26,7 +26,7 @@ wine64_DEPS = $(WINELOADER_DEPENDS)
- wine64_LDFLAGS = $(LDEXECFLAGS) -lwine $(PTHREAD_LIBS)
+--- wine-4.0.1/configure.ac
++++ wine-4.0.1/configure.ac
+@@ -955,7 +955,7 @@
- wine_preloader_OBJS = preloader.o
--wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
+ [WINELOADER_LDFLAGS="-Wl,--export-dynamic"])
+- WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000"
++ WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie"
- wine64_preloader_OBJS = preloader.o
--wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--rpath,\$ORIGIN/../lib],
+ [LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"
diff --git a/user/wine/nopie.patch b/user/wine/nopie.patch
deleted file mode 100644
index 54eb141be..000000000
--- a/user/wine/nopie.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/loader/Makefile.in b/loader/Makefile.in
-index 8190037..b4f2902 100644
---- a/loader/Makefile.in
-+++ b/loader/Makefile.in
-@@ -29,4 +29,4 @@ wine_preloader_OBJS = preloader.o
- wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-
- wine64_preloader_OBJS = preloader.o
--wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
diff --git a/user/xfce4-session/APKBUILD b/user/xfce4-session/APKBUILD
index 05c391a80..4adcf1291 100644
--- a/user/xfce4-session/APKBUILD
+++ b/user/xfce4-session/APKBUILD
@@ -2,17 +2,17 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=xfce4-session
pkgver=4.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="Session management for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
license="GPL-2.0+ AND LGPL-2.0+"
+depends="cmd:which xdg-user-dirs"
makedepends="intltool gtk+3.0-dev libice-dev libsm-dev libxfce4util-dev
libxfce4ui-dev libwnck-dev iceauth dbus-glib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
langdir="/usr/lib/locale"
-source="http://archive.xfce.org/src/xfce/xfce4-session/4.13/xfce4-session-$pkgver.tar.bz2"
-sha512sums="5845e3591919e23ca176199e81075a097ef9d65cbcf23b34d84afc649a307bfa8c6492e3a01855cacff9328da809725213ec1fa9d76024c0a0c25cce3c51da1b xfce4-session-4.13.1.tar.bz2"
+source="https://archive.xfce.org/src/xfce/xfce4-session/4.13/xfce4-session-$pkgver.tar.bz2"
build() {
cd "$builddir"
@@ -36,3 +36,4 @@ package() {
make DESTDIR="$pkgdir" install
}
+sha512sums="5845e3591919e23ca176199e81075a097ef9d65cbcf23b34d84afc649a307bfa8c6492e3a01855cacff9328da809725213ec1fa9d76024c0a0c25cce3c51da1b xfce4-session-4.13.1.tar.bz2"