summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/firefox-esr/APKBUILD4
-rw-r--r--user/thunderbird/APKBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/user/firefox-esr/APKBUILD b/user/firefox-esr/APKBUILD
index 4c9e50068..22b156a49 100644
--- a/user/firefox-esr/APKBUILD
+++ b/user/firefox-esr/APKBUILD
@@ -71,7 +71,7 @@ prepare() {
echo "mk_add_options MOZ_MAKE_FLAGS=\"-j$JOBS\"" >> "$builddir"/mozconfig
case "$CARCH" in
- pmmx|x86*)
+ pmmx|x86*|arm*)
echo "ac_add_options --disable-elf-hack" >> "$builddir"/mozconfig
;;
ppc)
@@ -93,7 +93,7 @@ build() {
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
case "${CARCH}" in
- armv7)
+ pmmx|x86|ppc|i528|m68k|mips32*|arm*)
# 32-bit memory ceiling, #1012
LDFLAGS="${LDFLAGS} -Wl,--strip-debug";
;;
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index ec73faadd..bd69b282f 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -107,7 +107,7 @@ build() {
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
case "${CARCH}" in
- armv7)
+ pmmx|x86|ppc|i528|m68k|mips32*|arm*)
# 32-bit memory ceiling, #1012
LDFLAGS="${LDFLAGS} -Wl,--strip-debug";
;;