summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/kcachegrind/APKBUILD43
-rw-r--r--user/tellico/APKBUILD55
-rw-r--r--user/tellico/btparse-strcasecmp.patch20
-rw-r--r--user/xf86-video-fbdev/APKBUILD34
-rw-r--r--user/youtube-dl/APKBUILD68
5 files changed, 220 insertions, 0 deletions
diff --git a/user/kcachegrind/APKBUILD b/user/kcachegrind/APKBUILD
new file mode 100644
index 000000000..68dc6519c
--- /dev/null
+++ b/user/kcachegrind/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kcachegrind
+pkgver=18.08.3
+pkgrel=0
+pkgdesc="Profile data visualisation tool and call graph viewer"
+url="https://kcachegrind.github.io/html/Home.html"
+arch="all"
+license="GPL-2.0-only"
+depends="binutils graphviz"
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qttools-dev
+ karchive-dev kconfig-dev kcoreaddons-dev kdoctools-dev ki18n-dev kio-dev
+ kwidgetsaddons-dev kxmlgui-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/applications/$pkgver/src/kcachegrind-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="abbbf7ba539da1fa71d31e4603d1b8a76178a48bf503c735ebce9bbc9887e9ec64b2338ce77de2f38114faa27dee51e19af61cf4d3e9fbbe942a417edf2558c1 kcachegrind-18.08.3.tar.xz"
diff --git a/user/tellico/APKBUILD b/user/tellico/APKBUILD
new file mode 100644
index 000000000..a38fa7618
--- /dev/null
+++ b/user/tellico/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=tellico
+pkgver=3.1.3
+pkgrel=0
+pkgdesc="Collection manager"
+url="http://tellico-project.org/"
+arch="all"
+license="GPL-2.0-only OR GPL-3.0-only"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev libxml2-dev libxslt-dev
+ karchive-dev kcodecs-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev
+ kcrash-dev kdoctools-dev kguiaddons-dev khtml-dev ki18n-dev
+ kiconthemes-dev kio-dev kitemmodels-dev kjobwidgets-dev kwallet-dev
+ kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev solid-dev
+
+ kfilemetadata-dev knewstuff-dev libcdio-dev libksane-dev poppler-dev
+ poppler-qt5-dev taglib-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://tellico-project.org/files/tellico-$pkgver.tar.xz
+ btparse-strcasecmp.patch
+ "
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS -std=gnu99" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ # imagejob: needs running X11
+ # htmlexporter: needs plasma desktop
+ # filelisting: needs dbus
+ # tellicoread: needs network
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(filelisting|imagejob|htmlexporter|tellicoread)test'
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9024f423f0685e834ed46e7038c5b95fab5b684aaac00d6298e23493fb4290daeda994faf36a0f04973093a477be5506591e6b0e7f57ef5591fb10953ad8ec5e tellico-3.1.3.tar.xz
+4627e717d67340de6d88f7a21604a66ba236c651a0ae38d9d3569b76ad58c79f046cfd5686dd688de86d6acafc17ba3959902babdc7f00ab8e9d65717c4fab4a btparse-strcasecmp.patch"
diff --git a/user/tellico/btparse-strcasecmp.patch b/user/tellico/btparse-strcasecmp.patch
new file mode 100644
index 000000000..2afd4dec3
--- /dev/null
+++ b/user/tellico/btparse-strcasecmp.patch
@@ -0,0 +1,20 @@
+--- tellico-3.1.3/src/3rdparty/btparse/lex_auxiliary.c.old 2018-09-03 00:35:39.883417043 +0000
++++ tellico-3.1.3/src/3rdparty/btparse/lex_auxiliary.c 2018-11-25 06:07:20.260000000 +0000
+@@ -32,6 +32,7 @@
+ #include "bt_debug.h"
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <ctype.h>
+ #include <stdarg.h>
+ #include <assert.h>
+--- tellico-3.1.3/src/3rdparty/btparse/sym.c.old 2018-09-03 00:35:39.887417131 +0000
++++ tellico-3.1.3/src/3rdparty/btparse/sym.c 2018-11-25 06:07:11.570000000 +0000
+@@ -110,6 +110,7 @@
+ /*#include "bt_config.h"*/
+ #include <stdio.h>
+ #include <string.h>
++#include <strings.h>
+ #include <stdlib.h>
+ #ifdef MEMCHK
+ #include "trax.h"
diff --git a/user/xf86-video-fbdev/APKBUILD b/user/xf86-video-fbdev/APKBUILD
new file mode 100644
index 000000000..628551019
--- /dev/null
+++ b/user/xf86-video-fbdev/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xf86-video-fbdev
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="X.Org driver for video over framebuffers"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libxi-dev util-macros xorgproto-dev xorg-server-dev"
+source="https://www.X.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="c1217b943bbe3301b3c2a8649ed1004c3c67b02607bd56bbc14f6dfa05e7f0184332c81a6a19595514745501ed88526aee932e555779b7c3a8233646b0979448 xf86-video-fbdev-0.5.0.tar.bz2"
diff --git a/user/youtube-dl/APKBUILD b/user/youtube-dl/APKBUILD
new file mode 100644
index 000000000..af5d02712
--- /dev/null
+++ b/user/youtube-dl/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=youtube-dl
+pkgver=2018.11.23
+pkgrel=0
+pkgdesc="Command-line program to download videos from YouTube and many other sites"
+url="https://youtube-dl.org"
+arch="noarch"
+options="!check" # Takes way too long, and uses network
+license="Unlicense AND Public-Domain"
+depends="ffmpeg python3"
+subpackages="$pkgname-doc
+ $pkgname-zsh-completion:zshcomp
+ $pkgname-bash-completion:bashcomp
+ $pkgname-fish-completion:fishcomp"
+source="https://github.com/rg3/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname"
+
+prepare() {
+ default_prepare
+ sed -i \
+ -e 's|etc/bash_completion.d|share/bash-completion/completions|' \
+ -e 's|etc/fish/completions|share/fish/completions|' \
+ "$builddir/setup.py"
+}
+
+check() {
+ cd "$builddir"
+ python3 -m unittest discover
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+zshcomp() {
+ pkgdesc="Zsh completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir/$pkgname.zsh" \
+ "$subpkgdir/usr/share/zsh/site-functions/_$pkgname"
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir/usr/share/bash-completion/completions/"
+ mv "$pkgdir/usr/share/bash-completion/completions/$pkgname.bash-completion" \
+ "$subpkgdir/usr/share/bash-completion/completions/$pkgname"
+}
+
+fishcomp() {
+ pkgdesc="Fish completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ mkdir -p "$subpkgdir/usr/share/fish/completions/"
+ mv "$pkgdir/usr/share/fish/completions/$pkgname.fish" \
+ "$subpkgdir/usr/share/fish/completions/"
+}
+
+sha512sums="d4d2813657972c37d3493743a44055d7a776aeb5c5a97902e07caa317a3b2db30332507c37b56b3d8554e0bdc2a0ec6a9862977b449b363343a4de2df12bf059 youtube-dl-2018.11.23.tar.gz"