summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/libliftoff/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/libliftoff/APKBUILD b/user/libliftoff/APKBUILD
new file mode 100644
index 000000000..f20afd85f
--- /dev/null
+++ b/user/libliftoff/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=libliftoff
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A lightweight KMS plane library"
+url="https://gitlab.freedesktop.org/emersion/libliftoff"
+arch="all"
+license="MIT"
+depends=""
+makedepends="meson libdrm-dev"
+subpackages="$pkgname-dev"
+source="https://gitlab.freedesktop.org/emersion/libliftoff/-/releases/v$pkgver/downloads/libliftoff-$pkgver.tar.gz"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="ce808f6a087f1f629cfebef95bfc7e216a09fb409b96b3c9f6b84d9d986ce50c5d7bf5b45c68e8baa99566b3627d754c269855b6f4ec3be63ae7b9f5109d5f08 libliftoff-0.5.0.tar.gz"