summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/labplot/APKBUILD6
-rw-r--r--user/mosquitto/APKBUILD80
-rw-r--r--user/mosquitto/disable-flaky-test.patch11
-rw-r--r--user/mosquitto/mosquitto.initd36
-rw-r--r--user/mosquitto/mosquitto.pre-install7
-rw-r--r--user/mosquitto/openrc-conf.patch20
-rw-r--r--user/mosquitto/python3.patch48
-rw-r--r--user/pciutils/APKBUILD8
-rw-r--r--user/perl-devel-nytprof/APKBUILD31
-rw-r--r--user/py3-paho-mqtt/APKBUILD33
-rw-r--r--user/py3-paho-mqtt/setup.patch24
-rw-r--r--user/qt5-qtdeclarative/APKBUILD7
-rw-r--r--user/qt5-qtdeclarative/pmmx.patch122
-rw-r--r--user/tmux/APKBUILD8
-rw-r--r--user/tmux/xterm-DECLRMM.patch23
-rw-r--r--user/xterm/APKBUILD2
16 files changed, 453 insertions, 13 deletions
diff --git a/user/labplot/APKBUILD b/user/labplot/APKBUILD
index d6ed5bf7e..0e2d99394 100644
--- a/user/labplot/APKBUILD
+++ b/user/labplot/APKBUILD
@@ -2,10 +2,11 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=labplot
pkgver=2.6
-pkgrel=0
+pkgrel=1
pkgdesc="Interactive tool for graphing and analysis of scientific data"
url="https://www.kde.org/applications/education/labplot2"
arch="all"
+options="!check" # all tests require X11
license="GPL-2.0-only"
depends="shared-mime-info"
makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
@@ -18,7 +19,6 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/labplot/$pkgver.0/labplot-$pkgver.0.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -34,13 +34,11 @@ build() {
}
check() {
- cd "$builddir"
# gives incorrect results
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E fittest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
new file mode 100644
index 000000000..e7cd25057
--- /dev/null
+++ b/user/mosquitto/APKBUILD
@@ -0,0 +1,80 @@
+# Contributor: Pedro Filipe <xpecex@outlook.com>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=mosquitto
+pkgver=1.6.6
+pkgrel=0
+pkgdesc="An Open Source MQTT Broker"
+url="https://mosquitto.org/"
+arch="all"
+license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
+depends=""
+makedepends="c-ares-dev openssl-dev util-linux-dev"
+checkdepends="python3"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc
+ $pkgname-clients"
+install="$pkgname.pre-install"
+source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
+ mosquitto.initd
+ disable-flaky-test.patch
+ openrc-conf.patch
+ python3.patch"
+
+# secfixes:
+# 1.6.6-r0:
+# - CVE-2019-11779
+# 1.5.6-r0:
+# - CVE-2018-12546
+# - CVE-2018-12550
+# - CVE-2018-12551
+# 1.5.3-r0:
+# - CVE-2018-12543
+# 1.4.15-r0:
+# - CVE-2017-7652
+# - CVE-2017-7651
+# 1.4.13-r0:
+# - CVE-2017-9868
+# 1.4.12-r0:
+# - CVE-2017-7650
+
+build() {
+ make \
+ WITH_ADNS=no \
+ WITH_MEMORY_TRACKING=no \
+ WITH_SRV=yes \
+ prefix=/usr
+}
+
+check() {
+ # Unit tests require cunit, so skip them.
+ make -j1 -C test/broker test
+ make -j1 -C test/lib test
+}
+
+package() {
+ make prefix=/usr DESTDIR="$pkgdir" install
+
+ # C++ bindings are deprecated, so don't install them.
+ make -C lib/cpp prefix=/usr DESTDIR="$pkgdir" uninstall
+ rm "$pkgdir"/usr/lib/pkgconfig/libmosquittopp.pc
+
+ mv "$pkgdir"/usr/sbin/mosquitto "$pkgdir"/usr/bin
+ mv "$pkgdir"/etc/mosquitto/mosquitto.conf.example \
+ "$pkgdir"/etc/mosquitto/mosquitto.conf
+
+ install -Dm755 "$srcdir"/mosquitto.initd \
+ "$pkgdir"/etc/init.d/mosquitto
+}
+
+clients() {
+ pkgdesc="Mosquitto command line MQTT clients"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
+}
+
+sha512sums="ea6ba7b57773c8f4a59e708ae305a0e38ca85df94854410b29cccddbe10bbb91c2ea5e827fefb3f57cb4fce188ab9c3021804f1ae398b7fd5e9e965354b68bc1 mosquitto-1.6.6.tar.gz
+681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
+3886171e36f759a717aa6626d5b8dbd392963c737d5de28b4d52b81359008927b99ff7a0ca82f56a0e5deaed4585571759ba9216336a664fd346845837c2bc18 disable-flaky-test.patch
+b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch
+078197e6c3e59b664f5fdd1e4a4f669c9a76ab84fe4a5d8602ac80406b85c4e1cce29d9372e76d995155b74abb438d0dc0cdcdb98251fb904122073c4088d76a python3.patch"
diff --git a/user/mosquitto/disable-flaky-test.patch b/user/mosquitto/disable-flaky-test.patch
new file mode 100644
index 000000000..8fd51c403
--- /dev/null
+++ b/user/mosquitto/disable-flaky-test.patch
@@ -0,0 +1,11 @@
+--- mosquitto-1.6.4/test/broker/Makefile 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/Makefile 2019-08-28 00:03:54.430562623 +0000
+@@ -193,7 +193,7 @@ endif
+ ./10-listener-mount-point.py
+
+ 11 :
+- ./11-message-expiry.py
++ #./11-message-expiry.py
+ ./11-persistent-subscription.py
+ ./11-persistent-subscription-v5.py
+ ./11-persistent-subscription-no-local.py
diff --git a/user/mosquitto/mosquitto.initd b/user/mosquitto/mosquitto.initd
new file mode 100644
index 000000000..818931213
--- /dev/null
+++ b/user/mosquitto/mosquitto.initd
@@ -0,0 +1,36 @@
+#!/sbin/openrc-run
+MOSQUITTO_CFG="${MOSQUITTO_CFG:-/etc/mosquitto/${RC_SVCNAME}.conf}"
+
+command="/usr/bin/mosquitto"
+command_args="-c '${MOSQUITTO_CFG}' $command_args"
+command_args_background="--daemon"
+pidfile="$(awk '$1 == "pid_file" {print $2}' "${MOSQUITTO_CFG}" || true)"
+
+extra_started_commands="reload"
+description_reload="Reload configuration"
+
+start_pre() {
+ if ! [ -e "$MOSQUITTO_CFG" ]; then
+ eerror "$MOSQUITTO_CFG does not exist"
+ return 1
+ fi
+
+ if [ -z "$pidfile" ]; then
+ eerror "${MOSQUITTO_CFG} is missing the pid_file option"
+ return 1
+ fi
+
+ MOSQUITTO_LOG="$(awk '$1 " " $2 == "log_dest file" {print $3}' "${MOSQUITTO_CFG}")"
+ if [ -n "$MOSQUITTO_LOG" ]; then
+ MOSQUITTO_USER="$(awk '$1 == "user" {print $2}' "${MOSQUITTO_CFG}")"
+ MOSQUITTO_USER="${MOSQUITTO_USER:-mosquitto}"
+ checkpath -fm 660 -o "${MOSQUITTO_USER}" \
+ "${MOSQUITTO_LOG}" || return 1
+ fi
+}
+
+reload() {
+ ebegin "Reloading ${RC_SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}
diff --git a/user/mosquitto/mosquitto.pre-install b/user/mosquitto/mosquitto.pre-install
new file mode 100644
index 000000000..ac36da04c
--- /dev/null
+++ b/user/mosquitto/mosquitto.pre-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+groupadd -r mosquitto 2>/dev/null
+useradd -c mosquitto -s /sbin/nologin -g mosquitto \
+ -m -d /var/empty -k /etc/skel -r mosquitto 2>/dev/null
+
+exit 0
diff --git a/user/mosquitto/openrc-conf.patch b/user/mosquitto/openrc-conf.patch
new file mode 100644
index 000000000..d1c5ee04b
--- /dev/null
+++ b/user/mosquitto/openrc-conf.patch
@@ -0,0 +1,20 @@
+--- mosquitto-1.6.4/mosquitto.conf 2019-08-01 14:50:01.000000000 -0500
++++ mosquitto-1.6.4/mosquitto.conf 2019-08-27 18:16:52.290542736 -0500
+@@ -158,7 +158,7 @@
+ # This should be set to /var/run/mosquitto.pid if mosquitto is
+ # being run automatically on boot with an init script and
+ # start-stop-daemon or similar.
+-#pid_file
++pid_file /var/run/mosquitto.pid
+
+ # Set to true to queue messages with QoS 0 when a persistent client is
+ # disconnected. These messages are included in the limit imposed by
+@@ -585,7 +585,7 @@
+ # Note that if the broker is running as a Windows service it will default to
+ # "log_dest none" and neither stdout nor stderr logging is available.
+ # Use "log_dest none" if you wish to disable logging.
+-#log_dest stderr
++log_dest file /var/log/mosquitto.log
+
+ # Types of messages to log. Use multiple log_type lines for logging
+ # multiple types of messages.
diff --git a/user/mosquitto/python3.patch b/user/mosquitto/python3.patch
new file mode 100644
index 000000000..f348cbc3e
--- /dev/null
+++ b/user/mosquitto/python3.patch
@@ -0,0 +1,48 @@
+--- mosquitto-1.6.4/test/broker/09-extended-auth-change-username.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-change-username.py 2019-08-27 22:20:08.560518752 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # Check whether an extended auth plugin can change the username of a client.
+
+--- mosquitto-1.6.4/test/broker/09-extended-auth-multistep-reauth.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-multistep-reauth.py 2019-08-27 22:22:11.530519618 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from mosq_test_helper import *
+
+--- mosquitto-1.6.4/test/broker/09-extended-auth-multistep.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-multistep.py 2019-08-27 22:20:37.030518952 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from mosq_test_helper import *
+
+--- mosquitto-1.6.4/test/broker/09-extended-auth-single.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-single.py 2019-08-27 22:21:42.250519412 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # Multi tests for extended auth with a single step.
+ # * Error in plugin
+--- mosquitto-1.6.4/test/broker/09-extended-auth-single2.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-single2.py 2019-08-27 22:21:02.220519130 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # Multi tests for extended auth with a single step - multiple plugins at once.
+ # * Error in plugin
+--- mosquitto-1.6.4/test/broker/09-extended-auth-unsupported.py.old 2019-08-01 19:50:01.000000000 +0000
++++ mosquitto-1.6.4/test/broker/09-extended-auth-unsupported.py 2019-08-27 22:21:20.360519257 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # Test whether an unsupported extended auth is rejected.
+
diff --git a/user/pciutils/APKBUILD b/user/pciutils/APKBUILD
index f198c08c8..a20e48e9d 100644
--- a/user/pciutils/APKBUILD
+++ b/user/pciutils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=pciutils
pkgver=3.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="PCI bus configuration space access library and tools"
url="http://mj.ucw.cz/pciutils.html"
arch="all"
@@ -35,6 +35,12 @@ package() {
MANDIR="$pkgdir"/usr/share/man \
install install-lib
+ mkdir "$pkgdir"/usr/bin/
+ mv "$pkgdir"/usr/sbin/lspci "$pkgdir"/usr/bin/lspci
+ mkdir "$pkgdir"/usr/share/man/man1
+ mv "$pkgdir"/usr/share/man/man8/lspci.8 \
+ "$pkgdir"/usr/share/man/man1/lspci.1
+
rm "$pkgdir"/usr/sbin/update-pciids
rm "$pkgdir"/usr/share/man/man8/update-pciids.8
rm -r "$pkgdir"/usr/share/hwdata
diff --git a/user/perl-devel-nytprof/APKBUILD b/user/perl-devel-nytprof/APKBUILD
new file mode 100644
index 000000000..e67a2e807
--- /dev/null
+++ b/user/perl-devel-nytprof/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=perl-devel-nytprof
+pkgver=6.06
+pkgrel=0
+pkgdesc="Powerful, fast, feature-rich Perl source code profiler"
+url="https://metacpan.org/release/Devel-NYTProf"
+arch="all"
+license="Artistic-1.0-Perl OR GPL-2.0-only"
+depends="perl perl-file-which perl-json-maybexs"
+makedepends="perl-dev"
+checkdepends="perl-test-differences"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TI/TIMB/Devel-NYTProf-$pkgver.tar.gz"
+builddir="$srcdir/Devel-NYTProf-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="e1fdab3208646ff9283eb606b856f0c25025479b55eddecadfdb7f9b2a9db144c003713b8abf333d03fb8ba420b7f3fbc885de360cd815d72e73ae3bffc27426 Devel-NYTProf-6.06.tar.gz"
diff --git a/user/py3-paho-mqtt/APKBUILD b/user/py3-paho-mqtt/APKBUILD
new file mode 100644
index 000000000..cda723c76
--- /dev/null
+++ b/user/py3-paho-mqtt/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-paho-mqtt
+_pkgname=paho.mqtt.python
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="MQTT version 3.1.1 client class for Python"
+url="https://www.eclipse.org/paho/"
+# Certified net clean
+arch="noarch"
+license="EPL-1.0 AND EDL-1.0"
+depends="python3"
+makedepends=""
+checkdepends="py3-pytest"
+# Use GitHub tarball since PyPI doesn't include tests
+source="$pkgname-$pkgver.tar.gz::https://github.com/eclipse/paho.mqtt.python/archive/v$pkgver.tar.gz
+ setup.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$builddir"/src pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2e49f0f146207ab4fbc8c346b10d3e2b50869b2d9db7c999b6645f7213fb635b64cff01c5405e7833a8b25334d24685ce6ed734a6e4b6b0660b48f65cf4a941c py3-paho-mqtt-1.4.0.tar.gz
+0cfff826651b36b5062dae8bad3abcab428dc18bfcee6c941a46f5c8900c871bd475d96fa382e06d731ea451ad9159edadf0ee3767f7dea992cb7a7ed7313d80 setup.patch"
diff --git a/user/py3-paho-mqtt/setup.patch b/user/py3-paho-mqtt/setup.patch
new file mode 100644
index 000000000..70ccc869f
--- /dev/null
+++ b/user/py3-paho-mqtt/setup.patch
@@ -0,0 +1,24 @@
+--- paho.mqtt.python-1.4.0/setup.py 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.py 2019-08-28 02:51:55.690633661 +0000
+@@ -11,9 +11,8 @@ with open('README.rst', 'rb') as readme_
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama']
+-needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+-setup_requirements = ['pytest-runner'] if needs_pytest else []
++test_requirements = ['pytest']
++setup_requirements = []
+
+ if sys.version_info < (3, 0):
+ test_requirements += ['mock']
+--- paho.mqtt.python-1.4.0/setup.cfg 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.cfg 2019-08-28 02:50:19.540632984 +0000
+@@ -1,7 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
+ strict=True
+ testpaths=tests src
+ [pylama]
diff --git a/user/qt5-qtdeclarative/APKBUILD b/user/qt5-qtdeclarative/APKBUILD
index 3b9b56a89..38d6e1bb1 100644
--- a/user/qt5-qtdeclarative/APKBUILD
+++ b/user/qt5-qtdeclarative/APKBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-qtdeclarative
_pkgname=${pkgname#qt5-}-opensource-src
pkgver=5.9.7
-pkgrel=0
+pkgrel=1
pkgdesc="Qt 5 - Qt Declarative and Qt Quick 2"
url="https://www.qt.io/"
arch="all"
@@ -11,6 +11,7 @@ makedepends="qt5-qtbase-dev libexecinfo-dev python3"
subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
add-execinfo.patch
+ pmmx.patch
python3.patch
"
@@ -18,17 +19,14 @@ _qt5_prefix=/usr/lib/qt5
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
qmake && make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install INSTALL_ROOT="$pkgdir"
mkdir -p "$pkgdir"/usr/bin/
@@ -39,4 +37,5 @@ package() {
sha512sums="bccddeca26c317083fcebc182dd3221dcbe9af665c502bfb636907f2c17a6edd8874a964910423c9eaa6e5c68bf5a13520193ba77f915be08ba1982348d2a9ee qtdeclarative-opensource-src-5.9.7.tar.xz
065ab2440fd0a81e76fe8873b0991929fad3d4189c8938e0205e94478a6cdce81ef710e3bad19cd5ca0b5ea0f8b3cd1b366969ddede51070496d1d02ace59220 add-execinfo.patch
+07bad5742bf00acadc6f2d5e1b8756b9545b95ad93d2b16646c0031abec881bfab6e1c39ca2f1b0a4e43d716518bd4380fd45995a9597d9ce1b51f88f9379176 pmmx.patch
c434ec3b3eaa8859cc3a3ce48d0299533428d94c998876e5735c210b25f89bc8509980cee0d96f2e68331540f95b5f1ec5e9745949d26367bde1d15bc7ac9081 python3.patch"
diff --git a/user/qt5-qtdeclarative/pmmx.patch b/user/qt5-qtdeclarative/pmmx.patch
new file mode 100644
index 000000000..a4ce84650
--- /dev/null
+++ b/user/qt5-qtdeclarative/pmmx.patch
@@ -0,0 +1,122 @@
+From 4950c366b12265f1ea390a6feb8dbbd0d850d206 Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@hadrons.org>
+Date: Mon, 12 Oct 2015 01:45:37 +0200
+Subject: [PATCH v2] Do not make lack of SSE2 support on x86-32 fatal
+
+When an x86-32 CPU does not have SSE2 support (which is the case for
+all AMD CPUs, and older Intel CPUs), fallback to use the interpreter,
+otherwise use the JIT engine.
+
+Even then, make the lack of SSE2 support on x86-32 fatal when trying
+to instantiate a JIT engine, which does require it.
+
+Refactor the required CPU support check into a new pair of privately
+exported functions to avoid duplicating the logic, and do so in
+functions instead of class members to avoid changing the class
+signatures.
+
+Version: 5.7.x
+Bug-Debian: https://bugs.debian.org/792594
+---
+ src/qml/jit/qv4isel_masm.cpp | 2 ++
+ src/qml/jit/qv4isel_masm_p.h | 18 ++++++++++++++++++
+ src/qml/jsruntime/qv4engine.cpp | 1 +
+ src/qml/qml/v8/qv8engine.cpp | 7 -------
+ tools/qmljs/qmljs.cpp | 7 +++----
+ 5 files changed, 24 insertions(+), 11 deletions(-)
+
+--- a/src/qml/jit/qv4isel_masm.cpp
++++ b/src/qml/jit/qv4isel_masm.cpp
+@@ -72,6 +72,8 @@ InstructionSelection<JITAssembler>::Inst
+ , compilationUnit(new CompilationUnit)
+ , qmlEngine(qmlEngine)
+ {
++ checkRequiredCpuSupport();
++
+ compilationUnit->codeRefs.resize(module->functions.size());
+ module->unitFlags |= QV4::CompiledData::Unit::ContainsMachineCode;
+ }
+--- a/src/qml/jit/qv4isel_masm_p.h
++++ b/src/qml/jit/qv4isel_masm_p.h
+@@ -60,6 +60,7 @@
+
+ #include <QtCore/QHash>
+ #include <QtCore/QStack>
++#include <private/qsimd_p.h>
+ #include <config.h>
+ #include <wtf/Vector.h>
+
+@@ -72,6 +73,23 @@ QT_BEGIN_NAMESPACE
+ namespace QV4 {
+ namespace JIT {
+
++Q_QML_PRIVATE_EXPORT inline bool hasRequiredCpuSupport()
++{
++#ifdef Q_PROCESSOR_X86_32
++ return qCpuHasFeature(SSE2);
++#else
++ return true;
++#endif
++}
++
++Q_QML_PRIVATE_EXPORT inline void checkRequiredCpuSupport()
++{
++#ifdef Q_PROCESSOR_X86_32
++ if (!qCpuHasFeature(SSE2))
++ qFatal("This program requires an X86 processor that supports SSE2 extension, at least a Pentium 4 or newer");
++#endif
++}
++
+ template <typename JITAssembler = Assembler<DefaultAssemblerTargetConfiguration>>
+ class Q_QML_EXPORT InstructionSelection:
+ protected IR::IRDecoder,
+--- a/src/qml/jsruntime/qv4engine.cpp
++++ b/src/qml/jsruntime/qv4engine.cpp
+@@ -159,6 +159,7 @@
+
+ #ifdef V4_ENABLE_JIT
+ static const bool forceMoth = !qEnvironmentVariableIsEmpty("QV4_FORCE_INTERPRETER") ||
++ !JIT::hasRequiredCpuSupport() ||
+ !OSAllocator::canAllocateExecutableMemory();
+ if (forceMoth) {
+ factory = new Moth::ISelFactory;
+--- a/src/qml/qml/v8/qv8engine.cpp
++++ b/src/qml/qml/v8/qv8engine.cpp
+@@ -64,7 +64,6 @@
+ #include <QtCore/qjsonvalue.h>
+ #include <QtCore/qdatetime.h>
+ #include <QtCore/qdatastream.h>
+-#include <private/qsimd_p.h>
+
+ #include <private/qv4value_p.h>
+ #include <private/qv4dateobject_p.h>
+@@ -129,12 +128,6 @@ QV8Engine::QV8Engine(QJSEngine* qq)
+ , m_xmlHttpRequestData(0)
+ , m_listModelData(0)
+ {
+-#ifdef Q_PROCESSOR_X86_32
+- if (!qCpuHasFeature(SSE2)) {
+- qFatal("This program requires an X86 processor that supports SSE2 extension, at least a Pentium 4 or newer");
+- }
+-#endif
+-
+ QML_MEMORY_SCOPE_STRING("QV8Engine::QV8Engine");
+ qMetaTypeId<QJSValue>();
+ qMetaTypeId<QList<int> >();
+--- a/tools/qmljs/qmljs.cpp
++++ b/tools/qmljs/qmljs.cpp
+@@ -92,11 +92,10 @@ int main(int argc, char *argv[])
+ enum {
+ use_masm,
+ use_moth
+- } mode;
++ } mode = use_moth;
+ #ifdef V4_ENABLE_JIT
+- mode = use_masm;
+-#else
+- mode = use_moth;
++ if (QV4::JIT::hasRequiredCpuSupport())
++ mode = use_masm;
+ #endif
+
+ bool runAsQml = false;
diff --git a/user/tmux/APKBUILD b/user/tmux/APKBUILD
index 1748375c1..ebd0a38c0 100644
--- a/user/tmux/APKBUILD
+++ b/user/tmux/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=tmux
pkgver=2.7
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io/"
arch="all"
@@ -10,7 +10,8 @@ license="MIT"
depends="ncurses-terminfo"
makedepends="bsd-compat-headers libevent-dev libutempter-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ xterm-DECLRMM.patch"
build() {
./configure \
@@ -37,4 +38,5 @@ package() {
done
}
-sha512sums="7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37 tmux-2.7.tar.gz"
+sha512sums="7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37 tmux-2.7.tar.gz
+7fb006f8f24d60614fcaeadace933c2ad6674d2476980736a830f63a40d7110638942478322336849d47707c99ab7de0cb01ff39806a4c9144650daf2f666773 xterm-DECLRMM.patch"
diff --git a/user/tmux/xterm-DECLRMM.patch b/user/tmux/xterm-DECLRMM.patch
new file mode 100644
index 000000000..b9bef3455
--- /dev/null
+++ b/user/tmux/xterm-DECLRMM.patch
@@ -0,0 +1,23 @@
+From 26f274011096b9eacfd2753d8f7afcb63e796ab9 Mon Sep 17 00:00:00 2001
+From: nicm <nicm>
+Date: Thu, 1 Aug 2019 11:45:34 +0000
+Subject: [PATCH] xterm 348 now disables margins when resized, so send DECLRMM
+ again.
+
+---
+ tty.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tty.c b/tty.c
+index ab1da9fd3..024aef271 100644
+--- a/tty.c
++++ b/tty.c
+@@ -1879,6 +1879,8 @@ tty_invalidate(struct tty *tty)
+ tty->rlower = tty->rright = UINT_MAX;
+
+ if (tty->flags & TTY_STARTED) {
++ if (tty_use_margin(tty))
++ tty_puts(tty, "\033[?69h"); /* DECLRMM */
+ tty_putcode(tty, TTYC_SGR0);
+
+ tty->mode = ALL_MODES;
diff --git a/user/xterm/APKBUILD b/user/xterm/APKBUILD
index 06c3a8dba..d1d870a8a 100644
--- a/user/xterm/APKBUILD
+++ b/user/xterm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=xterm
pkgver=348
-pkgrel=1
+pkgrel=3
pkgdesc="An X-based terminal emulator"
url="https://invisible-island.net/xterm/"
arch="all"