summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/ant/APKBUILD58
-rw-r--r--user/ant/ant.sh3
-rw-r--r--user/ant/imageio_fix_java_test.patch26
-rw-r--r--user/ant/imageio_fix_test.patch23
-rw-r--r--user/eudev/APKBUILD14
-rw-r--r--user/java-common/APKBUILD4
-rw-r--r--user/libfm-extra/APKBUILD4
-rw-r--r--user/libfm/APKBUILD18
-rw-r--r--user/libfm/without-extra.patch75
-rw-r--r--user/quassel/APKBUILD9
-rw-r--r--user/quassel/unterminated-mIRC-codes.patch40
-rw-r--r--user/rrdtool/APKBUILD10
-rw-r--r--user/rrdtool/disable-rpn2.patch35
-rw-r--r--user/rrdtool/no-posix-fallocate.patch12
-rw-r--r--user/sane/APKBUILD13
-rw-r--r--user/vlc/APKBUILD131
16 files changed, 318 insertions, 157 deletions
diff --git a/user/ant/APKBUILD b/user/ant/APKBUILD
new file mode 100644
index 000000000..8afaf5929
--- /dev/null
+++ b/user/ant/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Steeve Chailloux <steeve@chaahk.com>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=ant
+pkgver=1.10.6
+pkgrel=0
+pkgdesc="Java-based build tool"
+url="http://ant.apache.org/"
+arch="noarch"
+license="Apache-2.0"
+makedepends=""
+depends="openjdk8"
+source="https://www-eu.apache.org/dist/ant/source/apache-$pkgname-$pkgver-src.tar.gz
+ ant.sh
+ imageio_fix_java_test.patch
+ imageio_fix_test.patch"
+builddir="$srcdir/apache-$pkgname-$pkgver"
+
+_anthome="/usr/lib/java/$pkgname"
+
+build() {
+ sh ./bootstrap.sh
+ ./bootstrap/bin/ant dist-lite
+}
+
+check() {
+ ./bootstrap/bin/ant test
+}
+
+package() {
+ local destdir="$pkgdir/$_anthome"
+
+ install -dm755 "$destdir"/bin
+ rm dist/bin/*.bat dist/bin/*.cmd
+ install -m755 dist/bin/* "$destdir"/bin
+
+ install -dm755 "$pkgdir"/usr/bin
+ ln -sf $_anthome/bin/ant "$pkgdir"/usr/bin/ant
+
+ install -dm755 "$destdir"/lib
+ install -m644 dist/lib/*.jar "$destdir"/lib
+
+ # symlink to junit so it's on the javac build path for ant
+ # matches behavior on ubuntu 9 and makes sense for compatibility
+ ln -sf ../../junit.jar "$destdir"/lib/junit.jar
+
+ # The license says the NOTICE file should be redistributed for
+ # derivative works, so lets supply it.
+ install -m644 -D NOTICE "$pkgdir"/usr/share/licenses/$pkgname/NOTICE
+
+ install -m644 -D $srcdir/$pkgname.sh "$pkgdir"/etc/profile.d/$pkgname.sh
+}
+
+sha512sums="2bef0cf5f53ce9fa6e9dc7a673745f75bcd0df027f9ff07442cf66bc8d7d99e022153b08d20d314061b497763e85d587c3087952b3f5730e5a19b2656f3236fb apache-ant-1.10.6-src.tar.gz
+955fe52b415d57716df1338eff6d667d80e06a67bffd53def7d63d96f1224157b724a92df647afe8b3243dea749e221aec1e86d5be01060408fa000ec1132374 ant.sh
+9a698041a06ccc6db7765133fc6fabc6f2d0e70b96ff9de594bd836fc05ac33f489968a4fdd12fe044458eb3b99e905ca1e2a62a55acdbacebff9782c82a27de imageio_fix_java_test.patch
+1457c7415df1e80c8763b4db9f41cbdebfa58e17bcd263dae9ce31f9ee601650b51a893e4e0a324c974b60a6c2076fddfd78180baca0bcdbff65e9e88b30e063 imageio_fix_test.patch"
diff --git a/user/ant/ant.sh b/user/ant/ant.sh
new file mode 100644
index 000000000..bab7b972d
--- /dev/null
+++ b/user/ant/ant.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+ANT_HOME="/usr/share/java/ant"
+export ANT_HOME
diff --git a/user/ant/imageio_fix_java_test.patch b/user/ant/imageio_fix_java_test.patch
new file mode 100644
index 000000000..4fa856e73
--- /dev/null
+++ b/user/ant/imageio_fix_java_test.patch
@@ -0,0 +1,26 @@
+diff --git a/src/tests/junit/org/apache/tools/ant/taskdefs/optional/image/ImageIOTest.java b/src/tests/junit/org/apache/tools/ant/taskdefs/optional/image/ImageIOTest.java
+index c96691d..e8cfd29 100644
+--- a/src/tests/junit/org/apache/tools/ant/taskdefs/optional/image/ImageIOTest.java
++++ b/src/tests/junit/org/apache/tools/ant/taskdefs/optional/image/ImageIOTest.java
+@@ -86,21 +86,6 @@ public class ImageIOTest {
+ assertTrue("File was not overwritten.", lastModified < overwrittenLastModified);
+ }
+
+- @Test
+- public void testDrawOverwriteTrue() {
+- buildRule.executeTarget("testSimpleScale");
+- assertThat(buildRule.getLog(), containsString("Processing File"));
+- File f = new File(buildRule.getOutputDir(), LARGEIMAGE);
+- assumeTrue("Could not change file modification date",
+- f.setLastModified(f.lastModified() - FILE_UTILS.getFileTimestampGranularity() * 2));
+- long lastModified = f.lastModified();
+- buildRule.executeTarget("testDrawOverwriteTrue");
+- assertThat(buildRule.getLog(), containsString("Processing File"));
+- f = new File(buildRule.getOutputDir(), LARGEIMAGE);
+- long overwrittenLastModified = f.lastModified();
+- assertTrue("File was not overwritten.", lastModified < overwrittenLastModified);
+- }
+-
+ @Test
+ public void testOverwriteFalse() {
+ buildRule.executeTarget("testSimpleScale");
diff --git a/user/ant/imageio_fix_test.patch b/user/ant/imageio_fix_test.patch
new file mode 100644
index 000000000..ad3cc3e67
--- /dev/null
+++ b/user/ant/imageio_fix_test.patch
@@ -0,0 +1,23 @@
+diff --git a/src/etc/testcases/taskdefs/optional/image/imageio.xml b/src/etc/testcases/taskdefs/optional/image/imageio.xml
+index a7d6a23..0f0318b 100644
+--- a/src/etc/testcases/taskdefs/optional/image/imageio.xml
++++ b/src/etc/testcases/taskdefs/optional/image/imageio.xml
+@@ -59,18 +59,6 @@
+ </imageio>
+ </target>
+
+- <!-- this should produce a single file in the dest dir, overwriting any existing file -->
+- <target name="testDrawOverwriteTrue" depends="setUp">
+- <imageio includes="*.jpg" srcdir="${src.dir}" destdir="${output}"
+- overwrite="yes" failonerror="no">
+- <scale width="300" proportions="width"/>
+- <draw xloc="10" yloc="10">
+- <rectangle height="50" width="50" strokewidth="2"/>
+- <text string="Test"/>
+- </draw>
+- </imageio>
+- </target>
+-
+ <!-- this should not overwrite the existing file -->
+ <target name="testOverwriteFalse" depends="setUp">
+ <imageio includes="*.jpg" srcdir="${src.dir}" destdir="${output}"
diff --git a/user/eudev/APKBUILD b/user/eudev/APKBUILD
index 5b9aa2526..f1cc65903 100644
--- a/user/eudev/APKBUILD
+++ b/user/eudev/APKBUILD
@@ -2,21 +2,20 @@
# Maintainer:
pkgname=eudev
pkgver=3.2.7
-pkgrel=0
+pkgrel=1
pkgdesc="OpenRC compatible fork of systemd-udev"
url="https://wiki.gentoo.org/wiki/Project:Eudev"
arch="all"
options="!checkroot"
license="GPL-2.0-only"
depends=""
-depends_dev=""
-replaces="udev udev-init-scripts"
-provides="udev=176"
makedepends="gperf glib-dev linux-headers kmod-dev gobject-introspection-dev
util-linux-dev"
checkdepends="tree xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc
$pkgname-netifnames::noarch"
+provides="udev=176"
+replaces="udev udev-init-scripts"
source="http://dev.gentoo.org/~blueness/$pkgname/$pkgname-$pkgver.tar.gz
default-rules.patch
load-fbcon.patch
@@ -102,6 +101,13 @@ netifnames() {
openrc() {
replaces="udev-init-scripts-openrc"
default_openrc
+ install -d "$subpkgdir"/usr/share/runlevels/openrc/sysinit
+ # https://bts.adelielinux.org/show_bug.cgi?id=51
+ # if eudev is installed, it should be running in the sysinit runlevel
+ ln -s /etc/init.d/udev \
+ "$subpkgdir"/usr/share/runlevels/openrc/sysinit/udev
+ ln -s /etc/init.d/udev-trigger \
+ "$subpkgdir"/usr/share/runlevels/openrc/sysinit/udev-trigger
}
sha512sums="e6c8ec86ae434c967f6a568fa0b281229bb87be7e3fec025dc3e0225de7843ffaa5dd65bdeffefbc91e9e2911aa3de9df84c76148fe8863ff60fba4c88653c40 eudev-3.2.7.tar.gz
diff --git a/user/java-common/APKBUILD b/user/java-common/APKBUILD
index 3ebb6a864..da94e271c 100644
--- a/user/java-common/APKBUILD
+++ b/user/java-common/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=java-common
pkgver=7
-pkgrel=0
+pkgrel=1
pkgdesc="Default Java runtime binary symlinks"
url=" "
arch="noarch"
options="!check" # Symlinks only.
license="Public-Domain"
-depends=""
+depends="nss" # for TLS, needed by all OpenJDKs.
makedepends=""
subpackages=""
source="java.profd"
diff --git a/user/libfm-extra/APKBUILD b/user/libfm-extra/APKBUILD
index 18a9ddb73..775b4d322 100644
--- a/user/libfm-extra/APKBUILD
+++ b/user/libfm-extra/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libfm-extra
-pkgver=1.3.0.2
+pkgver=1.3.1
pkgrel=0
pkgdesc="Library for generating menu caches"
url="https://wiki.lxde.org/en/PCManFM"
@@ -33,4 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="179cc0350509cb1a8a60b89f8145169857926c7cc3dadb9f61078d4dba79709b248b3d05862e78c11747f1fc4e45825ad6f4916d423ae5e346e5274d34197445 libfm-1.3.0.2.tar.xz"
+sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14 libfm-1.3.1.tar.xz"
diff --git a/user/libfm/APKBUILD b/user/libfm/APKBUILD
index fc1021a8e..ad75ec5d9 100644
--- a/user/libfm/APKBUILD
+++ b/user/libfm/APKBUILD
@@ -2,19 +2,21 @@
# Maintainer:
pkgname=libfm
pkgver=1.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0+"
makedepends="dbus-glib-dev glib-dev gtk+2.0-dev intltool libexif-dev
- menu-cache-dev udisks2-dev"
+ libfm-extra-dev menu-cache-dev udisks2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-replaces="libfm-extra"
-source="https://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz"
+source="https://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz
+ without-extra.patch
+ "
build() {
cd "$builddir"
+ mv data/libfm.conf data/libfm.conf.sample
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -33,9 +35,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-dev() {
- default_dev
- replaces="libfm-extra-dev"
-}
-
-sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14 libfm-1.3.1.tar.xz"
+sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14 libfm-1.3.1.tar.xz
+776559307e796309a0a68173292d4ce91c3a241a0e8310a04a96856949677f2f7f8527ae463e4438d635ebe93676dda923a2deed5b76aba007b00093e3a5a109 without-extra.patch"
diff --git a/user/libfm/without-extra.patch b/user/libfm/without-extra.patch
new file mode 100644
index 000000000..c6e86d5e7
--- /dev/null
+++ b/user/libfm/without-extra.patch
@@ -0,0 +1,75 @@
+--- libfm-1.3.1/Makefile.in.old 2018-12-17 19:18:43.000000000 +0000
++++ libfm-1.3.1/Makefile.in 2019-06-04 01:33:11.797284687 +0000
+@@ -461,7 +461,7 @@
+ docs/reference/libfm/version.xml.in
+
+ pkgconfigdir = $(libdir)/pkgconfig
+-pkgconfig_DATA = libfm-extra.pc $(am__append_5)
++pkgconfig_DATA = $(am__append_5)
+ @EXTRALIB_ONLY_FALSE@SUBDIRS = $(DIST_SUBDIRS) $(am__append_3)
+ @EXTRALIB_ONLY_TRUE@SUBDIRS = src $(am__append_3)
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+--- libfm-1.3.1/data/Makefile.in.old 2018-12-17 19:18:43.000000000 +0000
++++ libfm-1.3.1/data/Makefile.in 2019-06-04 01:38:26.663631036 +0000
+@@ -406,7 +406,7 @@
+ mime_DATA = libfm.xml
+ libfmconfdir = $(sysconfdir)/xdg/libfm
+ libfmconf_DATA = \
+- libfm.conf \
++ libfm.conf.sample \
+ $(NULL)
+
+ desktop_in_files = \
+--- libfm-1.3.1/src/Makefile.in.old 2018-12-17 19:18:44.000000000 +0000
++++ libfm-1.3.1/src/Makefile.in 2019-06-04 01:35:34.592026293 +0000
+@@ -909,14 +909,14 @@
+ @EXTRALIB_ONLY_FALSE@ gtk/fm-thumbnail.h \
+ @EXTRALIB_ONLY_FALSE@ $(NULL)
+
+-LIBFM_EXTRA_INCLUDES = \
+- fm-extra.h \
+- fm-version.h \
+- extra/fm-xml-file.h \
+- $(NULL)
++@EXTRALIB_ONLY_TRUE@LIBFM_EXTRA_INCLUDES = \
++@EXTRALIB_ONLY_TRUE@ fm-extra.h \
++@EXTRALIB_ONLY_TRUE@ fm-version.h \
++@EXTRALIB_ONLY_TRUE@ extra/fm-xml-file.h \
++@EXTRALIB_ONLY_TRUE@ $(NULL)
+
+ EXTRA_LTLIBRARIES = libfm-gtk.la libfm-gtk3.la
+-@EXTRALIB_ONLY_FALSE@lib_LTLIBRARIES = libfm-extra.la libfm.la @LIBFM_GTK_LTLIBRARIES@
++@EXTRALIB_ONLY_FALSE@lib_LTLIBRARIES = libfm.la @LIBFM_GTK_LTLIBRARIES@
+ @EXTRALIB_ONLY_TRUE@lib_LTLIBRARIES = libfm-extra.la
+ libfm_la_SOURCES = \
+ $(libfm_SOURCES) \
+@@ -1059,7 +1059,7 @@
+ @ENABLE_DEMO_TRUE@ $(GTK_LIBS) \
+ @ENABLE_DEMO_TRUE@ $(INTLLIBS) \
+ @ENABLE_DEMO_TRUE@ libfm.la \
+-@ENABLE_DEMO_TRUE@ libfm-extra.la \
++@ENABLE_DEMO_TRUE@ -lfm-extra \
+ @ENABLE_DEMO_TRUE@ @LIBFM_GTK_LTLIBRARIES@ \
+ @ENABLE_DEMO_TRUE@ $(NULL)
+
+--- libfm-1.3.1/src/modules/Makefile.in.old 2018-12-17 19:18:44.000000000 +0000
++++ libfm-1.3.1/src/modules/Makefile.in 2019-06-04 01:37:50.457501640 +0000
+@@ -180,8 +180,7 @@
+ $(gtk_menu_trash_la_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) \
+ -o $@
+ @ENABLE_GTK_TRUE@am_gtk_menu_trash_la_rpath = -rpath $(pkglibdir)
+-vfs_menu_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+- $(top_builddir)/src/libfm-extra.la
++vfs_menu_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ vfs_menu_la_SOURCES = vfs-menu.c
+ vfs_menu_la_OBJECTS = vfs_menu_la-vfs-menu.lo
+ vfs_menu_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
+@@ -459,7 +458,7 @@
+
+ # module-specific parameters
+ vfs_menu_la_CFLAGS = $(MENU_CACHE_CFLAGS) -I$(top_srcdir)/src/extra
+-vfs_menu_la_LIBADD = $(MENU_CACHE_LIBS) $(top_builddir)/src/libfm-extra.la
++vfs_menu_la_LIBADD = $(MENU_CACHE_LIBS) -lfm-extra
+ gtk_fileprop_x_desktop_la_CFLAGS = $(GTK_CFLAGS) -I$(top_srcdir)/src/gtk
+ gtk_fileprop_x_desktop_la_LIBADD = $(GTK_LIBS)
+ gtk_fileprop_x_shortcut_la_CFLAGS = $(GTK_CFLAGS) -I$(top_srcdir)/src/gtk
diff --git a/user/quassel/APKBUILD b/user/quassel/APKBUILD
index 695fd4e4b..f9f583de7 100644
--- a/user/quassel/APKBUILD
+++ b/user/quassel/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=quassel
pkgver=0.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="Modern, cross-platform IRC client"
url="https://quassel-irc.org/"
arch="all"
@@ -14,7 +14,9 @@ makedepends="qt5-qtbase-dev qt5-qtmultimedia-dev libdbusmenu-qt-dev sonnet-dev
kwidgetsaddons-dev qca-dev qt5-qttools-dev zlib-dev libexecinfo-dev"
langdir="/usr/share/quassel/translations"
subpackages="$pkgname-core $pkgname-client $pkgname-lang"
-source="https://quassel-irc.org/pub/quassel-$pkgver.tar.bz2"
+source="https://quassel-irc.org/pub/quassel-$pkgver.tar.bz2
+ unterminated-mIRC-codes.patch
+ "
# secfixes:
# 0.12.5-r0:
@@ -74,4 +76,5 @@ core() {
mv "$pkgdir"/usr/bin/quasselcore "$subpkgdir"/usr/bin/
}
-sha512sums="4ed55e81b1638c8851ddae5d9c9d23a1c2cea92f307e19f426873c2600d8e183898d3ed7c290f2ea5d1b8c5e1be7f9ffcc3e8c3c0193d080fc879b10cc3a962c quassel-0.13.1.tar.bz2"
+sha512sums="4ed55e81b1638c8851ddae5d9c9d23a1c2cea92f307e19f426873c2600d8e183898d3ed7c290f2ea5d1b8c5e1be7f9ffcc3e8c3c0193d080fc879b10cc3a962c quassel-0.13.1.tar.bz2
+7f5ffa64d0620061ac2b6eab2e163d5862d43b16e3d7572415b5819f9ee19a5482791c3cee20c3b99722f05ffed3f1f3ba6c82e7f78b6bea9170037675dd3b4a unterminated-mIRC-codes.patch"
diff --git a/user/quassel/unterminated-mIRC-codes.patch b/user/quassel/unterminated-mIRC-codes.patch
new file mode 100644
index 000000000..8cedeb461
--- /dev/null
+++ b/user/quassel/unterminated-mIRC-codes.patch
@@ -0,0 +1,40 @@
+From 391cdf6c2595060ff3b2adb54f5b2fc8ebd7cc04 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Mon, 3 Jun 2019 00:16:30 -0500
+Subject: [PATCH] multilineedit: handle unterminated mIRC codes
+
+Currently, if an unterminated mIRC code is pasted into Quassel, trying to
+go through input line history will cause a deadlock. This breaks the loop
+at the cost of possibly mangling the formatting of the line somewhat.
+This is seen as more acceptable than locking up, and the line is invalid
+anyway.
+
+Reproducer:
+
+```sh
+printf '\00303,08HONK' | xclip -selection clipboard
+```
+
+Paste into Quassel, send, press Up arrow key.
+---
+ src/uisupport/multilineedit.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/uisupport/multilineedit.cpp b/src/uisupport/multilineedit.cpp
+index 133a2433..b13834c5 100644
+--- a/src/uisupport/multilineedit.cpp
++++ b/src/uisupport/multilineedit.cpp
+@@ -645,6 +645,10 @@ QString MultiLineEdit::convertMircCodesToHtml(const QString &text)
+ }
+
+ posRight = text.indexOf(mircCode.cap(), posRight + 1);
++ if (posRight == -1) {
++ words << text.mid(posLeft);
++ break; // unclosed color code; can't process
++ }
+ words << text.mid(posLeft, posRight + 1 - posLeft);
+ posLeft = posRight + 1;
+ }
+--
+2.21.0
+
diff --git a/user/rrdtool/APKBUILD b/user/rrdtool/APKBUILD
index f61223adc..bec89b8ca 100644
--- a/user/rrdtool/APKBUILD
+++ b/user/rrdtool/APKBUILD
@@ -1,19 +1,20 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=rrdtool
-pkgver=1.7.1
+pkgver=1.7.2
pkgrel=0
pkgdesc="Data logging and graphing application"
url="https://oss.oetiker.ch/rrdtool/"
arch="all"
-options="!check" # Tests fail because of CET time zone begin date changing.
license="GPL-2.0+"
depends="font-sony-misc"
+checkdepends="bc"
makedepends="cairo-dev freetype-dev groff libart-lgpl-dev libpng-dev
libxml2-dev pango-dev perl-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang perl-rrd:perl_rrd
$pkgname-cached $pkgname-cgi $pkgname-utils librrd:libs"
source="https://oss.oetiker.ch/$pkgname/pub/$pkgname-$pkgver.tar.gz
+ disable-rpn2.patch
rrdcached.initd
"
@@ -33,7 +34,7 @@ build() {
check() {
cd "$builddir"
- make check
+ LANG=C.UTF-8 LC_ALL=C.UTF-8 TZ=UTC make check
}
package() {
@@ -86,5 +87,6 @@ utils() {
"$subpkgdir"/usr/bin
}
-sha512sums="ee5c9ff234493442ccd9bfc7031700483011de3e05c01e026509b699cb0d7d3e286e2046357c5fff5807f3e709043c8f218b48b43f8b126a23e228a3927d7b14 rrdtool-1.7.1.tar.gz
+sha512sums="453230efc68aeb4a12842d20a9d246ba478a79c2f6bfd9693a91837c1c1136abe8af177be64fe29aa40bf84ccfce7f2f15296aefe095e89b8b62aef5a7623e29 rrdtool-1.7.2.tar.gz
+47fbfa1ee974d607c15d7a49b1007ccfb6dcd2764f82236f8741b96fe1c3cdec8535f570116a2b24767e09c018177bd5ace4f2ceb39342b2baf3baec01a35dc1 disable-rpn2.patch
c0c27b2c2dfa8e7ec1cb1160d2bda8d7996bbea67f4ce7779da029f583c35e5e415cf46e2a1e5cb8ed2e63d2c58a68fd7471ee6bd820db4c0f4eeeb5c252f8a3 rrdcached.initd"
diff --git a/user/rrdtool/disable-rpn2.patch b/user/rrdtool/disable-rpn2.patch
new file mode 100644
index 000000000..1baed862c
--- /dev/null
+++ b/user/rrdtool/disable-rpn2.patch
@@ -0,0 +1,35 @@
+https://github.com/oetiker/rrdtool-1.x/issues/1012
+--- rrdtool-1.7.2/tests/Makefile.in.old 2019-05-27 18:46:42.000000000 +0000
++++ rrdtool-1.7.2/tests/Makefile.in 2019-06-04 06:27:36.143871636 +0000
+@@ -537,7 +537,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ TESTS = modify1 modify2 modify3 modify4 modify5 \
+- tune1 tune2 graph1 rpn1 rpn2 \
++ tune1 tune2 graph1 rpn1 \
+ rrdcreate \
+ dump-restore \
+ create-with-source-1 create-with-source-2 create-with-source-3 \
+@@ -555,7 +555,7 @@
+ rrdcreate \
+ tune1-testa-mod1.dump tune1-testa-mod2.dump tune1-testorg.dump \
+ tune2-testa-mod1.dump tune2-testorg.dump \
+- valgrind-supressions dcounter1 dcounter1.output graph1.output vformatter1 rpn1.output rpn2.output \
++ valgrind-supressions dcounter1 dcounter1.output graph1.output vformatter1 rpn1.output \
+ xport1.json.output xport1.xml.output \
+ pdp-calc1 pdp-calc1-1-avg-60.output pdp-calc1-1-avg-300.output pdp-calc1-1-max-300.output
+
+@@ -820,13 +820,6 @@
+ $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+ --log-file $$b.log --trs-file $$b.trs \
+ $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+- "$$tst" $(AM_TESTS_FD_REDIRECT)
+-rpn2.log: rpn2
+- @p='rpn2'; \
+- b='rpn2'; \
+- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+- --log-file $$b.log --trs-file $$b.trs \
+- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+ "$$tst" $(AM_TESTS_FD_REDIRECT)
+ rrdcreate.log: rrdcreate
+ @p='rrdcreate'; \
diff --git a/user/rrdtool/no-posix-fallocate.patch b/user/rrdtool/no-posix-fallocate.patch
deleted file mode 100644
index c34c5a187..000000000
--- a/user/rrdtool/no-posix-fallocate.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- rrdtool-1.4.8.orig/configure.ac
-+++ rrdtool-1.4.8/configure.ac
-@@ -280,9 +280,6 @@
- #include <fcntl.h>])
- AC_CHECK_FUNCS(posix_fadvise)
-
--dnl can we use posix_fallocate
--AC_CHECK_FUNCS(posix_fallocate)
--
- CONFIGURE_PART(Libintl Processing)
-
- AM_GNU_GETTEXT_VERSION(0.17)
diff --git a/user/sane/APKBUILD b/user/sane/APKBUILD
index 1a5e2fc16..941402502 100644
--- a/user/sane/APKBUILD
+++ b/user/sane/APKBUILD
@@ -4,7 +4,7 @@
pkgname=sane
_pkgname=sane-backends
pkgver=1.0.27
-pkgrel=4
+pkgrel=5
pkgdesc="Scanner access library"
url="http://www.sane-project.org/"
arch="all"
@@ -35,7 +35,8 @@ for _backend in $_backends; do
subpackages="$subpackages $pkgname-backend-$_backend:_backend"
done
subpackages="$pkgname-doc $pkgname-dev $subpackages $pkgname-utils saned
- $pkgname-udev::noarch $_pkgname::noarch"
+ saned-openrc:openrc:noarch $pkgname-udev::noarch $_pkgname::noarch
+ $pkgname-lang"
source="http://distfiles.gentoo.org/distfiles/$_pkgname-$pkgver.tar.gz
saned.initd
include.patch
@@ -81,6 +82,12 @@ saned() {
mkdir -p "$subpkgdir"/etc/sane.d "$subpkgdir"/usr
mv "$pkgdir"/etc/sane.d/saned.conf "$subpkgdir"/etc/sane.d
mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
+}
+
+openrc() {
+ pkgdesc="Network scanner server (OpenRC runscripts)"
+ depends="saned"
+ install_if="saned=$pkgver-r$pkgrel openrc"
install -Dm755 "$srcdir"/saned.initd "$subpkgdir"/etc/init.d/saned
}
@@ -101,7 +108,7 @@ udev() {
backends() {
local _backend;
pkgdesc="$pkgdesc (metapackage)"
- depends="$pkgname-utils $pkgname-saned"
+ depends="$pkgname-utils saned"
for _backend in $_backends; do
[ "$_backend" = "test" ] && continue
depends="$depends $pkgname-backend-$_backend"
diff --git a/user/vlc/APKBUILD b/user/vlc/APKBUILD
index a06e293ed..31a7b2975 100644
--- a/user/vlc/APKBUILD
+++ b/user/vlc/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=vlc
pkgver=3.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Multi-platform MPEG, VCD/DVD, and DivX player"
triggers="vlc-libs.trigger=/usr/lib/vlc/plugins"
pkgusers="vlc"
@@ -12,34 +12,9 @@ url="https://www.videolan.org/vlc/"
arch="all"
license="GPL-2.0+"
options="!checkroot textrel"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-xorg
- $pkgname-daemon::noarch $pkgname-libs $pkgname-plugins
- $pkgname-lang
-
- $pkgname-plugins-access:plugins_access
- $pkgname-plugins-access_output:plugins_access_output
- $pkgname-plugins-audio_filter:plugins_audio_filter
- $pkgname-plugins-audio_mixer:plugins_audio_mixer
- $pkgname-plugins-audio_output:plugins_audio_output
- $pkgname-plugins-codec:plugins_codec
- $pkgname-plugins-control:plugins_control
- $pkgname-plugins-demux:plugins_demux
- $pkgname-plugins-gui:plugins_gui
- $pkgname-plugins-lua:plugins_lua
- $pkgname-plugins-meta_engine:plugins_meta_engine
- $pkgname-plugins-misc:plugins_misc
- $pkgname-plugins-mux:plugins_mux
- $pkgname-plugins-notify:plugins_notify
- $pkgname-plugins-packetizer:plugins_packetizer
- $pkgname-plugins-services_discovery:plugins_services_discovery
- $pkgname-plugins-stream_filter:plugins_stream_filter
- $pkgname-plugins-stream_out:plugins_stream_out
- $pkgname-plugins-text_renderer:plugins_text_renderer
- $pkgname-plugins-video_chroma:plugins_video_chroma
- $pkgname-plugins-video_filter:plugins_video_filter
- $pkgname-plugins-video_output:plugins_video_output
- $pkgname-plugins-visualization:plugins_visualization"
-depends="ttf-dejavu $pkgname-plugins"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-pulse
+ $pkgname-daemon::noarch $pkgname-libs $pkgname-lang"
+depends="ttf-dejavu xdg-utils"
# Generic dependencies, then X11, then multimedia libraries
makedepends="autoconf automake bison eudev-dev flex libarchive-dev
libgcrypt-dev libtool libxml2-dev lua5.3-dev ncurses-dev sysfsutils-dev
@@ -58,6 +33,7 @@ makedepends="autoconf automake bison eudev-dev flex libarchive-dev
libraw1394-dev>=2.0.1 librsvg-dev libshout-dev libtheora-dev libva-dev
libvdpau-dev libvorbis-dev live-media-dev opus-dev pulseaudio-dev
speex-dev speexdsp-dev taglib-dev v4l-utils-dev x264-dev x265-dev"
+replaces="vlc-plugins vlc-xorg"
source="https://get.videolan.org/vlc/$pkgver/vlc-$pkgver.tar.xz
check-headless.patch
disable-sub-autodetect-fuzzy-1-test.patch
@@ -165,43 +141,23 @@ check() {
make check
}
-plugins() {
- pkgdesc="$pkgname all plugins meta package"
- depends="$pkgname-plugins-access
- $pkgname-plugins-access_output
- $pkgname-plugins-audio_filter
- $pkgname-plugins-audio_mixer
- $pkgname-plugins-audio_output
- $pkgname-plugins-codec
- $pkgname-plugins-control
- $pkgname-plugins-demux
- $pkgname-plugins-gui
- $pkgname-plugins-lua
- $pkgname-plugins-meta_engine
- $pkgname-plugins-misc
- $pkgname-plugins-mux
- $pkgname-plugins-notify
- $pkgname-plugins-packetizer
- $pkgname-plugins-services_discovery
- $pkgname-plugins-stream_filter
- $pkgname-plugins-stream_out
- $pkgname-plugins-text_renderer
- $pkgname-plugins-video_chroma
- $pkgname-plugins-video_filter
- $pkgname-plugins-video_output
- $pkgname-plugins-visualization"
- mkdir -p "$subpkgdir"
-}
-
_mv() {
local dir=${1%/*}
mkdir -p "$subpkgdir"/$dir
mv "$1" "$subpkgdir"/$dir/
}
+pulse() {
+ pkgdesc="PulseAudio support for VLC"
+ depends=""
+ install_if="vlc pulseaudio"
+ mkdir -p "$subpkgdir"/usr/lib/vlc
+ mv "$pkgdir"/usr/lib/vlc/libvlc_pulse* "$subpkgdir"/usr/lib/vlc/
+}
+
qt() {
pkgdesc="Qt frontend for VLC"
- depends="vlc-xorg=$pkgver-r$pkgrel"
+ depends="vlc=$pkgver-r$pkgrel"
cd "$pkgdir"
# scan for elf files that directly or indirectly depends on
# libQt* libraries
@@ -216,32 +172,6 @@ qt() {
"$subpkgdir"/usr/bin/
}
-xorg() {
- pkgdesc="Video LAN X.org support"
- depends="xdg-utils vlc=$pkgver-r$pkgrel"
-
- # scan for elf files that directly or indirectly depends on
- # libX* libraries
- cd "$pkgdir"
- for i in $(find . -type f ); do
- if ldd $i 2>/dev/null | grep -E -q "libX|x11|libxcb|libGL"; then
- echo $i | grep libavcodec_plugin.so || _mv "$i" || return 1
- fi
- done
-
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/svlc \
- "$subpkgdir"/usr/bin
-
- mkdir -p "$subpkgdir"/usr/share/vlc
- mv "$pkgdir"/usr/share/applications \
- "$pkgdir"/usr/share/icons \
- "$subpkgdir"/usr/share/
-
- mv "$pkgdir"/usr/share/vlc/skins2 \
- "$subpkgdir"/usr/share/vlc
-}
-
daemon() {
pkgdesc="Support for running VLC as a daemon"
install="vlc-daemon.pre-install"
@@ -262,39 +192,6 @@ libs() {
default_libs
}
-_mv_plugins() {
- local plugin=$1
- pkgdesc="$pkgname $plugin plugin"
- depends=
- mkdir -p "$subpkgdir"/usr/lib/vlc/plugins
- mv "$pkgdir"/usr/lib/vlc/plugins/"$plugin" \
- "$subpkgdir"/usr/lib/vlc/plugins
-}
-
-plugins_access() { _mv_plugins access; }
-plugins_access_output() { _mv_plugins access_output; }
-plugins_audio_filter() { _mv_plugins audio_filter; }
-plugins_audio_mixer() { _mv_plugins audio_mixer; }
-plugins_audio_output() { _mv_plugins audio_output; }
-plugins_codec() { _mv_plugins codec; }
-plugins_control() { _mv_plugins control; }
-plugins_demux() { _mv_plugins demux; }
-plugins_gui() { _mv_plugins gui; }
-plugins_lua() { _mv_plugins lua; }
-plugins_meta_engine() { _mv_plugins meta_engine; }
-plugins_misc() { _mv_plugins misc; }
-plugins_mux() { _mv_plugins mux; }
-plugins_notify() { _mv_plugins notify; }
-plugins_packetizer() { _mv_plugins packetizer; }
-plugins_services_discovery() { _mv_plugins services_discovery; }
-plugins_stream_filter() { _mv_plugins stream_filter; }
-plugins_stream_out() { _mv_plugins stream_out; }
-plugins_text_renderer() { _mv_plugins text_renderer; }
-plugins_video_chroma() { _mv_plugins video_chroma; }
-plugins_video_filter() { _mv_plugins video_filter; }
-plugins_video_output() { _mv_plugins video_output; }
-plugins_visualization() { _mv_plugins visualization; }
-
sha512sums="7c72e98f30ce5c5a94d74e097fa9960442f89240079b042a729f8a33dd7fedee2538c86c99738ccef2eb27f29055f0221d4c70316e3312c5ebba9565eaa15c52 vlc-3.0.6.tar.xz
22d80df599b8b65a5439cefbb7140af8e9530f326d54945da3769af65f37518b99ec2cc8647aafd2763324a0698280915afe043cc87e5720c4694881ed35bffa check-headless.patch
e214b407235cb3afb8bec93f20c9b42957b57e6fd3960679d3d4235e77762e03e64d03c01f00ef63d589e7c85aaad02ce6abbeeccd66b1867bc92451a5b5e9b0 disable-sub-autodetect-fuzzy-1-test.patch