summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/cve-check-tool/APKBUILD43
-rw-r--r--user/dumb-init/APKBUILD22
2 files changed, 65 insertions, 0 deletions
diff --git a/user/cve-check-tool/APKBUILD b/user/cve-check-tool/APKBUILD
new file mode 100644
index 000000000..b0c2db9ba
--- /dev/null
+++ b/user/cve-check-tool/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=cve-check-tool
+pkgver=5.6.4_p1
+_pkgver=${pkgver%_p*}+adelie${pkgver#*_p}
+pkgrel=0
+pkgdesc="Vulnerability checker for Linux packaging"
+url="https://code.foxkit.us/sroracle/cve-check-tool"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="bash curl-dev glib-dev gobject-introspection-dev
+ libxml2-dev openssl-dev sqlite-dev"
+checkdepends="check-dev"
+subpackages="$pkgname-doc"
+source="https://dev.sick.bike/dist/cve-check-tool-$_pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$_pkgver"
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make -j1 check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6af4778752c1c64c9a7c747f5a099ac83a42b9c92e273b315a386547144bfcdcd325dac9f17cfea16944442cdd20faf829ec401792ba67a34ec21fc65046dfac cve-check-tool-5.6.4+adelie1.tar.gz"
diff --git a/user/dumb-init/APKBUILD b/user/dumb-init/APKBUILD
new file mode 100644
index 000000000..e500cb008
--- /dev/null
+++ b/user/dumb-init/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=dumb-init
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A minimal init system for Linux containers"
+url="https://github.com/Yelp/dumb-init"
+arch="all"
+options="!check" # Check requires Python 3.7 and will not function correctly within chroots.
+license="MIT"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yelp/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m755 ./dumb-init $pkgdir/usr/bin/
+}
+
+sha512sums="efb0b99d3a98a2ff0bd1ac9d105f034589869b44237575489fb0d2ebb99b13df4451cf355bf285b91ac1e87af9d5ac87aed3e9d225f0c0f47299ca716ed70b27 dumb-init-1.2.2.tar.gz"