summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/autoconf2.13/APKBUILD7
-rw-r--r--user/dotconf/APKBUILD43
-rw-r--r--user/flite/APKBUILD39
-rw-r--r--user/kde-utilities/APKBUILD2
-rw-r--r--user/kleopatra/APKBUILD4
-rw-r--r--user/kpimtextedit/APKBUILD7
-rw-r--r--user/libkleo/APKBUILD4
-rw-r--r--user/nsd/APKBUILD55
-rw-r--r--user/nsd/nsd.confd5
-rw-r--r--user/nsd/nsd.initd15
-rwxr-xr-xuser/nsd/nsd.pre-install5
-rw-r--r--user/qt5-qtspeech/APKBUILD32
-rw-r--r--user/qt5-qtspeech/fix-linking-order.patch6
-rw-r--r--user/speech-dispatcher/APKBUILD38
-rw-r--r--user/unbound/APKBUILD4
15 files changed, 255 insertions, 11 deletions
diff --git a/user/autoconf2.13/APKBUILD b/user/autoconf2.13/APKBUILD
index d3b3ca73b..bd5b533a9 100644
--- a/user/autoconf2.13/APKBUILD
+++ b/user/autoconf2.13/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=autoconf2.13
pkgver=2.13
-pkgrel=1
+pkgrel=2
pkgdesc="A GNU tool for automatically configuring source code"
arch="noarch"
license="GPL-2.0"
@@ -38,5 +38,10 @@ package() {
rm -f "$pkgdir"/usr/share/info/standards.info
}
+doc() {
+ default_doc
+ mv "$subpkgdir/usr/share/info/autoconf.info" "$subpkgdir/usr/share/info/autoconf-2.13.info"
+}
+
sha512sums="602584f4c77b7a554aaa068eda5409b68eb0b3229e9c224bffb91c83c4314d25de15bd560a323626ff78f6df339c79e1ef8938c54b78ecadf4dc75c5241290ad autoconf-2.13.tar.gz
483d0ba23c90e41c746868ea57436033930906f306b86de5e23284a60da069f4203d478615d653b8acee7226d9b02427be42a9764ff82710019de485e5f26d1b getloadavg.patch"
diff --git a/user/dotconf/APKBUILD b/user/dotconf/APKBUILD
new file mode 100644
index 000000000..54f08fa92
--- /dev/null
+++ b/user/dotconf/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=dotconf
+pkgver=1.3
+pkgrel=0
+pkgdesc="Configuration file parsing library"
+url=" "
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://distfiles.gentoo.org/distfiles/dotconf-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ced0e66f70d11a309e77add1bfac1da8e85dcbe193633bd4bd1ae4bfd043b66880406e93ec18327b8c5d3de8d4bfc5278db6e5cb39b030ee1dabfa1ce267a98e dotconf-1.3.tar.gz"
diff --git a/user/flite/APKBUILD b/user/flite/APKBUILD
new file mode 100644
index 000000000..5ae3ea67a
--- /dev/null
+++ b/user/flite/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=flite
+pkgver=2.1
+pkgrel=0
+pkgdesc="Small, fast text-to-speech synthesizer based on Festival"
+url="http://www.festvox.org/flite/"
+arch="all"
+options="!check" # testsuite refuses to cooperate
+license="MIT AND Apache-2.0 AND BSD-3-Clause AND Public-Domain AND BSD-2-Clause"
+depends=""
+makedepends="alsa-lib-dev"
+subpackages="$pkgname-dev"
+source="http://www.festvox.org/flite/packed/flite-$pkgver/flite-$pkgver-release.tar.bz2"
+builddir="$srcdir/flite-$pkgver-release"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e9ef9ca4b6920178634d94bbe6e21a8b0ec471b010b07e6cc961ed2d120acb944c8e1d268fe26188f7dfe43fb7bd4bdff7fa53b2d2f12029d37e08d0316620d2 flite-2.1-release.tar.bz2"
diff --git a/user/kde-utilities/APKBUILD b/user/kde-utilities/APKBUILD
index b83782a1a..8c1a45489 100644
--- a/user/kde-utilities/APKBUILD
+++ b/user/kde-utilities/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kde-utilities
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Desktop utiltiies from the KDE Software Collection"
url="https://www.kde.org/applications/utilities/"
diff --git a/user/kleopatra/APKBUILD b/user/kleopatra/APKBUILD
index b980e4aed..c8c89833e 100644
--- a/user/kleopatra/APKBUILD
+++ b/user/kleopatra/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kleopatra
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Certificate manager and cryptography GUI"
url="https://www.kde.org/applications/utilities/kleopatra/"
@@ -40,4 +40,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3740481570653f718eb469f1cdfbfa69e7b41104b26403c3902667894d17321f6119b3dbf1487d59c7fbfd6707cd6dcca562aeba6036cdb41a9b29530bfa5a6b kleopatra-18.08.3.tar.xz"
+sha512sums="e8273c5564c2a48afbd0c9ae467092afc3fa80cd6d374da7273e110c2b1d3c2cbc093b8e7eee682dac204ceb851352f6e4ae6263d8d689d8c3e1bb93f924906d kleopatra-18.12.2.tar.xz"
diff --git a/user/kpimtextedit/APKBUILD b/user/kpimtextedit/APKBUILD
index dd58a6090..d305928a8 100644
--- a/user/kpimtextedit/APKBUILD
+++ b/user/kpimtextedit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpimtextedit
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="Text editor for Personal Information Managers (PIMs)"
url="https://pim.kde.org/"
@@ -13,7 +13,8 @@ depends_dev="qt5-qtbase-dev kwidgetsaddons-dev syntax-highlighting-dev
ktextwidgets-dev sonnet-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev ki18n-dev
grantlee-dev kcodecs-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev
- kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev"
+ kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev
+ qt5-qtspeech-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.kde.org/stable/applications/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
@@ -43,4 +44,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3a5ca2c2fc30f1c961a6f8b76a01c29be4b36c4e512e3c0cfaaa36c95fa9ba548f0d56cca3b9be86f2453c5c4be990b031cb2cd52a0747e1ab8af798156a7da7 kpimtextedit-18.08.3.tar.xz"
+sha512sums="6961f0fff5343bf77518b0d7e4991375c1a4d8b909ca81019c4a9574806942a115d08a4793bb7cfd4f6aca97d4b3e0909c6475a66c25b89866f16509899a5326 kpimtextedit-18.12.2.tar.xz"
diff --git a/user/libkleo/APKBUILD b/user/libkleo/APKBUILD
index 8122014b2..658974ef1 100644
--- a/user/libkleo/APKBUILD
+++ b/user/libkleo/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libkleo
-pkgver=18.08.3
+pkgver=18.12.2
pkgrel=0
pkgdesc="KDE encryption library"
url="https://www.kde.org/"
@@ -41,4 +41,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="5bd2aac755e6dad05e05e1c49b83cccf8b349c9231533dc821b3ba1dcc4da3fb66f7e8aaaeebdd1c080a28d94b9646afb248b5bee44e3bec8447d1293dda5f10 libkleo-18.08.3.tar.xz"
+sha512sums="06dba154a77df481678208c7b687c1b7b7664fbde971ba5b4f854bdcdc6ab6e1f09864b989da7c929fa1b56bae4042d37ed2d39b6d2eacfeda726cfc82e61839 libkleo-18.12.2.tar.xz"
diff --git a/user/nsd/APKBUILD b/user/nsd/APKBUILD
new file mode 100644
index 000000000..388c902a1
--- /dev/null
+++ b/user/nsd/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Luis Ressel <aranea@aixah.de>
+# Maintainer: Luis Ressel <aranea@aixah.de>
+pkgname=nsd
+pkgver=4.1.26
+pkgrel=0
+pkgdesc="An authoritative only name server"
+url="https://www.nlnetlabs.nl/projects/nsd/about/"
+arch="all"
+options="!check" # No test suite
+license="BSD-3-Clause"
+depends=""
+makedepends="libevent-dev openssl-dev"
+subpackages="$pkgname-doc $pkgname-openrc"
+install="$pkgname.pre-install"
+pkgusers="nsd"
+pkggroups="nsd"
+source="https://nlnetlabs.nl/downloads/$pkgname/$pkgname-$pkgver.tar.gz
+ nsd.confd
+ nsd.initd"
+
+build() {
+ cd "$builddir"
+
+ # dnstap has yet unpackaged dependencies
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-pidfile=/run/nsd.pid \
+ --disable-dnstap \
+ --enable-bind8-stats \
+ --enable-ratelimit \
+ --enable-ratelimit-default-is-off \
+ --enable-recvmmsg \
+ --with-ssl=/usr \
+ --with-libevent=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+openrc() {
+ default_openrc
+ install -Dm755 "$srcdir/nsd.initd" "$subpkgdir/etc/init.d/nsd"
+ install -Dm644 "$srcdir/nsd.confd" "$subpkgdir/etc/conf.d/nsd"
+}
+
+sha512sums="49c07ad79e4e056bd519dad157a44d5cc55cd9a28723fd910159dc761d4ba56ef86cb7bf289dc5d1b363a49b999232bb7ec1afa737ca5c2659c4c9893e93494b nsd-4.1.26.tar.gz
+f0ef1d3427e92650239d9d91402810c045fc9223e3f42ce86986422bf2039a0bcc02dffdfe1153d54de5c76c8f2bdc3e34fe341c65b41f2d333b02c00b5b0eae nsd.confd
+139e52dec98792173f06d298574db0d0e6966a06af8a0a3069487beb01fd570c09d22322569b54bacdc43232dbfb99a8c497d4417d2bbfee88bcdd9d1b4d22f7 nsd.initd"
diff --git a/user/nsd/nsd.confd b/user/nsd/nsd.confd
new file mode 100644
index 000000000..403de4fe8
--- /dev/null
+++ b/user/nsd/nsd.confd
@@ -0,0 +1,5 @@
+#
+# Specify daemon options here.
+#
+
+nsd_opts=""
diff --git a/user/nsd/nsd.initd b/user/nsd/nsd.initd
new file mode 100644
index 000000000..981e04ac7
--- /dev/null
+++ b/user/nsd/nsd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+
+name="nsd"
+command="/usr/sbin/nsd"
+command_args="${nsd_opts}"
+pidfile="/run/nsd.pid"
+extra_started_commands="reload"
+
+depend() {
+ use logger net
+}
+
+reload() {
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+}
diff --git a/user/nsd/nsd.pre-install b/user/nsd/nsd.pre-install
new file mode 100755
index 000000000..b8a8bf698
--- /dev/null
+++ b/user/nsd/nsd.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+groupadd -r nsd 2>/dev/null
+useradd -M -N -g nsd -r -s /sbin/nologin -d /etc/nsd nsd 2>/dev/null
+exit 0
diff --git a/user/qt5-qtspeech/APKBUILD b/user/qt5-qtspeech/APKBUILD
new file mode 100644
index 000000000..408e95824
--- /dev/null
+++ b/user/qt5-qtspeech/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtspeech
+_pkgname=qtspeech-opensource-src
+pkgver=5.9.7
+pkgrel=0
+pkgdesc="Qt 5 - Library for speech processing and Text-to-Speech (TTS)"
+url="https://www.qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="qt5-qtbase-dev qt5-qtmultimedia-dev speech-dispatcher-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ fix-linking-order.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="e2d1f2f73bc6595572d18b1c17caf27878851adf164dbca25925301b94916cce96b2ea3db4c2c7e6a23d6e79c37c35b28239aa613adaf6cb9eb340f40c396099 qtspeech-opensource-src-5.9.7.tar.xz
+7bce4bd52aa0b60fbd0ec781fc18ac518a8fe76c99e61be03170f00d27747e989b1562a45435be78d0d166ab0fdf523055620ba7c63f49e328704e1cd6aa4718 fix-linking-order.patch"
diff --git a/user/qt5-qtspeech/fix-linking-order.patch b/user/qt5-qtspeech/fix-linking-order.patch
new file mode 100644
index 000000000..b07e0536d
--- /dev/null
+++ b/user/qt5-qtspeech/fix-linking-order.patch
@@ -0,0 +1,6 @@
+--- qtspeech-opensource-src-5.9.7/config.tests/flite_alsa/flite_alsa.pro.old 2018-05-31 12:22:17.000000000 +0000
++++ qtspeech-opensource-src-5.9.7/config.tests/flite_alsa/flite_alsa.pro 2019-02-17 15:12:30.810000000 +0000
+@@ -1,2 +1,2 @@
+-LIBS += -lasound
+ include(../flite/flite.pri)
++LIBS += -lasound
diff --git a/user/speech-dispatcher/APKBUILD b/user/speech-dispatcher/APKBUILD
new file mode 100644
index 000000000..b35da35bd
--- /dev/null
+++ b/user/speech-dispatcher/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=speech-dispatcher
+pkgver=0.8.8
+pkgrel=0
+pkgdesc="High-level interface to speech synthesis libraries"
+url="https://freebsoft.org/speechd"
+arch="all"
+license="LGPL-2.1-only AND (GPL-2.0+ AND LGPL-2.1+) AND LGPL-2.1+ AND GPL-2.0+"
+depends="flite"
+makedepends="alsa-lib-dev dotconf-dev flite-dev glib-dev intltool
+ libsndfile-dev pulseaudio-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://freebsoft.org/pub/projects/speechd/speech-dispatcher-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ LIBS="-lasound" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7c7b9bf9b9ce541e790b5ae396cb614616c6b3883e75c0258603e91bf679850e3d63a6251daa3a1819b30d7518e3f552c83fe87b006274ffe1aa0f7e19c0b99b speech-dispatcher-0.8.8.tar.gz"
diff --git a/user/unbound/APKBUILD b/user/unbound/APKBUILD
index aecfea4f6..3c6810ec3 100644
--- a/user/unbound/APKBUILD
+++ b/user/unbound/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=unbound
-pkgver=1.8.3
+pkgver=1.9.0
pkgrel=0
pkgdesc="A validating, recursive and caching DNS resolver"
url="https://unbound.net/"
@@ -71,6 +71,6 @@ python() {
mv "$pkgdir/usr/lib/python"* "$subpkgdir"
}
-sha512sums="545486ccce288a6ef1937d82653a43a11dbd3aec7b8d0036e7fd107e537cdfc935def9db9178c2eb418d6f4b0849a242a0be1dea966f3e9e0145aa7266e483ad unbound-1.8.3.tar.gz
+sha512sums="7dfa8e078507fc24a2d0938eea590389453bacfcac023f1a41af19350ea1f7b87d0c82d7eead121a11068921292a96865e177274ff27ed8b8868445f80f7baf6 unbound-1.9.0.tar.gz
de9dc269553f5449c1757690c2a8a3b9f228964f5672d721cfdbc29e6fab8954907fa4fa3761dd6f705b3ccd2f729cc6e2fe870107feb68cca611589f8306b94 unbound.confd
6627cbcbcb4e04f596e7e0ffdbf80ceb54cdb59144cb89896e53503dfb41b99fd77d8b85d05e6670f77023b6eafec8885b00c0c8e4e34e3e638c52c037a7985e unbound.initd"