summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/iputils/APKBUILD16
-rw-r--r--user/iputils/docbook-man.patch33
-rw-r--r--user/kdoctools/APKBUILD2
-rw-r--r--user/kpmcore/APKBUILD2
-rw-r--r--user/kwalletmanager/APKBUILD2
-rw-r--r--user/labplot/APKBUILD4
-rw-r--r--user/partitionmanager/APKBUILD2
7 files changed, 11 insertions, 50 deletions
diff --git a/user/iputils/APKBUILD b/user/iputils/APKBUILD
index 4a35f931b..142a5ff2d 100644
--- a/user/iputils/APKBUILD
+++ b/user/iputils/APKBUILD
@@ -6,18 +6,16 @@ pkgrel=0
pkgdesc="IP Configuration Utilities (and Ping)"
url="https://github.com/iputils/iputils/"
arch="all"
+options="suid"
license="BSD-3-Clause AND GPL-2.0-or-later"
-makedepends="meson libcap-dev libxslt docbook-xsl-ns openssl-dev libgcrypt-dev"
+makedepends="docbook-xsl docbook-xsl-ns libcap-dev libgcrypt-dev libxslt meson
+ openssl-dev"
replaces="bbsuid"
subpackages="$pkgname-doc $pkgname-lang $pkgname-openrc"
-source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz
- docbook-man.patch
- "
-options="suid"
+source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz"
builddir="$srcdir/$pkgname-s$pkgver"
build() {
- cd "$builddir"
# we're waiting for idn support in musl so that we can enable it here
# https://wiki.musl-libc.org/functional-differences-from-glibc.html#Name-Resolver/DNS
meson --prefix /usr --buildtype=plain builddir -DUSE_IDN=false
@@ -25,18 +23,14 @@ build() {
}
check() {
- cd "$builddir"
ninja -C builddir test
}
package() {
- cd "$builddir"
-
DESTDIR=$pkgdir ninja -C builddir install
ln -s tracepath "$pkgdir"/usr/bin/tracepath6
ln -s ping "$pkgdir"/usr/bin/ping6
}
-sha512sums="adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250 iputils-20190515.tgz
-411f45a2d16c88b09f3547e3f04aa20e257f54650c7783123e4cb021bd8850cd96896480fbf9305d6df72abe32d8d5c2239ce4ac4ef9bfa821c205309451d6ff docbook-man.patch"
+sha512sums="adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250 iputils-20190515.tgz"
diff --git a/user/iputils/docbook-man.patch b/user/iputils/docbook-man.patch
deleted file mode 100644
index 1793858e4..000000000
--- a/user/iputils/docbook-man.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- iputils-s20190515/doc/custom-man.xsl.old 2019-06-25 11:48:48.790000000 +0000
-+++ iputils-s20190515/doc/custom-man.xsl 2019-06-25 11:49:06.250000000 +0000
-@@ -5,7 +5,7 @@
- extension-element-prefixes="exsl"
- version="1.0">
-
--<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl"/>
-+<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl"/>
-
- <xsl:template name="top.comment" />
-
---- iputils-s20190515/doc/meson.build.old 2019-06-25 14:54:58.170000000 +0000
-+++ iputils-s20190515/doc/meson.build 2019-06-25 14:55:28.460000000 +0000
-@@ -48,7 +48,7 @@
- ]
-
- if xsltproc.found()
-- xsl = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
-+ xsl = 'file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl'
- testrun = run_command([xsltproc, '--nonet', xsl])
- xsltproc_works = testrun.returncode() == 0
- if xsltproc_works == false
---- iputils-s20190515/doc/custom-html.xsl.old 2019-06-25 14:56:50.460000000 +0000
-+++ iputils-s20190515/doc/custom-html.xsl 2019-06-25 14:57:11.680000000 +0000
-@@ -2,7 +2,7 @@
-
- <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
-
--<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/html/docbook.xsl"/>
-+<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/html/docbook.xsl"/>
- <!--
- - The docbook stylesheet injects empty anchor tags into generated HTML, identified by an auto-generated ID.
- - Ask the docbook stylesheet to generate reproducible output when generating (these) ID values.
diff --git a/user/kdoctools/APKBUILD b/user/kdoctools/APKBUILD
index f11c59983..126b3eda5 100644
--- a/user/kdoctools/APKBUILD
+++ b/user/kdoctools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kdoctools
pkgver=5.54.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tools to generate user-readable documentation from DocBook XML"
url="https://www.kde.org/"
arch="all"
diff --git a/user/kpmcore/APKBUILD b/user/kpmcore/APKBUILD
index 102059e09..a6fef6476 100644
--- a/user/kpmcore/APKBUILD
+++ b/user/kpmcore/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kpmcore
pkgver=3.3.0
pkgrel=0
pkgdesc="Core routines for KDE Partition Manager"
-url="https://www.kde.org/applications/system/kdepartitionmanager"
+url="https://www.kde.org/applications/system/partitionmanager"
arch="all"
license="LGPL-2.1+"
depends=""
diff --git a/user/kwalletmanager/APKBUILD b/user/kwalletmanager/APKBUILD
index f4eae23bd..a512e4072 100644
--- a/user/kwalletmanager/APKBUILD
+++ b/user/kwalletmanager/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kwalletmanager
pkgver=19.04.2
pkgrel=0
pkgdesc="Manage KDE wallets"
-url="https://www.kde.org/applications/system/kwalletmanager/"
+url="https://www.kde.org/applications/system/kwalletmanager5"
arch="all"
license="GPL-2.0-only"
depends=""
diff --git a/user/labplot/APKBUILD b/user/labplot/APKBUILD
index caf9aa5df..d6ed5bf7e 100644
--- a/user/labplot/APKBUILD
+++ b/user/labplot/APKBUILD
@@ -4,7 +4,7 @@ pkgname=labplot
pkgver=2.6
pkgrel=0
pkgdesc="Interactive tool for graphing and analysis of scientific data"
-url="https://www.kde.org/applications/education/labplot/"
+url="https://www.kde.org/applications/education/labplot2"
arch="all"
license="GPL-2.0-only"
depends="shared-mime-info"
@@ -13,7 +13,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
kdoctools-dev ki18n-dev kiconthemes-dev kdelibs4support-dev kxmlgui-dev
knewstuff-dev ktextwidgets-dev kwidgetsaddons-dev gsl-dev fftw-dev
qt5-qtserialport-dev syntax-highlighting-dev bison libexecinfo-dev
- cantor-dev"
+ cantor-dev docbook-xsl"
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/labplot/$pkgver.0/labplot-$pkgver.0.tar.xz"
diff --git a/user/partitionmanager/APKBUILD b/user/partitionmanager/APKBUILD
index 33c6e3bdf..5e67e25af 100644
--- a/user/partitionmanager/APKBUILD
+++ b/user/partitionmanager/APKBUILD
@@ -4,7 +4,7 @@ pkgname=partitionmanager
pkgver=3.3.1
pkgrel=0
pkgdesc="Qt-based partition manager"
-url="https://www.kde.org/applications/system/kdepartitionmanager"
+url="https://www.kde.org/applications/system/partitionmanager"
arch="all"
license="GPL-3.0+"
depends=""