summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/adwaita-icon-theme/APKBUILD37
-rw-r--r--user/libqtxdg/APKBUILD4
-rw-r--r--user/xf86-video-r128/APKBUILD7
-rw-r--r--user/xf86-video-r128/xaa.patch21
4 files changed, 65 insertions, 4 deletions
diff --git a/user/adwaita-icon-theme/APKBUILD b/user/adwaita-icon-theme/APKBUILD
new file mode 100644
index 000000000..ae769910e
--- /dev/null
+++ b/user/adwaita-icon-theme/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=adwaita-icon-theme
+pkgver=3.31.1
+pkgrel=0
+pkgdesc="GNOME system icon set"
+url="https://www.gnome.org/"
+arch="noarch"
+license="CC-BY-SA-3.0 OR LGPL-3.0-only"
+depends=""
+makedepends=""
+subpackages=""
+source="https://ftp.gnome.org/pub/gnome/sources/adwaita-icon-theme/3.31/adwaita-icon-theme-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="aa73637cca8189e7141c0554ba7bda1234cbe192710463c9ad1c81b46a410b21e5fb48a090917324163ee4c0301fb1380d18ef5f9bb8faf1b401a52af18c60b1 adwaita-icon-theme-3.31.1.tar.xz"
diff --git a/user/libqtxdg/APKBUILD b/user/libqtxdg/APKBUILD
index e49fb0742..4c1c24f96 100644
--- a/user/libqtxdg/APKBUILD
+++ b/user/libqtxdg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libqtxdg
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Qt5-based library implementing the XDG spec"
url="https://lxqt.org"
arch="all"
@@ -23,7 +23,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_TESTS=True \
diff --git a/user/xf86-video-r128/APKBUILD b/user/xf86-video-r128/APKBUILD
index 0dd94af4e..094b11633 100644
--- a/user/xf86-video-r128/APKBUILD
+++ b/user/xf86-video-r128/APKBUILD
@@ -10,7 +10,9 @@ license="X11 AND MIT"
depends=""
makedepends="util-macros xorgproto-dev xorg-server-dev"
subpackages="$pkgname-doc"
-source="https://www.x.org/releases/individual/driver/xf86-video-r128-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/driver/xf86-video-r128-$pkgver.tar.bz2
+ xaa.patch
+ "
build() {
cd "$builddir"
@@ -34,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0e667e2cfa8a87a00846361d86528c93754c403c812b66798953fa4c857b2143b2c4c44885da467e7f910d8cb910b69492cdcb6f25e2197bae6617364d152e38 xf86-video-r128-6.12.0.tar.bz2"
+sha512sums="0e667e2cfa8a87a00846361d86528c93754c403c812b66798953fa4c857b2143b2c4c44885da467e7f910d8cb910b69492cdcb6f25e2197bae6617364d152e38 xf86-video-r128-6.12.0.tar.bz2
+45104ea2da49933f6d40834badb58c4db8706a9bf3080df7b2538f4cb1e7964b900c10b47386b9502bb4abee796b5f40f30252d1526e26d860b833c4dabca8ba xaa.patch"
diff --git a/user/xf86-video-r128/xaa.patch b/user/xf86-video-r128/xaa.patch
new file mode 100644
index 000000000..3ede81203
--- /dev/null
+++ b/user/xf86-video-r128/xaa.patch
@@ -0,0 +1,21 @@
+--- xf86-video-r128-6.12.0/src/r128_driver.c.old 2019-01-05 15:59:11.340000000 +0000
++++ xf86-video-r128-6.12.0/src/r128_driver.c 2019-01-05 16:16:10.810000000 +0000
+@@ -1887,14 +1887,16 @@
+ }
+
+ if (!info->noAccel) {
++#ifdef HAVE_XAA_H
+ if (R128XAAAccelInit(pScreen)) {
+ info->accelOn = TRUE;
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "XAA acceleration enabled.\n");
+- } else {
++ } else
++#endif
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
+ "Acceleration disabled.\n");
+- }
++
+ }
+ }
+ }