summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/libnftnl/APKBUILD7
-rw-r--r--user/nftables/APKBUILD6
2 files changed, 3 insertions, 10 deletions
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
index 7c335bca8..f2796b3ea 100644
--- a/user/libnftnl/APKBUILD
+++ b/user/libnftnl/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
+# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=libnftnl
pkgver=1.1.2
pkgrel=0
@@ -12,7 +12,6 @@ subpackages="$pkgname-dev"
source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"/tests
- make check # builds test binaries
+ make -C tests check # builds test binaries
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/nftables/APKBUILD b/user/nftables/APKBUILD
index b70d5e9a4..13cd0a2a2 100644
--- a/user/nftables/APKBUILD
+++ b/user/nftables/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer:
+# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=nftables
pkgver=0.9.0
pkgrel=0
@@ -17,8 +17,6 @@ source="https://netfilter.org/projects/nftables/files/$pkgname-$pkgver.tar.bz2
nftables.initd"
build() {
- cd "$builddir"
-
DB2MAN=docbook2x-man ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,8 +30,6 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname