summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/apache-httpd/APKBUILD8
-rw-r--r--user/gvim/APKBUILD4
-rw-r--r--user/kpartx/APKBUILD32
-rwxr-xr-xuser/kpartx/test-kpartx395
-rw-r--r--user/latte-dock/APKBUILD44
-rw-r--r--user/libpsl/APKBUILD6
-rw-r--r--user/live-media/APKBUILD4
-rw-r--r--user/marco/APKBUILD4
-rw-r--r--user/qt5ct/APKBUILD4
-rw-r--r--user/ttf-sudo/APKBUILD10
-rw-r--r--user/tumbler/APKBUILD4
11 files changed, 495 insertions, 20 deletions
diff --git a/user/apache-httpd/APKBUILD b/user/apache-httpd/APKBUILD
index 48fcaf26d..a14c25cc8 100644
--- a/user/apache-httpd/APKBUILD
+++ b/user/apache-httpd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=apache-httpd
_pkgreal=httpd
-pkgver=2.4.43
+pkgver=2.4.46
pkgrel=0
pkgdesc="Open-source HTTP server"
url="https://httpd.apache.org"
@@ -37,6 +37,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
options="suid !check"
# secfixes: http_server
+# 2.4.46-r0:
+# - CVE-2020-9490
+# - CVE-2020-11984
+# - CVE-2020-11993
# 2.4.43-r0:
# - CVE-2020-1934
# - CVE-2020-1927
@@ -146,7 +150,7 @@ ldap() {
"$subpkgdir"/usr/libexec/apache2
}
-sha512sums="d9879b8f8ef7d94dee1024e9c25b56d963a3b072520878a88a044629ad577c109a5456791b39016bf4f6672c04bf4a0e5cfd32381211e9acdc81d4a50b359e5e httpd-2.4.43.tar.gz
+sha512sums="5801c1dd0365f706a5e2365e58599b5adac674f3c66b0f39249909841e6cdf16bfdfe001fbd668f323bf7b6d14b116b5e7af49867d456336fad5e685ba020b15 httpd-2.4.46.tar.gz
c8bc2bb06ae51b0956e0ee673e80c444551c9b33dfcbb845106477c46d9e52786a8896022e1f00102264fecdf66e35e47fc6cf0abe9836fa536735cff4e6adf4 adelie.layout
336e81fa0d08f8fbe6243d52bd59b12cf2e925deb49b29d7a22953c5d40a951b6b753f51e5a396752cb0bbaf1cf25b1358902f375fb65639d00e62db7ae55ff2 apache-httpd.confd
5762d53f39ce7ecd730e05ddf6c063ede65cd75b9e7d67217784c80366646491ef9474306e8eb119c8fb5b4358407b07636a4e9cd82325d8df4e3e00dabc3459 apache-httpd.initd
diff --git a/user/gvim/APKBUILD b/user/gvim/APKBUILD
index 4742f1256..e8a0a2f35 100644
--- a/user/gvim/APKBUILD
+++ b/user/gvim/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=gvim
_pkgreal=vim
-pkgver=8.2.1017
+pkgver=8.2.1382
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -71,4 +71,4 @@ package() {
ln -s gvim rgvim
}
-sha512sums="6fe243c3aeefe2d63d67e1710d5212a4b76b8fd49e037ca588655e25901ca2af4285128cc97146622c42d0df77194e18fb7d5a2bdd74f26c3534f0c2cc0e5d8b vim-8.2.1017.tar.gz"
+sha512sums="3e8a8cc5e566983fd1da3a9f4434b9c5b9dad91d08e807cb5b4b8f5029e201d3dd4bc2badc5cf6b1e41339fd6667cd91a6fb6c95a0914abe93b1e42fcec07fbd vim-8.2.1382.tar.gz"
diff --git a/user/kpartx/APKBUILD b/user/kpartx/APKBUILD
new file mode 100644
index 000000000..e1e0feddb
--- /dev/null
+++ b/user/kpartx/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: CyberLeo <cyberleo@cyberleo.net>
+# Maintainer: CyberLeo <cyberleo@cyberleo.net>
+pkgname=kpartx
+pkgver=0.8.4
+pkgrel=0
+pkgdesc="Manipulates device mappings for the partitions of any block device."
+url="http://christophe.varoqui.free.fr/"
+arch="all"
+options="!check" # Requires root and loopback/dm-mod kernel modules.
+license="LGPL-2.0-only"
+depends=""
+makedepends="lvm2-dev"
+checkdepends="debianutils-which parted"
+subpackages="$pkgname-doc"
+source="multipath-tools-$pkgver.tar.gz::https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=refs/tags/$pkgver;sf=tgz;/multipath-tools-$pkgver.tar.gz
+test-kpartx"
+builddir="$srcdir/multipath-tools-$pkgver/kpartx"
+
+build() {
+ make kpartx
+}
+
+check() {
+ sudo KPARTX="${builddir}/kpartx" WAIT_US=1000000 "${srcdir}/test-kpartx"
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="130308e61d6dce31085fc2763219f4df0f3ad9153e0e6e7a5a1c3c948a2305cff9413699025c28f9b81dd24d2a9263f9fa825253060e44232c3bb6600cd1f07f multipath-tools-0.8.4.tar.gz
+2e3702243bfc52df7353cc828fb03e3dff36eddbf77eb13140fd58d857c3d45990c679c535c00c569e5a5412ad3823717e264449c038ebf1726a4e7adc08e06e test-kpartx"
diff --git a/user/kpartx/test-kpartx b/user/kpartx/test-kpartx
new file mode 100755
index 000000000..93a5abdbd
--- /dev/null
+++ b/user/kpartx/test-kpartx
@@ -0,0 +1,395 @@
+#! /bin/bash
+
+# This is a unit test program for kpartx, in particular for deleting partitions.
+#
+# The rationale is the following:
+#
+# 1) kpartx should delete all mappings it created beforehand.
+# 2) kpartx should handle partitions on dm devices and other devices
+# (e.g. loop devices) equally well.
+# 3) kpartx should only delete "partitions", which are single-target
+# linear mappings into a block device. Other maps should not be touched.
+# 4) kpartx should only delete mappings it created itself beforehand.
+# In particular, it shouldn't delete LVM LVs, even if they are fully
+# contained in the block device at hand and thus look like partitions
+# in the first place. (For historical compatibility reasons, we allow
+# such mappings to be deleted with the -f/--force flag).
+# 5) DM map names may be changed, thus kpartx shouldn't rely on them to
+# check whether a mapping is a partition of a particular device. It is
+# legal for a partition of /dev/loop0 to be named "loop0".
+
+# Note: This program tries hard to clean up, but if tests fail,
+# stale DM or loop devices may keep lurking around.
+
+# Set WORKDIR in environment to existing dir to for persistence
+# WARNING: existing files will be truncated.
+# If empty, test will be done in temporary dir
+: ${WORKDIR:=}
+# Set this environment variable to test an alternative kpartx executable
+: ${KPARTX:=}
+# Options to pass to kpartx always
+: ${KPARTX_OPTS:=-s}
+# Time to wait for device nodes to appear (microseconds)
+# Waiting is only needed if "s" is not in $KPARTX_OPTS
+: ${WAIT_US:=0}
+
+# IMPORTANT: The ERR trap is essential for this program to work correctly!
+#trap 'LINE=$LINENO; trap - ERR; echo "== error in $BASH_COMMAND on line $LINE ==" >&2; ls -la /dev/mapper; read a; exit 1' ERR
+trap 'cleanup' 0
+
+CLEANUP=:
+cleanup() {
+ trap - ERR
+ trap - 0
+ if [[ $OK ]]; then
+ echo == all ${ALL_PASS} tests completed successfully == >&2
+ else
+ printf "== Final Results ==\n%s of %s failed!\n\n" "${ALL_FAIL}" "$(( ALL_PASS + ALL_FAIL ))" >&2
+ fi
+ eval "$CLEANUP" &>/dev/null
+}
+
+push_cleanup() {
+ CLEANUP="$@;$CLEANUP"
+}
+
+pop_cleanup() {
+ # CAUTION: simplistic
+ CLEANUP=${CLEANUP#*;}
+}
+
+step() {
+ STEP="$@"
+
+ if [ $PASS -gt 0 -o $FAIL -gt 0 ]
+ then
+ printf "PASS: %s FAIL: %s\n\n" "${PASS}" "${FAIL}"
+ PASS=0
+ FAIL=0
+ fi
+
+ echo == Test step: $STEP == >&2
+}
+
+mk_partitions() {
+ parted -s $1 mklabel msdos
+ parted -s -- $1 mkpart prim ext2 1MiB -1s
+}
+
+wipe_ptable() {
+ dd if=/dev/zero of=$1 bs=1b count=1
+}
+
+usleep() {
+ if which usleep >/dev/null 2>&1
+ then
+ env usleep "${1}"
+ else
+ sleep $( echo "${1}" / 1000000.0 | bc )
+ fi
+}
+
+invoke_kpartx() {
+ $KPARTX $KPARTX_OPTS "${@}"
+ usleep "${WAIT_US}"
+}
+
+assert_exists() {
+ local result=0
+ while [ "${1}" ]
+ do
+ if [ -b "$(readlink -f "${1}")" ]
+ then
+ PASS=$(( PASS + 1 ))
+ ALL_PASS=$(( ALL_PASS + 1 ))
+ else
+ FAIL=$(( FAIL + 1 ))
+ ALL_FAIL=$(( ALL_FAIL + 1 ))
+ echo "assert_exists: Device does not exist when it should: ${1}"
+ result=1
+ fi
+ shift
+ done
+ return $result
+}
+
+assert_unexists() {
+ local result=0
+ while [ "${1}" ]
+ do
+ if [ ! -b "$(readlink -f "${1}")" ]
+ then
+ PASS=$(( PASS + 1 ))
+ ALL_PASS=$(( ALL_PASS + 1 ))
+ else
+ FAIL=$(( FAIL + 1 ))
+ ALL_FAIL=$(( ALL_FAIL + 1 ))
+ echo "assert_exists: Device exists when it should not: ${1}"
+ result=1
+ fi
+ shift
+ done
+ return $result
+}
+
+PASS=0
+ALL_PASS=0
+FAIL=0
+ALL_FAIL=0
+
+step preparation
+
+[[ $UID -eq 0 ]]
+[[ $KPARTX ]] || {
+ if [[ -x $PWD/kpartx/kpartx ]]; then
+ KPARTX=$PWD/kpartx/kpartx
+ else
+ KPARTX=$(which kpartx)
+ fi
+}
+[[ $KPARTX ]]
+
+FILE1=kpartx1
+FILE2=kpartx2
+FILE3=kpartx3
+FILE4=kpartx4
+
+SIZE=$((1024*1024*1024)) # use bytes as units here
+SECTSIZ=512
+OFFS=32 # offset of linear mapping into dev, sectors
+VG=kpvg # volume group name
+LV=kplv # logical vol name
+LVMCONF='devices { filter = [ "a|/dev/loop.*|", r".*" ] }'
+
+OK=
+
+[[ $WORKDIR ]] || {
+ WORKDIR=$(mktemp -d /tmp/kpartx-XXXXXX)
+ push_cleanup 'rm -rf $WORKDIR'
+}
+
+push_cleanup "cd $PWD"
+cd "$WORKDIR"
+
+step "create loop devices"
+truncate -s $SIZE $FILE1
+truncate -s $SIZE $FILE2
+truncate -s $SIZE $FILE3
+truncate -s $SIZE $FILE4
+
+LO1=$(losetup -f $FILE1 --show)
+push_cleanup 'losetup -d $LO1'
+LO2=$(losetup -f $FILE2 --show)
+push_cleanup 'losetup -d $LO2'
+LO3=$(losetup -f $FILE3 --show)
+push_cleanup 'losetup -d $LO3'
+LO4=$(losetup -f $FILE4 --show)
+push_cleanup 'losetup -d $LO4'
+
+[[ $LO1 && $LO2 && $LO3 && $LO4 && -b $LO1 && -b $LO2 && -b $LO3 && -b $LO4 ]]
+DEV1=$(stat -c "%t:%T" $LO1)
+DEV2=$(stat -c "%t:%T" $LO2)
+DEV3=$(stat -c "%t:%T" $LO3)
+
+usleep $WAIT_US
+
+step "create DM devices (spans)"
+# Create two linear mappings spanning two loopdevs.
+# One of them gets a pathological name colliding with
+# the loop device name.
+# These mappings must not be removed by kpartx.
+# They also serve as DM devices to test partition removal on those.
+
+TABLE="\
+0 $((SIZE/SECTSIZ-OFFS)) linear $DEV1 $OFFS
+$((SIZE/SECTSIZ-OFFS)) $((SIZE/SECTSIZ-OFFS)) linear $DEV2 $OFFS"
+
+SPAN1=kpt
+SPAN2=$(basename $LO2)
+dmsetup create $SPAN1 <<<"$TABLE"
+push_cleanup 'dmsetup remove -f $SPAN1'
+
+dmsetup create $SPAN2 <<<"$TABLE"
+push_cleanup 'dmsetup remove -f $SPAN2'
+
+# This is a non-kpartx pseudo "partition" mapping
+USER1=user1
+push_cleanup 'dmsetup remove -f $USER1'
+dmsetup create $USER1 <<EOF
+0 $((SIZE/SECTSIZ-OFFS)) linear $DEV1 $OFFS
+EOF
+
+usleep $WAIT_US
+assert_exists /dev/mapper/$SPAN1 /dev/mapper/$SPAN2 /dev/mapper/$USER1
+[[ -b /dev/mapper/$SPAN1 ]]
+[[ -b /dev/mapper/$SPAN2 ]]
+[[ -b /dev/mapper/$USER1 ]]
+
+step "create vg on $LO3"
+# On the 3rd loop device, we create a VG and an LV
+# The LV should not be removed by kpartx.
+pvcreate --config "$LVMCONF" -f $LO3
+vgcreate --config "$LVMCONF" $VG $LO3
+push_cleanup 'vgremove --config "$LVMCONF" -f $VG'
+lvcreate --config "$LVMCONF" -L $((SIZE/2))B -n $LV $VG
+push_cleanup 'lvremove --config "$LVMCONF" -f $VG/$LV'
+usleep $WAIT_US
+
+assert_exists /dev/mapper/$VG-$LV
+[[ -b /dev/mapper/$VG-$LV ]]
+
+# dmsetup table /dev/mapper/$VG-$LV
+# dmsetup info /dev/mapper/$VG-$LV
+
+step "create partitions on loop devices"
+
+mk_partitions $LO1
+mk_partitions $LO2
+mk_partitions $LO4
+
+# Test invocation of kpartx with regular file here
+LO2P1=/dev/mapper/$(basename $LO2)-foo1
+invoke_kpartx -a -p -foo $FILE2
+assert_exists $LO2P1
+[[ -b $LO2P1 ]]
+push_cleanup 'dmsetup remove -f $(basename $LO2P1)'
+
+step "remove partitions with deleted ptable"
+wipe_ptable $LO2
+invoke_kpartx -d $LO2
+assert_unexists $LO2P1
+
+mk_partitions $LO2
+invoke_kpartx -a -p -foo $FILE2
+assert_exists $LO2P1
+
+LO1P1=/dev/mapper/$(basename $LO1)-eggs1
+invoke_kpartx -a -p -eggs $LO1
+push_cleanup 'dmsetup remove -f $(basename $LO1P1)'
+
+usleep $WAIT_US
+assert_exists $LO1P1 $LO2P1
+
+# dmsetup info $LO2P1
+
+# Set pathological name for partition on $LO1 (same as loop device itself)
+dmsetup rename $(basename $LO1P1) $(basename $LO1)
+LO1P1=/dev/mapper/$(basename $LO1)
+pop_cleanup
+push_cleanup 'dmsetup remove -f $(basename $LO1P1)'
+
+# dmsetup info $LO1P1
+
+step "create partitions on DM devices"
+mk_partitions /dev/mapper/$SPAN2
+
+invoke_kpartx -a -p -bar /dev/mapper/$SPAN2
+SPAN2P1=/dev/mapper/${SPAN2}-bar1
+
+# udev rules may have created partition mappings without UUIDs
+# which aren't removed by default (if system standard kpartx doesn't
+# set the UUID). Remove them using -f
+push_cleanup 'invoke_kpartx -f -d /dev/mapper/$SPAN2'
+push_cleanup 'dmsetup remove -f $(basename $SPAN2P1)'
+
+invoke_kpartx -a -p -spam /dev/mapper/$SPAN1
+SPAN1P1=/dev/mapper/${SPAN1}-spam1
+# see above
+push_cleanup 'invoke_kpartx -f -d /dev/mapper/$SPAN1'
+push_cleanup 'dmsetup remove -f $(basename $SPAN1P1)'
+
+usleep $WAIT_US
+assert_exists $SPAN2P1 $SPAN1P1
+
+step "rename partitions on DM device to default"
+invoke_kpartx -u /dev/mapper/$SPAN1
+assert_unexists $SPAN1P1
+# This assumes that $SPAN1 ends in a non-digit
+assert_exists ${SPAN1P1//-spam/}
+
+step "rename partitions on DM device back from default"
+invoke_kpartx -u -p -spam /dev/mapper/$SPAN1
+assert_exists $SPAN1P1
+assert_unexists ${SPAN1P1//-spam/}
+
+step "delete partitions on DM devices"
+invoke_kpartx -d /dev/mapper/$SPAN1 >&2
+usleep $WAIT_US
+
+assert_exists $SPAN2P1 $LO1P1 $LO2P1
+assert_unexists $SPAN1P1
+
+invoke_kpartx -d /dev/mapper/$SPAN2
+usleep $WAIT_US
+
+assert_exists $LO1P1 $LO2P1
+assert_unexists $SPAN2P1
+
+step "rename partitions on loop device"
+invoke_kpartx -u -p -spam $LO2
+assert_unexists $LO2P1
+assert_exists ${LO2P1//-foo/-spam}
+
+step "rename partitions on loop device back"
+invoke_kpartx -u -p -foo $LO2
+assert_exists $LO2P1
+assert_unexists ${LO2P1//-foo/-spam}
+
+step "rename partitions on loop device to default"
+invoke_kpartx -u $LO2
+#read a
+assert_unexists $LO2P1
+assert_exists ${LO2P1//-foo/p}
+# $LO1 ends in a digit
+
+step "rename partitions on loop device back from default"
+invoke_kpartx -u -p -foo $LO2
+assert_exists $LO2P1
+assert_unexists ${LO2P1//-foo/p}
+
+step "rename partitions on loop devices"
+invoke_kpartx -u -p spam $LO2
+
+step "delete partitions on loop devices"
+
+invoke_kpartx -d $LO3
+
+# This will also delete the loop device
+invoke_kpartx -d $FILE2
+invoke_kpartx -d $LO1
+usleep $WAIT_US
+
+# ls -l /dev/mapper
+assert_unexists $LO1P1
+pop_cleanup
+assert_unexists $LO2P1
+pop_cleanup
+# spans should not have been removed
+# LVs neither
+assert_exists /dev/mapper/$SPAN1 /dev/mapper/$SPAN2 /dev/mapper/$USER1 /dev/mapper/$VG-$LV
+
+step "delete partitions on $LO3 with -f"
+
+invoke_kpartx -f -d $LO3
+# -d -f should delete the LV, too
+assert_unexists /dev/mapper/$VG-$LV
+assert_exists /dev/mapper/$SPAN1 /dev/mapper/$SPAN2
+
+step "test kpartx creation/deletion on an image file with no existing loopdev"
+losetup -d $LO4
+
+OUTPUT=$(invoke_kpartx -v -a $FILE4 2>&1)
+read loop dm < \
+ <(sed -n 's/^add map \(loop[0-9]*\)p1 ([0-9]*:\([0-9]*\)).*$/\1 dm-\2/p' \
+ <<<$OUTPUT)
+[[ $dm && $loop ]]
+push_cleanup "dmsetup remove -f /dev/$dm"
+push_cleanup "losetup -d /dev/$loop"
+
+assert_exists /dev/mapper/${loop}p1
+invoke_kpartx -d $FILE4
+assert_unexists /dev/mapper/${loop}p1
+# /dev/$loop is _not_ automatically deleted
+assert_exists /dev/${loop}
+
+[ $ALL_FAIL -eq 0 ] && OK=yes
diff --git a/user/latte-dock/APKBUILD b/user/latte-dock/APKBUILD
new file mode 100644
index 000000000..619645630
--- /dev/null
+++ b/user/latte-dock/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=latte-dock
+pkgver=0.9.11
+pkgrel=0
+pkgdesc="KDE dock"
+url="https://kde.org/applications/utilities/org.kde.latte-dock"
+arch="all"
+license="GPL-2.0+"
+depends="plasma-workspace qqc2-desktop-style qt5-qtgraphicaleffects
+ qt5-qtquickcontrols"
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev
+ kactivities-dev karchive-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev
+ kdeclarative-dev kglobalaccel-dev kguiaddons-dev ki18n-dev
+ kiconthemes-dev knewstuff-dev knotifications-dev kwayland-dev
+ kwindowsystem-dev kxmlgui-dev plasma-framework-dev"
+subpackages="$pkgname-lang"
+source="https://download.kde.org/stable/latte-dock/latte-dock-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS} \
+ .
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d02747e4709de8f3091c4686f6d80129fa2fe9d6e994cec436083c59b0ceab0b01af3c1c92d946e497e725bd20efc8ec1e8d284666348a13cf6ba79e515c30d5 latte-dock-0.9.11.tar.xz"
diff --git a/user/libpsl/APKBUILD b/user/libpsl/APKBUILD
index 66d49e293..2b842085b 100644
--- a/user/libpsl/APKBUILD
+++ b/user/libpsl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=libpsl
-pkgver=0.21.0
+pkgver=0.21.1
pkgrel=0
pkgdesc="C library for examining the Public Suffix List"
url="https://rockdaboot.github.io/libpsl"
@@ -10,7 +10,7 @@ license="MIT AND BSD-3-Clause"
depends=""
makedepends="python3 libidn2-dev libunistring-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/rockdaboot/libpsl/releases/download/libpsl-$pkgver/libpsl-$pkgver.tar.gz
+source="https://github.com/rockdaboot/libpsl/releases/download/$pkgver/libpsl-$pkgver.tar.gz
use-python3.patch
"
@@ -33,5 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="165c4f0b0640a813d512bd916e1532e32e43c8c81a5efd048f3a5b07b1b3c9129b4c4b5008b8b11a7c1b3914caea17564321389cd350bf1d687d53a97f2afa4d libpsl-0.21.0.tar.gz
+sha512sums="a5084b9df4ff2a0b1f5074b20972efe0da846473396d27b57967c7f6aa190ab3c910b4bfc4f8f03802f08decbbad5820d850c36ad59610262ae37fe77de0c7f5 libpsl-0.21.1.tar.gz
00c9c09bac334efcd7ae6240b740ac88453425cc380cc23b443a0579f4ccabf86eafdb90f5f05027cc55ee20f6c1d4388939792a55cd95705d5e6919d40b30e5 use-python3.patch"
diff --git a/user/live-media/APKBUILD b/user/live-media/APKBUILD
index 9d2905189..224755425 100644
--- a/user/live-media/APKBUILD
+++ b/user/live-media/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=live-media
-pkgver=2020.07.21
+pkgver=2020.07.31
pkgrel=0
pkgdesc="Libraries for multimedia streaming"
url="http://live555.com/liveMedia"
@@ -51,4 +51,4 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="10fc8b9803b88d89860a72927fe7ca107032dcb6582cc4e76a5d71af323156bb3de5d7c3371cbb98e067d52db44eab208d1c9957ede12c1bca1d6ecf59db43bc live.2020.07.21.tar.gz"
+sha512sums="e23f6da5b0b1767c959bc3591276f8e0678732d4f197b1369aea2963ef2bf1e37a9ac714deded783819c1d5b5f9319cff0ed15f349908d88986649dc16e2da15 live.2020.07.31.tar.gz"
diff --git a/user/marco/APKBUILD b/user/marco/APKBUILD
index 30c55065c..b138a4789 100644
--- a/user/marco/APKBUILD
+++ b/user/marco/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=marco
-pkgver=1.24.0
+pkgver=1.24.1
pkgrel=0
pkgdesc="Window manager for the MATE desktop environment"
url="https://mate-desktop.org"
@@ -34,5 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b257994c097f174fe83f3f0f4d6b6991e8c0f402daffd99f8a9521d588b609c56953e73dd4d143be64f5c9a4caa8d890ff30a120e18a9d5b36c6f856a7190428 marco-1.24.0.tar.xz
+sha512sums="55607898b64f0da3a85dd8d7fd092d847c8f67cefa096a63dbe074c197157a3d661fcb3f2a495b4425340b583b600cda3d1c92ac08b7327904dbd4aab8e92c85 marco-1.24.1.tar.xz
b377b2a7d2af094a8b4bd6d1827c85f9675656cd8bdc6892b334c8479d188459ec8585fed3c746fdaef5820f768ce93605586693a3308f0db2d6f58e08f4df49 correctly-posix.patch"
diff --git a/user/qt5ct/APKBUILD b/user/qt5ct/APKBUILD
index 1aa673cea..462e54241 100644
--- a/user/qt5ct/APKBUILD
+++ b/user/qt5ct/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=qt5ct
-pkgver=1.0
+pkgver=1.1
pkgrel=0
pkgdesc="GUI utility for configuring Qt5"
url="https://sourceforge.net/projects/qt5ct/"
@@ -21,4 +21,4 @@ package() {
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="f650362c90782128e1b3ddb61e73d0295bc5b108a75c8a10d085ce9df7dc0926ac40baf80705136b39cc779212fc97e121757c440f2728aab12b761caace78b2 qt5ct-1.0.tar.bz2"
+sha512sums="0df00c0680aefb0eada1ddb70886fd63641c403ab42843f8d209413a56895dce0a88eb88a98d09d23a30df3b15ca1d595237592958769a1be86719f2a16cbdf7 qt5ct-1.1.tar.bz2"
diff --git a/user/ttf-sudo/APKBUILD b/user/ttf-sudo/APKBUILD
index 9d5b07819..6c200fa5c 100644
--- a/user/ttf-sudo/APKBUILD
+++ b/user/ttf-sudo/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=ttf-sudo
-pkgver=0.42
+pkgver=0.50
pkgrel=0
pkgdesc="Monospaced font family for programming and console users"
url="https://www.kutilek.de/sudo-font/"
@@ -9,9 +9,9 @@ arch="noarch"
options="!check" # No test suite.
license="OFL-1.1"
depends="fontconfig"
-makedepends=""
-source="https://github.com/jenskutilek/sudo-font/releases/download/v$pkgver/sudo.zip"
-builddir="$srcdir/sudo"
+makedepends="unzip"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jenskutilek/sudo-font/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/sudo-font-$pkgver/sudo"
package() {
mkdir -p "$pkgdir"/usr/share/fonts/X11/TTF/${pkgname#*-}
@@ -20,4 +20,4 @@ package() {
done
}
-sha512sums="e48016ed1a4f6cc29f7301667a7e6a4cb7c09c85a2410c8eea3cfadb0b89ed29495834c5ac007f05b3fa25d63f3597118ac468fba4c2913282810cc23dd755e0 sudo.zip"
+sha512sums="d48020d5261f9b968ad2fc92f88ce4b1482e3b752b33b50452875951b09cd7472d520b60380321af49404de7986b06d6e653017a07e6a8687792f333a96e8532 ttf-sudo-0.50.tar.gz"
diff --git a/user/tumbler/APKBUILD b/user/tumbler/APKBUILD
index 723a1b2ff..a1946e12d 100644
--- a/user/tumbler/APKBUILD
+++ b/user/tumbler/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=tumbler
-pkgver=0.2.8
+pkgver=0.2.9
pkgrel=0
pkgdesc="Thumbnail generation service for the XFCE desktop environment"
url="https://xfce.org"
@@ -33,4 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="cfb322fb960b4f4d25c6dc68db5087c46845592fd0af839269598dc22930f5d460aae5df7c852024de3733fad9b0e53a8906700cb4ba43ab60883a6104f3e7cb tumbler-0.2.8.tar.bz2"
+sha512sums="df9cf9b2ba77e220f11c5ca3ec4601c973802b802e989dcd24d1b2c7c13e97c185071488c866f3ed5ed1cc6defde1a4879b5fc2c48bfc015456508e526d6bf0f tumbler-0.2.9.tar.bz2"