summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/aspell/APKBUILD16
-rw-r--r--user/aspell/aspell-0.60.6.1-gcc7-fixes.patch34
-rw-r--r--user/gnutls/APKBUILD4
-rw-r--r--user/highlight/APKBUILD4
-rw-r--r--user/qt5-qtbase/APKBUILD6
-rw-r--r--user/qt5-qtbase/big-endian-scroll-wheel.patch43
-rw-r--r--user/qt5-qtbase/qt-musl-iconv-no-bom.patch2
7 files changed, 56 insertions, 53 deletions
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
index 88ab8a736..bce270974 100644
--- a/user/aspell/APKBUILD
+++ b/user/aspell/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=aspell
-pkgver=0.60.6.1
-pkgrel=15
+pkgver=0.60.7
+pkgrel=0
pkgdesc="Libre spell checker software"
url="http://aspell.net/"
arch="all"
@@ -12,14 +12,7 @@ makedepends="ncurses-dev perl"
provides="aspell-utils"
subpackages="$pkgname-compat::noarch $pkgname-dev $pkgname-doc
$pkgname-lang"
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- aspell-0.60.6.1-gcc7-fixes.patch
- "
-
-prepare() {
- default_prepare
- update_config_sub
-}
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
LIBS="-ltinfo" ./configure \
@@ -49,5 +42,4 @@ compat() {
mv spell ispell "$subpkgdir"/usr/bin/
}
-sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz
-7acdd483fa218952775282f42c28998b4901b1c70aeeef307835a205d1cde3fb2912898d08799ee596d744dde55d04e5c4905fb66d8bfa3028d1f5d45bb66d1e aspell-0.60.6.1-gcc7-fixes.patch"
+sha512sums="6f5fcd1c29164ee18f205594b66f382b51d19b17686293a931ca92c1442d3f7228627ca7d604d860551d0d367ac34dfb2ae34170a844f51e84e390fb1edc4535 aspell-0.60.7.tar.gz"
diff --git a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch b/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
deleted file mode 100644
index 4eb825a24..000000000
--- a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 8089fa02122fed0a6394eba14bbedcb1d18e2384
-Author: Kevin Atkinson <kevina@gnu.org>
-Date: Thu Dec 29 00:50:31 2016 -0500
-
- Compile Fixes for GCC 7.
-
- Closes #519.
-
-diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
-index a979539..19ab63c 100644
---- a/modules/filter/tex.cpp
-+++ b/modules/filter/tex.cpp
-@@ -174,7 +174,7 @@ namespace {
-
- if (c == '{') {
-
-- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
-+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
- push_command(Parm);
-
- top.in_what = Parm;
-diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
-index db54f3d..89ee09d 100644
---- a/prog/check_funs.cpp
-+++ b/prog/check_funs.cpp
-@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
- }
- }
- if (i == width-1) {
-- if (word == '\0')
-+ if (*word == '\0')
- put(out,' ');
- else if (word[len] == '\0')
- put(out, word, len);
diff --git a/user/gnutls/APKBUILD b/user/gnutls/APKBUILD
index 627abf2ec..8578e002b 100644
--- a/user/gnutls/APKBUILD
+++ b/user/gnutls/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer:
pkgname=gnutls
-pkgver=3.6.8
+pkgver=3.6.9
pkgrel=0
pkgdesc="A TLS protocol implementation"
url="http://www.gnutls.org/"
@@ -80,5 +80,5 @@ xx() {
mv "$pkgdir"/usr/lib/lib*xx.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="71f0899de0ffb2a39b25928042114e2bbfde7fbf2029d9f91f60bf60794916d13f544fc97337e4e3282e7faa17e79a8012b0e08f98805bee543c0ba4e5d5a905 gnutls-3.6.8.tar.xz
+sha512sums="a9fd0f4edae4c081d5c539ba2e5574a4d7294bc00c5c73ea25ce26cb7fd126299c2842a282d45ef5cf0544108f27066e587df28776bc7915143d190d7d5b9d07 gnutls-3.6.9.tar.xz
abc24ee59cc67805fe953535b0bae33080fc8b0bf788304377f6d10ec8c162c4cf203a69c98a4ba3483b4c60ed7a204433cc7db9b8190eddb0d68f6fb6dad52d gnulib-tests-dont-require-gpg-passphrase.patch"
diff --git a/user/highlight/APKBUILD b/user/highlight/APKBUILD
index d0289e95a..8ceb16c85 100644
--- a/user/highlight/APKBUILD
+++ b/user/highlight/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=highlight
-pkgver=3.52
+pkgver=3.53
pkgrel=0
pkgdesc="Fast and flexible source code highlighter"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
@@ -20,4 +20,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4a44f6c4d29836c6f1af9db02c4e989c7ce155bcb387ca294170c361ae6c41b7441b03810ee27e7b7cdbd3ec73907fb5746ab545b7a44dfc482cc242a86681fe highlight-3.52.tar.bz2"
+sha512sums="b25340aa881e5188fb9862d4858fab17627a80329835723a75de95bbf523f2453f42fa4e6ed842345b5e2842d66a40f16b03c19fbbbea4a226e247a93130a5e3 highlight-3.53.tar.bz2"
diff --git a/user/qt5-qtbase/APKBUILD b/user/qt5-qtbase/APKBUILD
index 08e623af5..95f461d64 100644
--- a/user/qt5-qtbase/APKBUILD
+++ b/user/qt5-qtbase/APKBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-qtbase
_pkgname=qtbase-opensource-src
pkgver=5.9.7
-pkgrel=0
+pkgrel=1
pkgdesc="Qt 5.9 base components"
url="https://www.qt.io/"
arch="all"
@@ -22,6 +22,7 @@ makedepends="$depends_dev
"
subpackages="$pkgname-dev $pkgname-doc $_sub"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ big-endian-scroll-wheel.patch
link-to-execinfo.patch
qt-musl-iconv-no-bom.patch
"
@@ -173,5 +174,6 @@ x11() {
}
sha512sums="7121837501b810f31863fbb3a6ea7189d3e38789ff25eb49b639a69b73913761c8cba18b65046519693d2f5c8755c2197feff1df1ec3d88676d00c649a326e1e qtbase-opensource-src-5.9.7.tar.xz
+0f5b3d93bd1543f4e28e3dfe4a77db4759f2e3afbeb6f6b2c3aa76bf106ed585984ea228b2233bc53afeb3f51c557e3545b18a74096d2cf129364a1f6c4ef090 big-endian-scroll-wheel.patch
ee78a44e28ba5f728914bfc3d8d5b467896c7de11a02d54b0bce11e40a4338b1f776c1fcc30cbd436df4f548c1ab0b4fe801f01b162ddd5c0f892893e227acfd link-to-execinfo.patch
-7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch"
+dca65670df25a8e391d4c62b8967f4377cbd193a3053d8e8e288452ea197f418fe3f6d9d5e48dc333a44aeadec68e3d4380b3672a07ef6baf7aa3eed96ba96e3 qt-musl-iconv-no-bom.patch"
diff --git a/user/qt5-qtbase/big-endian-scroll-wheel.patch b/user/qt5-qtbase/big-endian-scroll-wheel.patch
new file mode 100644
index 000000000..3fbb8aec7
--- /dev/null
+++ b/user/qt5-qtbase/big-endian-scroll-wheel.patch
@@ -0,0 +1,43 @@
+--- qtbase-opensource-src-5.9.7/src/plugins/platforms/xcb/qxcbconnection_xi2.cpp.old 2018-10-16 08:37:05.000000000 +0000
++++ qtbase-opensource-src-5.9.7/src/plugins/platforms/xcb/qxcbconnection_xi2.cpp 2019-08-03 03:58:05.875790720 +0000
+@@ -43,6 +43,7 @@
+ #include "qxcbwindow.h"
+ #include "qtouchdevice.h"
+ #include "QtCore/qmetaobject.h"
++#include "QtCore/qendian.h"
+ #include <qpa/qwindowsysteminterface_p.h>
+ #include <QDebug>
+ #include <cmath>
+@@ -106,6 +107,7 @@
+ XIEventMask xiEventMask;
+ bitMask = XI_HierarchyChangedMask;
+ bitMask |= XI_DeviceChangedMask;
++ bitMask = qToLittleEndian(bitMask);
+ xiEventMask.deviceid = XIAllDevices;
+ xiEventMask.mask_len = sizeof(bitMask);
+ xiEventMask.mask = xiBitMask;
+@@ -327,7 +329,8 @@
+ }
+ XIEventMask mask;
+ mask.mask_len = sizeof(bitMask);
++ bitMask = qToLittleEndian(bitMask);
+ mask.mask = xiBitMask;
+ // When xi2MouseEvents() is true (the default), pointer emulation for touch and tablet
+ // events will get disabled. This is preferable, as Qt Quick handles touch events
+ // directly, while for other applications QtGui synthesizes mouse events.
+@@ -353,6 +356,7 @@
+ tabletBitMask = XI_PropertyEventMask;
+ if (!pointerSelected)
+ tabletBitMask |= XI_ButtonPressMask | XI_ButtonReleaseMask | XI_MotionMask;
++ tabletBitMask = qToLittleEndian(tabletBitMask);
+ for (int i = 0; i < m_tabletData.count(); ++i) {
+ int deviceId = m_tabletData.at(i).deviceId;
+ tabletDevices.insert(deviceId);
+@@ -374,6 +378,7 @@
+
+ scrollBitMask = XI_MotionMask;
+ scrollBitMask |= XI_ButtonReleaseMask;
++ scrollBitMask = qToLittleEndian(scrollBitMask);
+ int i=0;
+ for (const ScrollingDevice& scrollingDevice : qAsConst(m_scrollingDevices)) {
+ if (tabletDevices.contains(scrollingDevice.deviceId))
diff --git a/user/qt5-qtbase/qt-musl-iconv-no-bom.patch b/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
index 8bf35ec1e..be2afc714 100644
--- a/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
+++ b/user/qt5-qtbase/qt-musl-iconv-no-bom.patch
@@ -1,6 +1,6 @@
--- qtbase/src/corelib/codecs/qiconvcodec.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/corelib/codecs/qiconvcodec.cpp 2017-02-21 14:33:32.423808603 +0100
-@@ -64,7 +64,7 @@
+@@ -63,7 +63,7 @@
#elif defined(Q_OS_AIX)
# define NO_BOM
# define UTF16 "UCS-2"