summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
Diffstat (limited to 'user')
-rw-r--r--user/feh/APKBUILD42
-rw-r--r--user/feh/cflags.patch11
-rw-r--r--user/feh/stdout-buff.patch113
-rw-r--r--user/lxqt-desktop/APKBUILD8
-rw-r--r--user/xmlsec/APKBUILD60
5 files changed, 232 insertions, 2 deletions
diff --git a/user/feh/APKBUILD b/user/feh/APKBUILD
new file mode 100644
index 000000000..b68566ae2
--- /dev/null
+++ b/user/feh/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=feh
+pkgver=2.23
+pkgrel=0
+pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
+url="http://feh.finalrewind.org/"
+arch="all"
+license="MIT-feh"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libxt-dev libpng-dev giblib-dev imlib2-dev libjpeg-turbo-dev
+ libxinerama-dev curl-dev libexif-dev"
+checkdepends="perl-utils perl-test-command"
+source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2
+ stdout-buff.patch
+ cflags.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr curl=1 exif=1 xinerama=1
+}
+
+check() {
+ cd "$builddir"
+ make PREFIX=/usr test
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" \
+ bin_dir="$pkgdir"/usr/bin \
+ man_dir="$pkgdir"/usr/share/man \
+ doc_dir="$pkgdir"/usr/share/doc/$pkgname \
+ example_dir="$pkgdir"/usr/share/doc/$pkgname/examples \
+ install
+}
+
+sha512sums="4b75f0053c3a4b1fb51251536896fd48470117ca3d59de1ac5a87f8071f37f886542e7d82730eec4579a1ebf507e4bc8a00fc45cf1364d2445b1aa82c5664ee7 feh-2.23.tar.bz2
+38ead15a58c402181da3e39c09002d9f951b03cfdf5edde19072da313638025dca5fa7dbe466b8f05094d49d44750c467d7fa3832fbaa11ac135c5839e0ecdc1 stdout-buff.patch
+577e0420aef6bbf1cc43fe97813fd56a877c45b9cb01f1f86ee41863a8bf12f97b5f62c01b37a6b8fc78f7dd8ab9a372d1b09ba00e3811d0043772f5e16e0707 cflags.patch"
diff --git a/user/feh/cflags.patch b/user/feh/cflags.patch
new file mode 100644
index 000000000..88f0c05c9
--- /dev/null
+++ b/user/feh/cflags.patch
@@ -0,0 +1,11 @@
+--- feh-2.23/config.mk 2017-12-28 18:28:35.000000000 +0000
++++ feh-2.23/config.mk 2018-01-08 01:19:54.440000000 +0000
+@@ -38,7 +38,7 @@
+ CFLAGS += -Wall -Wextra -pedantic
+
+ # Settings for glibc >= 2.19 - may need to be adjusted for other systems
+-CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=500
++CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700
+
+ ifeq (${curl},1)
+ CFLAGS += -DHAVE_LIBCURL
diff --git a/user/feh/stdout-buff.patch b/user/feh/stdout-buff.patch
new file mode 100644
index 000000000..eaa251a3a
--- /dev/null
+++ b/user/feh/stdout-buff.patch
@@ -0,0 +1,113 @@
+On glibc, if output is redirected to a file, output will look like this:
+
+touch test/ok/gif
+touch test/ok/jpg
+touch test/ok/png
+touch test/ok/pnm
+test/ok/gif
+test/ok/jpg
+test/ok/png
+test/ok/pnm
+
+On musl, if stdout is redirected to a file, output looks like this:
+
+test/ok/gif
+touch test/ok/gif
+touch test/ok/jpg
+touch test/ok/png
+touch test/ok/pnm
+test/ok/jpg
+test/ok/png
+test/ok/pnm
+
+On glibc and musl, if stdout is interactive, it looks like this:
+
+test/ok/gif
+touch test/ok/gif
+test/ok/jpg
+touch test/ok/jpg
+test/ok/png
+touch test/ok/png
+test/ok/pnm
+touch test/ok/pnm
+
+Adding two fflush calls makes all behavior look like the last example.
+
+--- feh-2.22/src/list.c 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/src/list.c 2018-01-03 02:59:08.840000000 +0000
+@@ -92,6 +92,7 @@
+ if (opt.verbose)
+ feh_display_status('.');
+ puts(file->filename);
++ fflush(stdout);
+ feh_action_run(file, opt.actions[0], NULL);
+ }
+ else {
+@@ -106,6 +107,7 @@
+ if (opt.verbose)
+ feh_display_status('.');
+ puts(file->filename);
++ fflush(stdout);
+ feh_action_run(file, opt.actions[0], NULL);
+ }
+ else {
+--- feh-2.22/test/nx_action/loadable_action 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/loadable_action 2018-01-03 02:46:48.030000000 +0000
+@@ -1,8 +1,8 @@
+-touch test/ok/gif
+-touch test/ok/jpg
+-touch test/ok/png
+-touch test/ok/pnm
+ test/ok/gif
++touch test/ok/gif
+ test/ok/jpg
++touch test/ok/jpg
+ test/ok/png
++touch test/ok/png
+ test/ok/pnm
++touch test/ok/pnm
+--- feh-2.22/test/nx_action/loadable_naction 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/loadable_naction 2018-01-03 02:51:05.340000000 +0000
+@@ -1,8 +1,8 @@
+-touch test/ok/gif
+-touch test/ok/jpg
+-touch test/ok/png
+-touch test/ok/pnm
+ test/ok/gif
++touch test/ok/gif
+ test/ok/jpg
++touch test/ok/jpg
+ test/ok/png
++touch test/ok/png
+ test/ok/pnm
++touch test/ok/pnm
+--- feh-2.22/test/nx_action/unloadable_action 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/unloadable_action 2018-01-03 02:51:36.480000000 +0000
+@@ -1,8 +1,8 @@
+-rm test/fail/gif
+-rm test/fail/jpg
+-rm test/fail/png
+-rm test/fail/pnm
+ test/fail/gif
++rm test/fail/gif
+ test/fail/jpg
++rm test/fail/jpg
+ test/fail/png
++rm test/fail/png
+ test/fail/pnm
++rm test/fail/pnm
+--- feh-2.22/test/nx_action/unloadable_naction 2017-11-04 14:03:43.000000000 +0000
++++ feh-2.22/test/nx_action/unloadable_naction 2018-01-03 02:51:51.850000000 +0000
+@@ -1,8 +1,8 @@
+-rm test/fail/gif
+-rm test/fail/jpg
+-rm test/fail/png
+-rm test/fail/pnm
+ test/fail/gif
++rm test/fail/gif
+ test/fail/jpg
++rm test/fail/jpg
+ test/fail/png
++rm test/fail/png
+ test/fail/pnm
++rm test/fail/pnm
diff --git a/user/lxqt-desktop/APKBUILD b/user/lxqt-desktop/APKBUILD
index 1cc486c90..6bb3ce183 100644
--- a/user/lxqt-desktop/APKBUILD
+++ b/user/lxqt-desktop/APKBUILD
@@ -2,13 +2,17 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=lxqt-desktop
pkgver=0.12.0
-pkgrel=0
+pkgrel=1
arch="noarch"
pkgdesc="Complete LXQt desktop"
url="https://lxqt.org"
license="NCSA"
options="!check" # meta package, no tests needed.
-depends="breeze breeze-icons oxygen ttf-liberation xorg-server dbus-x11 openbox lxqt-panel lxqt-runner qterminal pcmanfm-qt lxqt-sudo lxqt-session lxqt-powermanagement lxqt-policykit lxqt-openssh-askpass lxqt-notificationd lxqt-globalkeys lxqt-config lxqt-admin lxqt-about lximage-qt lxqt-themes pavucontrol-qt compton-conf"
+depends="breeze breeze-icons oxygen ttf-liberation xorg-server dbus-x11 openbox
+ lxqt-panel lxqt-runner lxqt-qtplugin qterminal pcmanfm-qt lxqt-sudo
+ lxqt-session lxqt-powermanagement lxqt-policykit lxqt-openssh-askpass
+ lxqt-notificationd lxqt-globalkeys lxqt-config lxqt-admin lxqt-about
+ lximage-qt lxqt-themes pavucontrol-qt compton-conf"
makedepends=""
install=""
subpackages=""
diff --git a/user/xmlsec/APKBUILD b/user/xmlsec/APKBUILD
new file mode 100644
index 000000000..4a3b752ed
--- /dev/null
+++ b/user/xmlsec/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname="xmlsec"
+pkgver=1.2.25
+pkgrel=0
+pkgdesc="C-based XML signature and encryption syntax and processing library"
+url="https://github.com/lsh123/${pkgname}/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="${depends_dev} libxml2-dev libxslt-dev openssl-dev nss-dev
+ autoconf automake libtool"
+install=""
+options="libtool"
+subpackages="$pkgname-nss $pkgname-dev $pkgname-doc"
+source="${url}/archive/${pkgname}-${pkgver//./_}.tar.gz"
+builddir="${srcdir}/${pkgname}-${pkgname}-${pkgver//./_}"
+
+prepare() {
+ cd "${builddir}"
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ cd "${builddir}"
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix='/usr' \
+ --disable-static \
+ --enable-pkgconfig \
+ --with-openssl=/usr \
+ --without-gnutls \
+ --without-gcrypt \
+ --with-default-crypto='openssl'
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make -k check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+nss() {
+ pkgdesc="xmlsec NSS plugin"
+ install_if="$pkgname=$pkgver-r$pkgrel nss"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libxmlsec1-nss.so* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz"