summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorTim Fuller <tjfulle@sandia.gov>2024-03-06 03:18:49 -0700
committerGitHub <noreply@github.com>2024-03-06 11:18:49 +0100
commit7e468aefd5dcc8b12c4e543ba3f9411dd3775759 (patch)
tree8989d84675aac1b9fe5a7590484acb782f510796 /pyproject.toml
parente685d04f8454bd26e848e64218d0e8a0b9084f1a (diff)
downloadspack-7e468aefd5dcc8b12c4e543ba3f9411dd3775759.tar.gz
spack-7e468aefd5dcc8b12c4e543ba3f9411dd3775759.tar.bz2
spack-7e468aefd5dcc8b12c4e543ba3f9411dd3775759.tar.xz
spack-7e468aefd5dcc8b12c4e543ba3f9411dd3775759.zip
Allow loading extensions through python entry-points (#42370)
This PR adds the ability to load spack extensions through `importlib.metadata` entry points, in addition to the regular configuration variable. It requires Python 3.8 or greater to be properly supported.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0a4d094d1a..06aec6fc43 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -154,11 +154,13 @@ ignore_missing_imports = true
'boto3',
'botocore',
'distro',
+ 'importlib.metadata',
'jinja2',
'jsonschema',
'macholib',
'markupsafe',
'numpy',
+ 'pkg_resources',
'pyristent',
'pytest',
'ruamel.yaml',