summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/abyss
diff options
context:
space:
mode:
authorAudrey Thoma <las_thoma15@iastate.edu>2017-06-20 16:34:42 -0500
committerAdam J. Stewart <ajstewart426@gmail.com>2017-06-20 16:34:42 -0500
commitbcb8615fb0d009ad4e7899b9e91701333dc56990 (patch)
treeaea88df0e918381e7fb2e74725e2211d10c7cf71 /var/spack/repos/builtin/packages/abyss
parent12113c41e49dc557f05f4dc0e5d10d9459b134a1 (diff)
downloadspack-bcb8615fb0d009ad4e7899b9e91701333dc56990.tar.gz
spack-bcb8615fb0d009ad4e7899b9e91701333dc56990.tar.bz2
spack-bcb8615fb0d009ad4e7899b9e91701333dc56990.tar.xz
spack-bcb8615fb0d009ad4e7899b9e91701333dc56990.zip
Add abyss package (#4555)
* abyss * abyss: deleting attemped test from script * abyss: adding new package abyss * abyss: partially fixing mpi dependency issue * abyss: added mpi provider conflicts
Diffstat (limited to 'var/spack/repos/builtin/packages/abyss')
-rw-r--r--var/spack/repos/builtin/packages/abyss/package.py54
1 files changed, 54 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/abyss/package.py b/var/spack/repos/builtin/packages/abyss/package.py
new file mode 100644
index 0000000000..9f4a31a47e
--- /dev/null
+++ b/var/spack/repos/builtin/packages/abyss/package.py
@@ -0,0 +1,54 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Abyss(AutotoolsPackage):
+ """ABySS is a de novo, parallel, paired-end sequence assembler
+ that is designed for short reads. The single-processor version
+ is useful for assembling genomes up to 100 Mbases in size."""
+
+ homepage = "http://www.bcgsc.ca/platform/bioinfo/software/abyss"
+ url = "http://www.bcgsc.ca/platform/bioinfo/software/abyss/releases/2.0.2/abyss-2.0.2.tar.gz"
+
+ version('2.0.2', '1623f55ad7f4586e80f6e74b1f27c798')
+
+ depends_on('mpi')
+ depends_on('boost@:1.50.0,1.53.0:')
+ depends_on('sparsehash')
+ depends_on('sqlite')
+
+ conflicts('^intel-mpi')
+ conflicts('^intel-parallel-studio+mpi')
+ conflicts('^mvapich2')
+ conflicts('^spectrum-mpi')
+
+ def configure_args(self):
+ args = ['--with-boost=%s' % self.spec['boost'].prefix,
+ '--with-sqlite=%s' % self.spec['sqlite'].prefix,
+ '--with-mpi=%s' % self.spec['mpi'].prefix]
+ if self.spec['mpi'].name == 'mpich':
+ args.append('--enable-mpich')
+ return args