summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/ascent/package.py
diff options
context:
space:
mode:
authorMassimiliano Culpo <massimiliano.culpo@gmail.com>2022-04-11 11:39:50 +0200
committerGitHub <noreply@github.com>2022-04-11 11:39:50 +0200
commitd0ad644ea6a0a3874fa7ed3785a4580b68b40b31 (patch)
tree5ef9c20ae73491cfc1ffd869fa7484094148ac43 /var/spack/repos/builtin/packages/ascent/package.py
parentc2f470f4a6630116800ac78d8fd8d812b742cfec (diff)
downloadspack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.gz
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.bz2
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.xz
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.zip
Remove custom phases in packages (1/n) (#29968)
* abi-dumper: remove custom phases * apktool: remove custom phases, add v2.6.1 * aragorn: remove custom phases * ascent: remove custom phases * astral: remove custom phases, add v5.7.1 * bigdft: remove redundant phase definitions * bazel: remove custom phases phase definitions * blasr: remove custom phases phase definitions * bmake: remove custom phases phase definitions, add v20220330 * botan: remove custom phases phase definitions * breakdancer: remove custom phases phase definitions * dnstracer: remove custom phases phase definitions * conduit: remove custom phases phase definitions * eclipse-gcj-parser: remove custom phases phase definitions * eem: remove custom phases phase definitions * fasttree: remove custom phases phase definitions * fleur: remove custom phases phase definitions * fpm: remove custom phases phase definitions * genie: remove custom phases phase definitions * gluegen: remove custom phases phase definitions * gnat: remove custom phases phase definitions * hpgmg: remove custom phases phase definitions * karma: remove custom phases phase definitions * libc: remove custom phases phase definitions
Diffstat (limited to 'var/spack/repos/builtin/packages/ascent/package.py')
-rw-r--r--var/spack/repos/builtin/packages/ascent/package.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/var/spack/repos/builtin/packages/ascent/package.py b/var/spack/repos/builtin/packages/ascent/package.py
index c2fb928f31..38d09da8b0 100644
--- a/var/spack/repos/builtin/packages/ascent/package.py
+++ b/var/spack/repos/builtin/packages/ascent/package.py
@@ -187,11 +187,6 @@ class Ascent(CMakePackage, CudaPackage):
conflicts("+shared", when="+cuda",
msg="Ascent needs to be built with ~shared for CUDA builds.")
- ###################################
- # build phases used by this package
- ###################################
- phases = ['hostconfig', 'cmake', 'build', 'install']
-
def setup_build_environment(self, env):
env.set('CTEST_OUTPUT_ON_FAILURE', '1')
@@ -260,7 +255,8 @@ class Ascent(CMakePackage, CudaPackage):
host_config_path))
return host_config_path
- def hostconfig(self, spec, prefix):
+ @run_before('cmake')
+ def hostconfig(self):
"""
This method creates a 'host-config' file that specifies
all of the options used to configure and build ascent.
@@ -269,6 +265,7 @@ class Ascent(CMakePackage, CudaPackage):
https://ascent.readthedocs.io/en/latest/BuildingAscent.html
"""
+ spec = self.spec
if not os.path.isdir(spec.prefix):
os.mkdir(spec.prefix)