summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/bat
diff options
context:
space:
mode:
authorDiego Magdaleno <38844659+DiegoMagdaleno@users.noreply.github.com>2020-04-27 19:40:35 -0500
committerGitHub <noreply@github.com>2020-04-27 19:40:35 -0500
commitf1a7fb2ffc16788aff261cfbd6f7558828dc6210 (patch)
tree6b089ec4e9811b0b076a0ddd76943f55f712428b /var/spack/repos/builtin/packages/bat
parentcd568829981bf62767b986df6fe9ff40d50500e0 (diff)
downloadspack-f1a7fb2ffc16788aff261cfbd6f7558828dc6210.tar.gz
spack-f1a7fb2ffc16788aff261cfbd6f7558828dc6210.tar.bz2
spack-f1a7fb2ffc16788aff261cfbd6f7558828dc6210.tar.xz
spack-f1a7fb2ffc16788aff261cfbd6f7558828dc6210.zip
Update bat and make the url dynamic (#16127)
* Update bat and make the url dynamic - Now depending on the version it will calculate the url - This also fixes a weird issue that was reported on Darwin, back when I reported that Rust wasn't linking properly on Darwin #15887 on the comment by hartzell i was also experiencing this issue * Remove unnecessary stuff - Removes the need for LLVM - Removes the need for version calculation. * Keep the versions on 1 line * Pass flake8 tests
Diffstat (limited to 'var/spack/repos/builtin/packages/bat')
-rw-r--r--var/spack/repos/builtin/packages/bat/package.py13
1 files changed, 3 insertions, 10 deletions
diff --git a/var/spack/repos/builtin/packages/bat/package.py b/var/spack/repos/builtin/packages/bat/package.py
index 50c3b5349a..0463580f8f 100644
--- a/var/spack/repos/builtin/packages/bat/package.py
+++ b/var/spack/repos/builtin/packages/bat/package.py
@@ -9,9 +9,10 @@ from spack import *
class Bat(Package):
"""A cat(1) clone with wings."""
- homepage = "https://github.com/sharkdp/bat"
- url = "https://github.com/sharkdp/bat/archive/v0.10.0.tar.gz"
+ homepage = 'https://github.com/sharkdp/bat'
+ url = 'https://github.com/sharkdp/bat/archive/v0.13.0.tar.gz'
+ version('0.13.0', sha256='f4aee370013e2a3bc84c405738ed0ab6e334d3a9f22c18031a7ea008cd5abd2a')
version('0.12.1', sha256='1dd184ddc9e5228ba94d19afc0b8b440bfc1819fef8133fe331e2c0ec9e3f8e2')
depends_on('rust')
@@ -19,11 +20,3 @@ class Bat(Package):
def install(self, spec, prefix):
cargo = which('cargo')
cargo('install', '--root', prefix, '--path', '.')
-
- # cargo seems to need these to be set so that when it's building
- # onig_sys it can run llvm-config and link against libclang.
- def setup_build_environment(self, env):
- env.append_flags('LLVM_CONFIG_PATH',
- join_path(self.spec['llvm'].prefix.libexec.llvm,
- 'llvm-config'))
- env.append_flags('LIBCLANG_PATH', self.spec['llvm'].prefix.lib)