summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/boost
diff options
context:
space:
mode:
authorBernhard Kaindl <43588962+bernhardkaindl@users.noreply.github.com>2022-11-23 11:36:22 +0100
committerGitHub <noreply@github.com>2022-11-23 03:36:22 -0700
commit09f2b6f5f575eb71ce0d8a5547d91db0b51df460 (patch)
tree64b021889d0f74eb8bbd7d84d745da23f3e8b733 /var/spack/repos/builtin/packages/boost
parent73fe21ba4185270b223c1f973c02e2ec1a5629e9 (diff)
downloadspack-09f2b6f5f575eb71ce0d8a5547d91db0b51df460.tar.gz
spack-09f2b6f5f575eb71ce0d8a5547d91db0b51df460.tar.bz2
spack-09f2b6f5f575eb71ce0d8a5547d91db0b51df460.tar.xz
spack-09f2b6f5f575eb71ce0d8a5547d91db0b51df460.zip
boost: At least with older Xcode, boost can't build with lzma (#34075)
Reference: https://lists.boost.org/Archives/boost/2019/11/247380.php As reported at the end of #33998 and this link, liblzma on older Xcode on MacOSX 10 misses _lzma_cputhreads, so boost's can't use liblzma on those.
Diffstat (limited to 'var/spack/repos/builtin/packages/boost')
-rw-r--r--var/spack/repos/builtin/packages/boost/package.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/boost/package.py b/var/spack/repos/builtin/packages/boost/package.py
index 03950786b4..36a5f32fa5 100644
--- a/var/spack/repos/builtin/packages/boost/package.py
+++ b/var/spack/repos/builtin/packages/boost/package.py
@@ -524,6 +524,9 @@ class Boost(Package):
"ZSTD_LIBPATH=%s" % spec["zstd"].prefix.lib,
]
)
+ # At least with older Xcode, _lzma_cputhreads is missing (#33998)
+ if "platform=darwin" in self.spec:
+ options.extend(["-s", "NO_LZMA=1"])
link_types = ["static"]
if "+shared" in spec: