summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/boost
diff options
context:
space:
mode:
authorSebastian Mobo <stmobo@gmail.com>2021-02-26 18:46:37 -0500
committerGitHub <noreply@github.com>2021-02-26 17:46:37 -0600
commit4f84721dc17b82af6f789d6020e1c339686d6363 (patch)
tree53d96268d78caa12b5efc6087752dec8bbd780ac /var/spack/repos/builtin/packages/boost
parentf2f58b70b1153621d9b42fa2f9045d81843692a7 (diff)
downloadspack-4f84721dc17b82af6f789d6020e1c339686d6363.tar.gz
spack-4f84721dc17b82af6f789d6020e1c339686d6363.tar.bz2
spack-4f84721dc17b82af6f789d6020e1c339686d6363.tar.xz
spack-4f84721dc17b82af6f789d6020e1c339686d6363.zip
boost: Patch B2 bootstrap step to use correct toolchain (#21408)
Diffstat (limited to 'var/spack/repos/builtin/packages/boost')
-rw-r--r--var/spack/repos/builtin/packages/boost/bootstrap-toolset.patch11
-rw-r--r--var/spack/repos/builtin/packages/boost/package.py5
2 files changed, 16 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/boost/bootstrap-toolset.patch b/var/spack/repos/builtin/packages/boost/bootstrap-toolset.patch
new file mode 100644
index 0000000000..8aed227207
--- /dev/null
+++ b/var/spack/repos/builtin/packages/boost/bootstrap-toolset.patch
@@ -0,0 +1,11 @@
+--- a/bootstrap.sh 2020-12-03 00:00:59.000000000 -0500
++++ a/bootstrap.sh 2021-01-08 13:38:30.000000000 -0500
+@@ -223,7 +223,7 @@
+ if test "x$BJAM" = x; then
+ $ECHO "Building B2 engine.."
+ pwd=`pwd`
+- (cd "$my_dir/tools/build/src/engine" && ./build.sh)
++ (cd "$my_dir/tools/build/src/engine" && ./build.sh "$TOOLSET")
+ if [ $? -ne 0 ]; then
+ echo
+ echo "Failed to build B2 build engine"
diff --git a/var/spack/repos/builtin/packages/boost/package.py b/var/spack/repos/builtin/packages/boost/package.py
index 54a0f50dd8..bb45fda9a3 100644
--- a/var/spack/repos/builtin/packages/boost/package.py
+++ b/var/spack/repos/builtin/packages/boost/package.py
@@ -260,6 +260,11 @@ class Boost(Package):
# See https://github.com/boostorg/python/pull/218
patch('boost_218.patch', when='@1.63.0:1.67.99')
+ # Fix B2 bootstrap toolset during installation
+ # See https://github.com/spack/spack/issues/20757
+ # and https://github.com/spack/spack/pull/21408
+ patch("bootstrap-toolset.patch", when="@1.75:")
+
def patch(self):
# Disable SSSE3 and AVX2 when using the NVIDIA compiler
if self.spec.satisfies('%nvhpc'):