summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cbtf-argonavis-gui
diff options
context:
space:
mode:
authorJim Galarowicz <jeg@krellinst.org>2018-05-17 14:04:33 -0500
committerscheibelp <scheibel1@llnl.gov>2018-05-17 12:04:33 -0700
commitdfd168d557f1acc981c9939526b3ab3f160bee5a (patch)
treeb60ae668a4d4262c1ab3083022e3901e22bfdb88 /var/spack/repos/builtin/packages/cbtf-argonavis-gui
parentde7d13b0e8dea4affd1ff40ff4d9ae62b27f3af0 (diff)
downloadspack-dfd168d557f1acc981c9939526b3ab3f160bee5a.tar.gz
spack-dfd168d557f1acc981c9939526b3ab3f160bee5a.tar.bz2
spack-dfd168d557f1acc981c9939526b3ab3f160bee5a.tar.xz
spack-dfd168d557f1acc981c9939526b3ab3f160bee5a.zip
cbtf-argonavis-gui: add openspeedshop-utils package to address qt conflicts (#8066)
Fixes #7946 Creates an openspeedshop-utils package that does not depend on qt3 and can be used to resolve the needs of cbtf-argonavis-gui. Changes for creating a release versus develop build are also included. There are package versions which are no longer relevant (e.g. 1.3.0 for cbtf-argonavis-gui has been replaced with 1.3.0.0) but these versions need to be kept to allow uninstalling them; issue #8173 has been created to investigate this.
Diffstat (limited to 'var/spack/repos/builtin/packages/cbtf-argonavis-gui')
-rw-r--r--var/spack/repos/builtin/packages/cbtf-argonavis-gui/package.py59
1 files changed, 47 insertions, 12 deletions
diff --git a/var/spack/repos/builtin/packages/cbtf-argonavis-gui/package.py b/var/spack/repos/builtin/packages/cbtf-argonavis-gui/package.py
index c4154592fa..8ba4e23267 100644
--- a/var/spack/repos/builtin/packages/cbtf-argonavis-gui/package.py
+++ b/var/spack/repos/builtin/packages/cbtf-argonavis-gui/package.py
@@ -49,20 +49,55 @@ class CbtfArgonavisGui(QMakePackage):
"""
homepage = "http://sourceforge.net/p/cbtf/wiki/Home/"
+ version('1.3.0.0', branch='1.3.0.0',
+ git='https://github.com/OpenSpeedShop/cbtf-argonavis-gui.git')
+
version('1.3.0', branch='master',
git='https://github.com/OpenSpeedShop/cbtf-argonavis-gui.git')
- depends_on("cmake@3.0.2:", type='build')
- depends_on("openspeedshop+cuda gui='qt4'")
- depends_on('qt@4.8.6:')
- depends_on("boost@1.50.0:")
- depends_on("cbtf")
- depends_on("cbtf-krell")
- depends_on("cbtf-argonavis")
+ version('develop', branch='master',
+ git='https://github.com/OpenSpeedShop/cbtf-argonavis-gui.git')
+
+ depends_on("cmake@3.0.2:", when='@develop', type='build')
+ depends_on("cmake@3.11.1", when='@1.3.0.0', type='build')
+
+ # To specify ^elfutils@0.170 on the command line spack
+ # apparently needs/wants this dependency explicity here
+ # even though it is referenced downstream
+ depends_on("elf", type="link")
+
+ depends_on('qt@4.8.6:', when='@develop')
+ depends_on('qt@5.10.0', when='@1.3.0.0')
+
+ depends_on("boost@1.50.0:", when='@develop')
+ depends_on("boost@1.66.0", when='@1.3.0.0')
+
+ # For MRNet
+ depends_on("mrnet@5.0.1-3:+lwthreads", when='@develop')
+ depends_on("mrnet@5.0.1-3+lwthreads", when='@1.3.0.0')
+
+ # Dependencies for the openspeedshop cbtf packages.
+ depends_on("cbtf@develop", when='@develop')
+ depends_on("cbtf@1.9.1.0", when='@1.3.0.0')
+
+ depends_on("cbtf-krell@develop", when='@develop')
+ depends_on("cbtf-krell@1.9.1.0", when='@1.3.0.0')
+
+ depends_on("cbtf-argonavis@develop", when='@develop')
+ depends_on("cbtf-argonavis@1.9.1.0", when='@1.3.0.0')
+
depends_on("cuda")
- depends_on("mrnet@5.0.1:+lwthreads")
- depends_on("xerces-c@3.1.1:")
- depends_on("graphviz")
+
+ depends_on("openspeedshop-utils+cuda@develop", when='@develop')
+ depends_on("openspeedshop-utils@2.3.1.3+cuda", when='@1.3.0.0')
+
+ # For Xerces-C
+ depends_on("xerces-c@3.1.1:", when='@develop')
+ depends_on("xerces-c@3.1.4", when='@1.3.0.0')
+
+ depends_on("graphviz@2.40.1:", when='@develop')
+ depends_on("graphviz@2.40.1", when='@1.3.0.0')
+
depends_on("qtgraph")
parallel = False
@@ -74,7 +109,7 @@ class CbtfArgonavisGui(QMakePackage):
spack_env.set('CBTF_KRELL_ROOT', self.spec['cbtf-krell'].prefix)
spack_env.set('CBTF_ARGONAVIS_ROOT',
self.spec['cbtf-argonavis'].prefix)
- spack_env.set('OSS_CBTF_ROOT', self.spec['openspeedshop'].prefix)
+ spack_env.set('OSS_CBTF_ROOT', self.spec['openspeedshop-utils'].prefix)
spack_env.set('GRAPHVIZ_ROOT', self.spec['graphviz'].prefix)
spack_env.set('QTGRAPHLIB_ROOT', self.spec['qtgraph'].prefix)
spack_env.set('KRELL_ROOT_MRNET', self.spec['mrnet'].prefix)
@@ -90,7 +125,7 @@ class CbtfArgonavisGui(QMakePackage):
# The openspeedshop libraries are needed to actually load the
# performance information into the GUI.
run_env.prepend_path(
- 'LD_LIBRARY_PATH', self.spec['openspeedshop'].prefix.lib64)
+ 'LD_LIBRARY_PATH', self.spec['openspeedshop-utils'].prefix.lib64)
def qmake_args(self):
options = ['-o', 'Makefile', 'openss-gui.pro']