summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/clamr
diff options
context:
space:
mode:
authorjiseung <anna.jiseung@gmail.com>2017-07-19 08:48:03 -0500
committerAdam J. Stewart <ajstewart426@gmail.com>2017-07-19 08:48:03 -0500
commite3e8893ed9c183678b68ab9228e01a808f86b465 (patch)
tree84d4804f6bf4eea405bd143bcb141a6c9f796cb8 /var/spack/repos/builtin/packages/clamr
parent45a7e8bb12cd840f5998c4ebb1b449183e50af47 (diff)
downloadspack-e3e8893ed9c183678b68ab9228e01a808f86b465.tar.gz
spack-e3e8893ed9c183678b68ab9228e01a808f86b465.tar.bz2
spack-e3e8893ed9c183678b68ab9228e01a808f86b465.tar.xz
spack-e3e8893ed9c183678b68ab9228e01a808f86b465.zip
new package: CLAMR (#4728)
* new package: CLAMR * changed from bool variants to single value variants and corresponding logic in build_type and cmake_args * lowercase variant values * updated conditionals for variants * adjusted url and docstring
Diffstat (limited to 'var/spack/repos/builtin/packages/clamr')
-rw-r--r--var/spack/repos/builtin/packages/clamr/package.py91
1 files changed, 91 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/clamr/package.py b/var/spack/repos/builtin/packages/clamr/package.py
new file mode 100644
index 0000000000..c45069d39f
--- /dev/null
+++ b/var/spack/repos/builtin/packages/clamr/package.py
@@ -0,0 +1,91 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Clamr(CMakePackage):
+ """The CLAMR code is a cell-based adaptive mesh refinement (AMR)
+ mini-app developed as a testbed for hybrid algorithm development
+ using MPI and OpenCL GPU code.
+ """
+
+ homepage = "https://github.com/lanl/CLAMR"
+ url = "https://github.com/lanl/CLAMR.git"
+ tags = ['proxy-app']
+
+ version('master', git='https://github.com/lanl/CLAMR.git')
+
+ variant(
+ 'graphics', default='opengl',
+ values=('opengl', 'mpe', 'none'),
+ description='Build with specified graphics support')
+ variant(
+ 'build', default='relwithdebinfo',
+ values=('debug', 'release', 'relwithdebinfo'),
+ description='Build type')
+ variant(
+ 'precision', default='mixed',
+ values=('single', 'mixed', 'full'),
+ description='single, mixed, or full double precision values')
+
+ depends_on('mpi')
+ depends_on('mpe', when='graphics=mpe')
+
+ def build_type(self):
+ spec = self.spec
+ if 'build=debug' in spec:
+ return 'Debug'
+ elif 'build=release' in spec:
+ return 'Release'
+ else:
+ return 'RelWithDebInfo'
+
+ def cmake_args(self):
+ spec = self.spec
+ cmake_args = []
+ if 'graphics=none' in spec:
+ cmake_args.append('-DGRAPHICS_TYPE=None')
+ elif 'graphics=mpe' in spec:
+ cmake_args.append('-DGRAPHICS_TYPE=MPE')
+ else:
+ cmake_args.append('-DGRAPHICS_TYPE=OpenGL')
+
+ if 'precision=full' in spec:
+ cmake_args.append('-DPRECISION_TYPE=full_precision')
+ elif 'precision=single' in spec:
+ cmake_args.append('-DPRECISION_TYPE=minimum_precision')
+ else:
+ cmake_args.append('-DPRECISION_TYPE=mixed_precision')
+
+ # if MIC, then -DMIC_NATIVE=yes
+ return cmake_args
+
+ def install(self, spec, prefix):
+ install('README', prefix)
+ install('LICENSE', prefix)
+ install_tree('docs', join_path(prefix, 'docs'))
+ install_tree('tests', join_path(prefix, 'tests'))
+ with working_dir(self.build_directory):
+ make('install')