summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/dd4hep
diff options
context:
space:
mode:
authorAndre Sailer <andre.philippe.sailer@cern.ch>2020-09-16 18:33:14 +0200
committerGitHub <noreply@github.com>2020-09-16 17:33:14 +0100
commit635b8243fe3081927cdd6c2198ab7887ea1611b8 (patch)
tree53cd8b5db23d229ac78cf3d3aa667c20da4a1311 /var/spack/repos/builtin/packages/dd4hep
parent0d5c0656787de659f65aecbb2c5b3ee8c8108450 (diff)
downloadspack-635b8243fe3081927cdd6c2198ab7887ea1611b8.tar.gz
spack-635b8243fe3081927cdd6c2198ab7887ea1611b8.tar.bz2
spack-635b8243fe3081927cdd6c2198ab7887ea1611b8.tar.xz
spack-635b8243fe3081927cdd6c2198ab7887ea1611b8.zip
[dd4hep]: add variant lcio (#18691)
Diffstat (limited to 'var/spack/repos/builtin/packages/dd4hep')
-rw-r--r--var/spack/repos/builtin/packages/dd4hep/package.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/dd4hep/package.py b/var/spack/repos/builtin/packages/dd4hep/package.py
index 6f1b2e8a8b..04d60499bf 100644
--- a/var/spack/repos/builtin/packages/dd4hep/package.py
+++ b/var/spack/repos/builtin/packages/dd4hep/package.py
@@ -40,6 +40,7 @@ class Dd4hep(CMakePackage):
variant('geant4', default=False, description="Enable the simulation part based on Geant4")
variant('assimp', default=False, description="Enable CAD interface based on Assimp")
variant('hepmc3', default=False, description="Enable build with hepmc3")
+ variant('lcio', default=False, description="Enable build with lcio")
depends_on('cmake @3.12:', type='build')
depends_on('boost @1.49:')
@@ -49,6 +50,7 @@ class Dd4hep(CMakePackage):
depends_on('geant4@10.2.2:', when='+geant4')
depends_on('assimp', when='+assimp')
depends_on('hepmc3', when="+hepmc3")
+ depends_on('lcio', when="+lcio")
def cmake_args(self):
spec = self.spec
@@ -60,6 +62,7 @@ class Dd4hep(CMakePackage):
"-DCMAKE_CXX_STANDARD={0}".format(cxxstd),
"-DDD4HEP_USE_XERCESC={0}".format(spec.satisfies('+xercesc')),
"-DDD4HEP_USE_GEANT4={0}".format(spec.satisfies('+geant4')),
+ "-DDD4HEP_USE_LCIO={0}".format(spec.satisfies('+lcio')),
"-DDD4HEP_LOAD_ASSIMP={0}".format(spec.satisfies('+assimp')),
"-DDD4HEP_USE_HEPMC3={0}".format(spec.satisfies('+hepmc3')),
"-DBUILD_TESTING={0}".format(self.run_tests),