summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/dssp
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/dssp
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/dssp')
-rw-r--r--var/spack/repos/builtin/packages/dssp/package.py44
1 files changed, 23 insertions, 21 deletions
diff --git a/var/spack/repos/builtin/packages/dssp/package.py b/var/spack/repos/builtin/packages/dssp/package.py
index cc11502b63..55a1fe0ed5 100644
--- a/var/spack/repos/builtin/packages/dssp/package.py
+++ b/var/spack/repos/builtin/packages/dssp/package.py
@@ -11,16 +11,16 @@ class Dssp(AutotoolsPackage):
"""'mkdssp' utility. (dictionary of protein secondary structure)"""
homepage = "https://github.com/cmbi/dssp"
- url = "https://github.com/cmbi/dssp/archive/3.1.4.tar.gz"
+ url = "https://github.com/cmbi/dssp/archive/3.1.4.tar.gz"
- version('3.1.4', sha256='496282b4b5defc55d111190ab9f1b615a9574a2f090e7cf5444521c747b272d4')
- version('2.3.0', sha256='4c95976d86dc64949cb0807fbd58c7bee5393df0001999405863dc90f05846c6')
+ version("3.1.4", sha256="496282b4b5defc55d111190ab9f1b615a9574a2f090e7cf5444521c747b272d4")
+ version("2.3.0", sha256="4c95976d86dc64949cb0807fbd58c7bee5393df0001999405863dc90f05846c6")
- depends_on('autoconf', type='build')
- depends_on('automake', type='build')
- depends_on('libtool', type='build')
- depends_on('m4', type='build')
- depends_on('boost@1.48:')
+ depends_on("autoconf", type="build")
+ depends_on("automake", type="build")
+ depends_on("libtool", type="build")
+ depends_on("m4", type="build")
+ depends_on("boost@1.48:")
# TODO: replace this with an explicit list of components of Boost,
# for instance depends_on('boost +filesystem')
@@ -34,28 +34,30 @@ class Dssp(AutotoolsPackage):
url="https://files.rcsb.org/download/1ALK.pdb",
sha256="99f4cd7ab63b35d64eacc85dc1491af5a03a1a0a89f2c9aadfb705c591b4b6c9",
expand=False,
- placement='pdb'
+ placement="pdb",
)
def configure_args(self):
- args = [
- "--with-boost=%s" % self.spec['boost'].prefix]
+ args = ["--with-boost=%s" % self.spec["boost"].prefix]
return args
- @run_after('configure')
+ @run_after("configure")
def edit(self):
- makefile = FileFilter(join_path(self.stage.source_path, 'Makefile'))
- makefile.filter('.*-Werror .*', ' -Wno-error \\')
+ makefile = FileFilter(join_path(self.stage.source_path, "Makefile"))
+ makefile.filter(".*-Werror .*", " -Wno-error \\")
- @run_after('install')
+ @run_after("install")
def cache_test_sources(self):
"""Save off the pdb sources for stand-alone testing."""
- self.cache_extra_test_sources('pdb')
+ self.cache_extra_test_sources("pdb")
def test(self):
"""Perform stand-alone/smoke test on installed package."""
- pdb_path = join_path(self.test_suite.current_test_cache_dir, 'pdb')
- self.run_test('mkdssp', options=['1ALK.pdb', '1alk.dssp'],
- purpose='test: calculating structure for example',
- installed=True,
- work_dir=pdb_path)
+ pdb_path = join_path(self.test_suite.current_test_cache_dir, "pdb")
+ self.run_test(
+ "mkdssp",
+ options=["1ALK.pdb", "1alk.dssp"],
+ purpose="test: calculating structure for example",
+ installed=True,
+ work_dir=pdb_path,
+ )