summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/faiss/package.py
diff options
context:
space:
mode:
authorAdam J. Stewart <ajstewart426@gmail.com>2022-01-14 12:37:57 -0600
committerGitHub <noreply@github.com>2022-01-14 12:37:57 -0600
commit3540f8200a536434946492d60b5e56b302112305 (patch)
treef1648d8e414394bcce2c3e749b82ad49e182a284 /var/spack/repos/builtin/packages/faiss/package.py
parent0b2507053e58ef4058631c10e5d9bf7ea2222c20 (diff)
downloadspack-3540f8200a536434946492d60b5e56b302112305.tar.gz
spack-3540f8200a536434946492d60b5e56b302112305.tar.bz2
spack-3540f8200a536434946492d60b5e56b302112305.tar.xz
spack-3540f8200a536434946492d60b5e56b302112305.zip
PythonPackage: install packages with pip (#27798)
* Use pip to bootstrap pip * Bootstrap wheel from source * Update PythonPackage to install using pip * Update several packages * Add wheel as base class dep * Build phase no longer exists * Add py-poetry package, fix py-flit-core bootstrapping * Fix isort build * Clean up many more packages * Remove unused import * Fix unit tests * Don't directly run setup.py * Typo fix * Remove unused imports * Fix issues caught by CI * Remove custom setup.py file handling * Use PythonPackage for installing wheels * Remove custom phases in PythonPackages * Remove <phase>_args methods * Remove unused import * Fix various packages * Try to test Python packages directly in CI * Actually run the pipeline * Fix more packages * Fix mappings, fix packages * Fix dep version * Work around bug in concretizer * Various concretization fixes * Fix gitlab yaml, packages * Fix typo in gitlab yaml * Skip more packages that fail to concretize * Fix? jupyter ecosystem concretization issues * Solve Jupyter concretization issues * Prevent duplicate entries in PYTHONPATH * Skip fenics-dolfinx * Build fewer Python packages * Fix missing npm dep * Specify image * More package fixes * Add backends for every from-source package * Fix version arg * Remove GitLab CI stuff, add py-installer package * Remove test deps, re-add install_options * Function declaration syntax fix * More build fixes * Update spack create template * Update PythonPackage documentation * Fix documentation build * Fix unit tests * Remove pip flag added only in newer pip * flux: add explicit dependency on jsonschema * Update packages that have been added since this was branched off of develop * Move Python 2 deprecation to a separate PR * py-neurolab: add build dep on py-setuptools * Use wheels for pip/wheel * Allow use of pre-installed pip for external Python * pip -> python -m pip * Use python -m pip for all packages * Fix py-wrapt * Add both platlib and purelib to PYTHONPATH * py-pyyaml: setuptools is needed for all versions * py-pyyaml: link flags aren't needed * Appease spack audit packages * Some build backend is required for all versions, distutils -> setuptools * Correctly handle different setup.py filename * Use wheels for py-tomli to avoid circular dep on py-flit-core * Fix busco installation procedure * Clarify things in spack create template * Test other Python build backends * Undo changes to busco * Various fixes * Don't test other backends
Diffstat (limited to 'var/spack/repos/builtin/packages/faiss/package.py')
-rw-r--r--var/spack/repos/builtin/packages/faiss/package.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/var/spack/repos/builtin/packages/faiss/package.py b/var/spack/repos/builtin/packages/faiss/package.py
index 662fe1677f..0c45b97416 100644
--- a/var/spack/repos/builtin/packages/faiss/package.py
+++ b/var/spack/repos/builtin/packages/faiss/package.py
@@ -33,6 +33,8 @@ class Faiss(AutotoolsPackage, CudaPackage):
conflicts('+tests', when='~python', msg='+tests must be accompanied by +python')
depends_on('python@3.7:', when='+python', type=('build', 'run'))
+ depends_on('py-pip', when='+python', type='build')
+ depends_on('py-wheel', when='+python', type='build')
depends_on('py-numpy', when='+python', type=('build', 'run'))
depends_on('py-scipy', when='+tests', type=('build', 'run'))
@@ -85,8 +87,8 @@ class Faiss(AutotoolsPackage, CudaPackage):
if '+python' in self.spec:
with working_dir('python'):
- setup_py('install', '--prefix=' + prefix,
- '--single-version-externally-managed', '--root=/')
+ args = std_pip_args + ['--prefix=' + prefix, '.']
+ pip(*args)
if '+tests' not in self.spec:
return