summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/fides/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/fides/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/fides/package.py')
-rw-r--r--var/spack/repos/builtin/packages/fides/package.py29
1 files changed, 15 insertions, 14 deletions
diff --git a/var/spack/repos/builtin/packages/fides/package.py b/var/spack/repos/builtin/packages/fides/package.py
index 3e9d16c30e..a62be5696a 100644
--- a/var/spack/repos/builtin/packages/fides/package.py
+++ b/var/spack/repos/builtin/packages/fides/package.py
@@ -8,38 +8,39 @@ from spack.package import *
class Fides(CMakePackage):
"""A library that provides a schema for ADIOS2 streams."""
+
homepage = "https://gitlab.kitware.com/vtk/fides"
- url = "https://gitlab.kitware.com/vtk/fides/-/archive/v1.0.0/fides-v1.0.0.tar.gz"
- git = "https://gitlab.kitware.com/vtk/fides.git"
+ url = "https://gitlab.kitware.com/vtk/fides/-/archive/v1.0.0/fides-v1.0.0.tar.gz"
+ git = "https://gitlab.kitware.com/vtk/fides.git"
- maintainers = ['caitlinross', 'dpugmire']
+ maintainers = ["caitlinross", "dpugmire"]
- version('master', branch='master')
- version('1.1.0', sha256='40d2e08b8d5cfdfc809eae6ed2ae0731108ce3b1383485f4934a5ec8aaa9425e')
- version('1.0.0', sha256='c355fdb4ca3790c1fa9a4491a0d294b8f883b6946c540ad9e5633c9fd8c8c3aa')
+ version("master", branch="master")
+ version("1.1.0", sha256="40d2e08b8d5cfdfc809eae6ed2ae0731108ce3b1383485f4934a5ec8aaa9425e")
+ version("1.0.0", sha256="c355fdb4ca3790c1fa9a4491a0d294b8f883b6946c540ad9e5633c9fd8c8c3aa")
variant("mpi", default=True, description="build mpi support")
variant("adios2", default=True, description="build ADIOS2 support")
- variant('vtk-m', default=True, description="build VTK-m support")
+ variant("vtk-m", default=True, description="build VTK-m support")
# Certain CMake versions have been found to break for our use cases
- depends_on("cmake@3.14.1:3.14,3.18.2:", type='build')
+ depends_on("cmake@3.14.1:3.14,3.18.2:", type="build")
depends_on("mpi", when="+mpi")
- depends_on('adios2~zfp', when='+adios2')
+ depends_on("adios2~zfp", when="+adios2")
depends_on("vtk-m@:1.7", when="+vtk-m")
# Fix missing implicit includes
- @when('%gcc@7:')
+ @when("%gcc@7:")
def setup_build_environment(self, env):
- env.append_flags('CXXFLAGS', '-include limits -include numeric')
+ env.append_flags("CXXFLAGS", "-include limits -include numeric")
def cmake_args(self):
spec = self.spec
options = [
- self.define("VTKm_DIR", spec['vtk-m'].prefix),
- self.define("ADIOS2_DIR", spec['adios2'].prefix),
+ self.define("VTKm_DIR", spec["vtk-m"].prefix),
+ self.define("ADIOS2_DIR", spec["adios2"].prefix),
self.define("FIDES_ENABLE_TESTING", "OFF"),
- self.define("FIDES_ENABLE_EXAMPLES", "OFF")
+ self.define("FIDES_ENABLE_EXAMPLES", "OFF"),
]
return options