summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py32
1 files changed, 16 insertions, 16 deletions
diff --git a/var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py b/var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py
index 823cd51cd8..de700408ce 100644
--- a/var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py
+++ b/var/spack/repos/builtin/packages/gamess-ri-mp2-miniapp/package.py
@@ -8,37 +8,37 @@ from spack.package import *
class GamessRiMp2Miniapp(MakefilePackage):
"""The GAMESS RI-MP2 mini-app computes the correlation energy with the
- Hartree-Fock energy and wave-function given as inputs. The inputs
- were generated from GAMESS."""
+ Hartree-Fock energy and wave-function given as inputs. The inputs
+ were generated from GAMESS."""
- tags = ['proxy-app']
+ tags = ["proxy-app"]
homepage = "https://github.com/jkwack/GAMESS_RI-MP2_MiniApp"
- url = "https://github.com/jkwack/GAMESS_RI-MP2_MiniApp/archive/1.5.tar.gz"
+ url = "https://github.com/jkwack/GAMESS_RI-MP2_MiniApp/archive/1.5.tar.gz"
- version('1.5', sha256='0ff4e8e556caa99ce1ab85c53e78932a32d2e2fa3c5d883fa321d5000f8a731e')
+ version("1.5", sha256="0ff4e8e556caa99ce1ab85c53e78932a32d2e2fa3c5d883fa321d5000f8a731e")
- depends_on('mpi')
- depends_on('lapack')
+ depends_on("mpi")
+ depends_on("lapack")
- build_directory = 'build_and_run'
+ build_directory = "build_and_run"
@property
def build_targets(self):
targets = [
- 'rimp2-serial',
- 'SDIR=../source',
- 'FFLAGS_SERIAL=-cpp ' + self.compiler.openmp_flag,
- 'LDFLAGS_ESSL={0}'.format(self.spec['lapack'].libs.ld_flags)
+ "rimp2-serial",
+ "SDIR=../source",
+ "FFLAGS_SERIAL=-cpp " + self.compiler.openmp_flag,
+ "LDFLAGS_ESSL={0}".format(self.spec["lapack"].libs.ld_flags),
]
return targets
def edit(self, spec, prefix):
- with working_dir('build_and_run'):
- copy('Makefile_OLCF', 'Makefile')
+ with working_dir("build_and_run"):
+ copy("Makefile_OLCF", "Makefile")
def install(self, spec, prefix):
mkdirp(prefix.bin)
- with working_dir('build_and_run'):
- install('rimp2-serial', prefix.bin)
+ with working_dir("build_and_run"):
+ install("rimp2-serial", prefix.bin)