summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch
diff options
context:
space:
mode:
authorMichael Kuhn <michael.kuhn@ovgu.de>2021-10-24 20:39:30 +0200
committerGitHub <noreply@github.com>2021-10-24 20:39:30 +0200
commitd7148a74a0f962cb33dbe20ae279f068f7c19f42 (patch)
tree40336dca956c2a012ff8bbaeba7676283f327d32 /var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch
parentc255e91bbadb58381428c301eb85383b80fbeddf (diff)
downloadspack-d7148a74a0f962cb33dbe20ae279f068f7c19f42.tar.gz
spack-d7148a74a0f962cb33dbe20ae279f068f7c19f42.tar.bz2
spack-d7148a74a0f962cb33dbe20ae279f068f7c19f42.tar.xz
spack-d7148a74a0f962cb33dbe20ae279f068f7c19f42.zip
glib: add 2.70.0 (#26915)
Diffstat (limited to 'var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch')
-rw-r--r--var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch b/var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch
new file mode 100644
index 0000000000..de9e4fba64
--- /dev/null
+++ b/var/spack/repos/builtin/packages/glib/meson-gettext-2.70.patch
@@ -0,0 +1,30 @@
+--- a/meson.build
++++ b/meson.build
+@@ -2047,9 +2047,10 @@ endif
+ # FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
+ # implementations. This could be extended if issues are found in some platforms.
+ libintl_deps = []
+-if cc.has_function('ngettext', args : osx_ldflags)
++gettext_opt = get_option('gettext')
++if ['auto', 'libc'].contains(gettext_opt) and cc.has_function('ngettext', args : osx_ldflags)
+ have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+-else
++elif ['auto', 'external'].contains(gettext_opt)
+ # First just find the bare library.
+ libintl = cc.find_library('intl', required : false)
+ # The bare library probably won't link without help if it's static.
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -9,6 +9,12 @@ option('iconv',
+ value : 'auto',
+ description : 'iconv implementation to use (\'libc\' = \'Part of the C library\'; \'external\' = \'External libiconv\'; \'auto\' = \'Auto-detect which iconv is available\')')
+
++option('gettext',
++ type : 'combo',
++ choices : ['auto', 'libc', 'external'],
++ value : 'auto',
++ description : 'gettext implementation to use (\'libc\' = \'Part of the C library\'; \'external\' = \'External libintl\'; \'auto\' = \'Auto-detect which gettext is available\')')
++
+ option('charsetalias_dir',
+ type : 'string',
+ value : '',