summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hdf5
diff options
context:
space:
mode:
authorGreg Becker <becker33@llnl.gov>2021-03-31 18:34:52 -0700
committerGreg Becker <becker33@llnl.gov>2021-03-31 18:38:22 -0700
commit7daf5823574dc18522f559a084095714cc9f3fb9 (patch)
tree9d75e1a8e51557cd44cb8f7acb6b656a8a77535e /var/spack/repos/builtin/packages/hdf5
parentc4f0a3cf6cd2ab282f6abf20fd72fcb4739a432a (diff)
downloadspack-7daf5823574dc18522f559a084095714cc9f3fb9.tar.gz
spack-7daf5823574dc18522f559a084095714cc9f3fb9.tar.bz2
spack-7daf5823574dc18522f559a084095714cc9f3fb9.tar.xz
spack-7daf5823574dc18522f559a084095714cc9f3fb9.zip
CachedCMakePackage for using *.cmake initial config files (#19316)"
Original commit message: This feature of CMake allows packages to increase reproducibility, especially between Spack- and manual builds. It also allows packages to sidestep certain parsing bugs in extremely long ``cmake`` commands, and to avoid system limits on the length of the command line. Adding: Co-authored by: Chris White <white238@llnl.gov> This reverts commit c4f0a3cf6cd2ab282f6abf20fd72fcb4739a432a.
Diffstat (limited to 'var/spack/repos/builtin/packages/hdf5')
-rw-r--r--var/spack/repos/builtin/packages/hdf5/package.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/hdf5/package.py b/var/spack/repos/builtin/packages/hdf5/package.py
index 8425242b53..01c1428766 100644
--- a/var/spack/repos/builtin/packages/hdf5/package.py
+++ b/var/spack/repos/builtin/packages/hdf5/package.py
@@ -245,7 +245,7 @@ class Hdf5(AutotoolsPackage):
# sanity check in configure, so this doesn't merit a variant.
extra_args = ['--enable-unsupported',
'--enable-symbols=yes',
- '--with-zlib']
+ '--with-zlib=%s' % self.spec['zlib'].prefix]
extra_args += self.enable_or_disable('threadsafe')
extra_args += self.enable_or_disable('cxx')
extra_args += self.enable_or_disable('hl')