summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hip
diff options
context:
space:
mode:
authorSreenivasa Murthy Kolam <67086238+srekolam@users.noreply.github.com>2021-04-07 16:55:20 -0400
committerGitHub <noreply@github.com>2021-04-07 22:55:20 +0200
commit56418bac391f4fe0b46806651357f47cded557a7 (patch)
tree49823ab1db9b6c563c0f03465aeb7949690e9a5d /var/spack/repos/builtin/packages/hip
parent77a211dc468fc76bf6cdde9344d1b156719a7477 (diff)
downloadspack-56418bac391f4fe0b46806651357f47cded557a7.tar.gz
spack-56418bac391f4fe0b46806651357f47cded557a7.tar.bz2
spack-56418bac391f4fe0b46806651357f47cded557a7.tar.xz
spack-56418bac391f4fe0b46806651357f47cded557a7.zip
bump up version for rccl for rocm-4.1.0 release (#22762)
Diffstat (limited to 'var/spack/repos/builtin/packages/hip')
-rw-r--r--var/spack/repos/builtin/packages/hip/0003-Improve-compilation-without-git-repo.4.1.0.patch44
-rw-r--r--var/spack/repos/builtin/packages/hip/package.py13
2 files changed, 47 insertions, 10 deletions
diff --git a/var/spack/repos/builtin/packages/hip/0003-Improve-compilation-without-git-repo.4.1.0.patch b/var/spack/repos/builtin/packages/hip/0003-Improve-compilation-without-git-repo.4.1.0.patch
new file mode 100644
index 0000000000..f5b59e5b6f
--- /dev/null
+++ b/var/spack/repos/builtin/packages/hip/0003-Improve-compilation-without-git-repo.4.1.0.patch
@@ -0,0 +1,44 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 483f8c9..8ddf76e 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -52,7 +52,16 @@ string(REPLACE "." ";" VERSION_LIST ${HIP_BASE_VERSION})
+ list(GET VERSION_LIST 0 HIP_VERSION_MAJOR)
+ list(GET VERSION_LIST 1 HIP_VERSION_MINOR)
+
+-find_package(Git)
++# only look for git when we have a git repo
++if (IS_DIRECTORY "${PROJECT_SOURCE_DIR}/.git")
++ find_package(Git)
++endif()
++
++# FIXME: Two different version strings used.
++
++set(HIP_PACKAGING_VERSION_PATCH "0")
++set(HIP_VERSION_GITDATE "0")
++set(HIP_VERSION_PATCH "0")
+
+ # FIXME: Two different version strings used.
+ if(GIT_FOUND)
+@@ -98,9 +107,6 @@ if(GIT_FOUND)
+ else()
+ set(HIP_PACKAGING_VERSION_PATCH ${HIP_VERSION_GITDATE}.${HIP_VERSION_GITCOUNT}-${HIP_VERSION_GITHASH})
+ endif()
+-else()
+- # FIXME: Some parts depend on this being set.
+- set(HIP_PACKAGING_VERSION_PATCH "0")
+ endif()
+
+ ## Debian package specific variables
+@@ -295,10 +301,6 @@ file(WRITE "${PROJECT_BINARY_DIR}/.hipInfo" ${_buildInfo})
+ # Generate .hipVersion
+ file(WRITE "${PROJECT_BINARY_DIR}/.hipVersion" ${_versionInfo})
+
+-if(NOT DEFINED HIP_VERSION_GITDATE)
+- set(HIP_VERSION_GITDATE 0)
+-endif()
+-
+ # Build doxygen documentation
+ find_program(DOXYGEN_EXE doxygen)
+ if(DOXYGEN_EXE)
+
diff --git a/var/spack/repos/builtin/packages/hip/package.py b/var/spack/repos/builtin/packages/hip/package.py
index 6c2a23f1a2..ccbab3bce1 100644
--- a/var/spack/repos/builtin/packages/hip/package.py
+++ b/var/spack/repos/builtin/packages/hip/package.py
@@ -58,6 +58,7 @@ class Hip(CMakePackage):
# See https://github.com/ROCm-Developer-Tools/HIP/pull/2218
patch('0003-Improve-compilation-without-git-repo.3.7.0.patch', when='@3.7.0:3.9.0')
patch('0003-Improve-compilation-without-git-repo.3.10.0.patch', when='@3.10.0:4.0.0')
+ patch('0003-Improve-compilation-without-git-repo.4.1.0.patch', when='@4.1.0')
# See https://github.com/ROCm-Developer-Tools/HIP/pull/2219
patch('0004-Drop-clang-rt-builtins-linking-on-hip-host.3.7.0.patch', when='@3.7.0:3.9.0')
@@ -85,7 +86,6 @@ class Hip(CMakePackage):
'hsa-rocr-dev': rocm_prefix.hsa,
'rocminfo': rocm_prefix,
'rocm-device-libs': rocm_prefix,
- 'hip-rocclr': rocm_prefix
}
else:
paths = {
@@ -94,7 +94,6 @@ class Hip(CMakePackage):
'hsa-rocr-dev': self.spec['hsa-rocr-dev'].prefix,
'rocminfo': self.spec['rocminfo'].prefix,
'rocm-device-libs': self.spec['rocm-device-libs'].prefix,
- 'hip-rocclr': self.spec['hip-rocclr'].prefix
}
# `device_lib_path` is the path to the bitcode directory
@@ -150,9 +149,6 @@ class Hip(CMakePackage):
# https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/blob/rocm-4.0.0/lib/comgr/src/comgr-env.cpp
env.set('LLVM_PATH', paths['llvm-amdgpu'])
- if self.spec.satisfies('@4.1.0:'):
- env.set('HIP_ROCCLR_HOME', paths['hip-rocclr'])
-
# Finally we have to set --rocm-path=<prefix> ourselves, which is not
# the same as --hip-device-lib-path (set by hipcc). It's used to set
# default bin, include and lib folders in clang. If it's not set it is
@@ -206,7 +202,7 @@ class Hip(CMakePackage):
files = [
'hipify-perl', 'hipcc', 'roc-obj-extract',
'hipconfig', 'hipify-cmakefile',
- 'roc-obj-ls'
+ 'roc-obj-ls', 'hipvars.pm'
]
filter_file(match, substitute, *files, **kwargs)
@@ -239,12 +235,9 @@ class Hip(CMakePackage):
]
if self.spec.satisfies('@:4.0.0'):
args.append(self.define('HIP_RUNTIME', 'ROCclr'))
- else:
- args.append(self.define('HIP_RUNTIME', 'rocclr'))
-
- if self.spec.satisfies('@:4.0.0'):
args.append(self.define('HIP_PLATFORM', 'rocclr'))
else:
+ args.append(self.define('HIP_RUNTIME', 'rocclr'))
args.append(self.define('HIP_PLATFORM', 'amd'))
# LIBROCclr_STATIC_DIR is unused from 3.6.0 and above