summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hip
diff options
context:
space:
mode:
authorrenjithravindrankannath <94420380+renjithravindrankannath@users.noreply.github.com>2022-12-12 11:46:20 -0800
committerGitHub <noreply@github.com>2022-12-12 13:46:20 -0600
commit0578ccc0e6aa8a92b2d4024bd376d58072b2b56e (patch)
treea4245fa4b6b23831bcd236ef7d1a071dafba4eec /var/spack/repos/builtin/packages/hip
parentfcc2ab8b4bae68808e7f134b84bb3a18d7d28f2e (diff)
downloadspack-0578ccc0e6aa8a92b2d4024bd376d58072b2b56e.tar.gz
spack-0578ccc0e6aa8a92b2d4024bd376d58072b2b56e.tar.bz2
spack-0578ccc0e6aa8a92b2d4024bd376d58072b2b56e.tar.xz
spack-0578ccc0e6aa8a92b2d4024bd376d58072b2b56e.zip
ROCm 5.3.0 updates (#33320)
* ROCm 5.3.0 updates * New patches for 5.3.0 on hip and hsakmt * Adding additional build arguments in hip and llvm * RVS updates for 5.3.0 release * New patches and rocm-tensile, rocprofiler-dev, roctracer-dev recipe updates for 5.3.0 * Reverting OPENMP fix from rocm-tensile * Removing the patch to compile without git and adding witout it * Install library in to lib directory instead of lib64 across all platform * Setting lib install directory to lib * Disable gallivm coroutine for libllvm15 * Update llvm-amdgpu prefix path in hip-config.cmake.in Removing libllvm15 from Mesa dependency removing * hip-config.cmake.in update required from 5.2 * hip-config.cmake.in update required from 5.2 and above * hip-config.cmake.in update required for all 5.2 release above * Style check correction in hip update * ginkgo: add missing include * Patching hsa include path for rocm 5.3 * Restricting patch for llvm-15 * Style check error correction * PIC flag required for the new test applications * Passing -DCMAKE_POSITION_INDEPENDENT_CODE=ON in the cmake_args instead of setting -fPIC in CFLAGS Co-authored-by: Cordell Bloor <Cordell.Bloor@amd.com>
Diffstat (limited to 'var/spack/repos/builtin/packages/hip')
-rw-r--r--var/spack/repos/builtin/packages/hip/0013-remove-compiler-rt-linkage-for-host.5.3.0.patch39
-rw-r--r--var/spack/repos/builtin/packages/hip/package.py22
2 files changed, 59 insertions, 2 deletions
diff --git a/var/spack/repos/builtin/packages/hip/0013-remove-compiler-rt-linkage-for-host.5.3.0.patch b/var/spack/repos/builtin/packages/hip/0013-remove-compiler-rt-linkage-for-host.5.3.0.patch
new file mode 100644
index 0000000000..d0b008f025
--- /dev/null
+++ b/var/spack/repos/builtin/packages/hip/0013-remove-compiler-rt-linkage-for-host.5.3.0.patch
@@ -0,0 +1,39 @@
+From 2eb146f180cd6ff35685ac23f79da4fe16dd295b Mon Sep 17 00:00:00 2001
+From: Renjith Ravindran <Renjith.RavindranKannath@amd.com>
+Date: Fri, 21 Oct 2022 14:02:37 -0700
+Subject: [PATCH] New patch removing the fix for the compilation without git
+
+---
+ bin/hipcc.pl | 3 ++-
+ hipamd/hip-config.cmake.in | 1 -
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bin/hipcc.pl b/bin/hipcc.pl
+index 645ae62..d3cf824 100755
+--- a/bin/hipcc.pl
++++ b/bin/hipcc.pl
+@@ -612,7 +612,8 @@ if($HIP_PLATFORM eq "amd"){
+ $targetsStr = $ENV{HCC_AMDGPU_TARGET};
+ } elsif (not $isWindows) {
+ # Else try using rocm_agent_enumerator
+- $ROCM_AGENT_ENUM = "${ROCM_PATH}/bin/rocm_agent_enumerator";
++ $ROCMINFO_PATH = $ENV{'ROCMINFO_PATH'} // $ROCM_PATH;
++ $ROCM_AGENT_ENUM = "${ROCMINFO_PATH}/bin/rocm_agent_enumerator";
+ $targetsStr = `${ROCM_AGENT_ENUM} -t GPU`;
+ $targetsStr =~ s/\n/,/g;
+ }
+diff --git a/hipamd/hip-config.cmake.in b/hipamd/hip-config.cmake.in
+index 89d1224..8c4f9b7 100755
+--- a/hipamd/hip-config.cmake.in
++++ b/hipamd/hip-config.cmake.in
+@@ -306,7 +306,6 @@ if(HIP_COMPILER STREQUAL "clang")
+ if(NOT CLANGRT_BUILTINS)
+ message(FATAL_ERROR "clangrt builtins lib not found")
+ else()
+- set_property(TARGET hip::host APPEND PROPERTY INTERFACE_LINK_LIBRARIES "${CLANGRT_BUILTINS}")
+ set_property(TARGET hip::device APPEND PROPERTY INTERFACE_LINK_LIBRARIES "${CLANGRT_BUILTINS}")
+ endif()
+ endif()
+--
+2.22.0
+
diff --git a/var/spack/repos/builtin/packages/hip/package.py b/var/spack/repos/builtin/packages/hip/package.py
index 5bcf3a4aca..bbf41fee56 100644
--- a/var/spack/repos/builtin/packages/hip/package.py
+++ b/var/spack/repos/builtin/packages/hip/package.py
@@ -18,7 +18,7 @@ class Hip(CMakePackage):
homepage = "https://github.com/ROCm-Developer-Tools/HIP"
git = "https://github.com/ROCm-Developer-Tools/HIP.git"
- url = "https://github.com/ROCm-Developer-Tools/HIP/archive/rocm-5.2.0.tar.gz"
+ url = "https://github.com/ROCm-Developer-Tools/HIP/archive/rocm-5.3.0.tar.gz"
tags = ["rocm"]
maintainers = ["srekolam", "renjithravindrankannath", "haampie"]
@@ -26,6 +26,7 @@ class Hip(CMakePackage):
version("master", branch="master")
+ version("5.3.0", sha256="05225832fb5a4d24f49a773ac27e315239943a6f24291a50d184e2913f2cdbe0")
version("5.2.3", sha256="5b83d1513ea4003bfad5fe8fa741434104e3e49a87e1d7fad49e5a8c1d06e57b")
version("5.2.1", sha256="7d4686a2f8a9124bb21f7f3958e451c57019f48a0cbb42ffdc56ed02860a46c3")
version("5.2.0", sha256="a6e0515d4d25865c037b546035df9c51f0882cd2700e759c266ff7e199f37c3a")
@@ -147,6 +148,7 @@ class Hip(CMakePackage):
"5.2.0",
"5.2.1",
"5.2.3",
+ "5.3.0",
]:
depends_on("hsakmt-roct@" + ver, when="@" + ver)
depends_on("hsa-rocr-dev@" + ver, when="@" + ver)
@@ -165,6 +167,7 @@ class Hip(CMakePackage):
# Add hip-amd sources thru the below
for d_version, d_shasum in [
+ ("5.3.0", "81e9bd5209a7b400c986f9bf1d7079bcf7169bbcb06fc4fe843644559a4d612e"),
("5.2.3", "5031d07554ce07620e24e44d482cbc269fa972e3e35377e935d2694061ff7c04"),
("5.2.1", "4feaa3883cbc54ddcd5d2d5becbe0f3fe3edd5b3b468dc73b5104893029eefac"),
("5.2.0", "8774958bebc29a4b7eb9dc2d38808d79d9a24bf9c1f44e801ff99d2d5ba82240"),
@@ -188,6 +191,7 @@ class Hip(CMakePackage):
)
# Add opencl sources thru the below
for d_version, d_shasum in [
+ ("5.3.0", "d251e2efe95dc12f536ce119b2587bed64bbda013969fa72be58062788044a9e"),
("5.2.3", "932ea3cd268410010c0830d977a30ef9c14b8c37617d3572a062b5d4595e2b94"),
("5.2.1", "eb4ff433f8894ca659802f81792646034f8088b47aca6ad999292bcb8d6381d5"),
("5.2.0", "80f73387effdcd987a150978775a87049a976aa74f5770d4420847b004dd59f0"),
@@ -210,6 +214,7 @@ class Hip(CMakePackage):
when="@{0}".format(d_version),
)
for d_version, d_shasum in [
+ ("5.3.0", "2bf14116b5e2270928265f5d417b3d0f0f2e13cbc8ec5eb8c80d4d4a58ff7e94"),
("5.2.3", "0493c414d4db1af8e1eb30a651d9512044644244488ebb13478c2138a7612998"),
("5.2.1", "465ca9fa16869cd89dab8c2d66d9b9e3c14f744bbedaa1d215b0746d77a500ba"),
("5.2.0", "37f5fce04348183bce2ece8bac1117f6ef7e710ca68371ff82ab08e93368bafb"),
@@ -260,7 +265,11 @@ class Hip(CMakePackage):
patch(
"0012-Improve-compilation-without-git-repo-and-remove-compiler-rt-linkage-for-host"
".5.2.1.patch",
- when="@5.2.1:",
+ when="@5.2.1:5.2.3",
+ )
+ patch(
+ "0013-remove-compiler-rt-linkage-for-host.5.3.0.patch",
+ when="@5.3.0:",
)
# See https://github.com/ROCm-Developer-Tools/HIP/pull/2141
@@ -463,6 +472,13 @@ class Hip(CMakePackage):
"hip-config.cmake.in",
string=True,
)
+ if self.spec.satisfies("@5.2:"):
+ filter_file(
+ '"${ROCM_PATH}/llvm"',
+ self.spec["llvm-amdgpu"].prefix,
+ "hipamd/hip-config.cmake.in",
+ string=True,
+ )
perl = self.spec["perl"].command
kwargs = {"ignore_absent": False, "backup": False, "string": False}
@@ -538,5 +554,7 @@ class Hip(CMakePackage):
args.append(self.define("HIP_CATCH_TEST", "OFF"))
args.append(self.define("ROCCLR_PATH", self.stage.source_path + "/rocclr"))
args.append(self.define("AMD_OPENCL_PATH", self.stage.source_path + "/opencl"))
+ if "@5.3.0:" in self.spec:
+ args.append("-DCMAKE_INSTALL_LIBDIR=lib")
return args