summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libcerf
diff options
context:
space:
mode:
authorQuinn <micheal.quinn85@gmail.com>2017-01-19 08:26:39 -0600
committerTodd Gamblin <tgamblin@llnl.gov>2017-01-19 06:26:39 -0800
commitf511f7b558c7cfe36265b9caf148808dcc849335 (patch)
treed6b95657472574e70e2a124eef432c325060446c /var/spack/repos/builtin/packages/libcerf
parent4dad5aab8402f787afd8f9e440ac4bbbecd4b80f (diff)
downloadspack-f511f7b558c7cfe36265b9caf148808dcc849335.tar.gz
spack-f511f7b558c7cfe36265b9caf148808dcc849335.tar.bz2
spack-f511f7b558c7cfe36265b9caf148808dcc849335.tar.xz
spack-f511f7b558c7cfe36265b9caf148808dcc849335.zip
Adding some fixes to packages that use `configure_args` function without setting spec set or directly referencing it (#2868)
* Adding 'self.' to the spec call for configure_args * Updating this to set spec to self.spec * More updates to the configure_args spec calls * Another spec issue * Another spec issue. * And another spec issue * Switching cmor back to self.spec.
Diffstat (limited to 'var/spack/repos/builtin/packages/libcerf')
-rw-r--r--var/spack/repos/builtin/packages/libcerf/package.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libcerf/package.py b/var/spack/repos/builtin/packages/libcerf/package.py
index 3bc8ddbd16..82637431d6 100644
--- a/var/spack/repos/builtin/packages/libcerf/package.py
+++ b/var/spack/repos/builtin/packages/libcerf/package.py
@@ -38,6 +38,7 @@ class Libcerf(AutotoolsPackage):
version('1.3', 'b3504c467204df71e62aeccf73a25612')
def configure_args(self):
+ spec = self.spec
options = []
# Clang reports unused functions as errors, see
# http://clang.debian.net/status.php?version=3.8.1&key=UNUSED_FUNCTION