summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libmicrohttpd/package.py
diff options
context:
space:
mode:
authorTim Haines <thaines.astro@gmail.com>2020-08-25 03:24:04 -0500
committerGitHub <noreply@github.com>2020-08-25 10:24:04 +0200
commit9b07669ab3c2d4939a88f82858ea0b95d857fb45 (patch)
tree856e1f850201ff7b75f9ffa72d71df03e5c3a73b /var/spack/repos/builtin/packages/libmicrohttpd/package.py
parentdf51cf20c5f9996b5c833b2d0ea703af983c05e6 (diff)
downloadspack-9b07669ab3c2d4939a88f82858ea0b95d857fb45.tar.gz
spack-9b07669ab3c2d4939a88f82858ea0b95d857fb45.tar.bz2
spack-9b07669ab3c2d4939a88f82858ea0b95d857fb45.tar.xz
spack-9b07669ab3c2d4939a88f82858ea0b95d857fb45.zip
libmicrohttpd: added new package at v0.9.71 (#18226)
Diffstat (limited to 'var/spack/repos/builtin/packages/libmicrohttpd/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libmicrohttpd/package.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libmicrohttpd/package.py b/var/spack/repos/builtin/packages/libmicrohttpd/package.py
new file mode 100644
index 0000000000..7f6daade04
--- /dev/null
+++ b/var/spack/repos/builtin/packages/libmicrohttpd/package.py
@@ -0,0 +1,48 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Libmicrohttpd(AutotoolsPackage):
+ """GNU libmicrohttpd is a small C library that is supposed to make
+ it easy to run an HTTP server as part of another application.
+ """
+
+ homepage = "https://www.gnu.org/software/libmicrohttpd/"
+ url = "https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-0.9.71.tar.gz"
+
+ maintainers = ['hainest']
+
+ version('0.9.71', 'e8f445e85faf727b89e9f9590daea4473ae00ead38b237cf1eda55172b89b182')
+ version('0.9.70', '90d0a3d396f96f9bc41eb0f7e8187796049285fabef82604acd4879590977307')
+
+ variant('https',
+ default=False,
+ description="HTTPS support with GnuTLS")
+
+ depends_on('gettext')
+ depends_on('gnutls', when='+https')
+ depends_on('libgcrypt', when='+https')
+
+ def configure_args(self):
+ options = [
+ '--enable-static=no', # don't build static libs
+ '--enable-shared=yes', # always build shared libs
+ '--with-pic', # always build PIC libs
+ '--disable-rpath', # let spack handle the RPATH
+ '--disable-doc', # don't build the docs
+ '--disable-examples', # don't build the examples
+ '--disable-curl' # disable cURL-based testcases
+ ]
+
+ if self.spec.satisfies('+https'):
+ options.append('--enable-https')
+ prefix = self.spec['gnutls'].prefix
+ options.append('--with-gnutls={0}'.format(prefix))
+ prefix = self.spec['libgcrypt'].prefix
+ options.append('--with-libgcrypt-prefix={0}'.format(prefix))
+
+ return options