summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libquo/package.py
diff options
context:
space:
mode:
authorMassimiliano Culpo <massimiliano.culpo@googlemail.com>2017-01-26 11:27:15 +0100
committerTodd Gamblin <tgamblin@llnl.gov>2017-01-26 02:27:15 -0800
commit81a5146b1df1f69172c0f76bc3dbe469f4e366f9 (patch)
treeb1f369a4b48c09fb90c499afd9856739ccf027ff /var/spack/repos/builtin/packages/libquo/package.py
parent3b2124af6a861273df5bc19345f2a03e8c9db0e1 (diff)
downloadspack-81a5146b1df1f69172c0f76bc3dbe469f4e366f9.tar.gz
spack-81a5146b1df1f69172c0f76bc3dbe469f4e366f9.tar.bz2
spack-81a5146b1df1f69172c0f76bc3dbe469f4e366f9.tar.xz
spack-81a5146b1df1f69172c0f76bc3dbe469f4e366f9.zip
AutotoolsPackage: minor improvements (#2859)
* AutotoolsPackage: added configure_directory to permit build out of source. The configure script executable is now invoked with an absolute path. Modified a few packages accordingly. * build_systems: functions returning directories are now properties * build_systems: fixed issues with tcl and tk * AutotoolsPackage: reworked recipe for autoreconf
Diffstat (limited to 'var/spack/repos/builtin/packages/libquo/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libquo/package.py28
1 files changed, 5 insertions, 23 deletions
diff --git a/var/spack/repos/builtin/packages/libquo/package.py b/var/spack/repos/builtin/packages/libquo/package.py
index 3e574f7004..76a508f9c6 100644
--- a/var/spack/repos/builtin/packages/libquo/package.py
+++ b/var/spack/repos/builtin/packages/libquo/package.py
@@ -23,10 +23,9 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
##############################################################################
from spack import *
-import os
-class Libquo(Package):
+class Libquo(AutotoolsPackage):
"""QUO (as in "status quo") is a runtime library that aids in accommodating
thread-level heterogeneity in dynamic, phased MPI+X applications comprising
@@ -42,25 +41,8 @@ class Libquo(Package):
depends_on('automake', type='build')
depends_on('libtool', type='build')
- def install(self, spec, prefix):
- autoreconf_options = [
- '--install',
- '--verbose',
- '--force',
- '-I', 'config',
- '-I', os.path.join(spec['automake'].prefix,
- 'share', 'aclocal'),
- '-I', os.path.join(spec['libtool'].prefix,
- 'share', 'aclocal')
+ def configure_args(self):
+ return [
+ 'CC={0}'.format(self.spec['mpi'].mpicc),
+ 'FC={0}'.format(self.spec['mpi'].mpifc)
]
- autoreconf(*autoreconf_options)
-
- configure_options = [
- '--prefix={0}'.format(prefix),
- 'CC=%s' % join_path(spec['mpi'].prefix.bin, "mpicc"),
- 'FC=%s' % join_path(spec['mpi'].prefix.bin, "mpif90")
- ]
- configure(*configure_options)
-
- make()
- make('install')