summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
diff options
context:
space:
mode:
authoralalazo <massimiliano.culpo@googlemail.com>2016-06-08 16:33:49 +0200
committeralalazo <massimiliano.culpo@googlemail.com>2016-06-08 16:33:49 +0200
commit564483936f32abfd5ee79dea6263af4bd6e9bb9d (patch)
treef0b0913dbd8e5772474d275d71a761b30d04302c /var/spack/repos/builtin/packages/lua-luafilesystem/package.py
parent4a61efe641c9bf987a62bff729334c7cce3f141b (diff)
downloadspack-564483936f32abfd5ee79dea6263af4bd6e9bb9d.tar.gz
spack-564483936f32abfd5ee79dea6263af4bd6e9bb9d.tar.bz2
spack-564483936f32abfd5ee79dea6263af4bd6e9bb9d.tar.xz
spack-564483936f32abfd5ee79dea6263af4bd6e9bb9d.zip
qa : fixed flake8 issues
Diffstat (limited to 'var/spack/repos/builtin/packages/lua-luafilesystem/package.py')
-rw-r--r--var/spack/repos/builtin/packages/lua-luafilesystem/package.py19
1 files changed, 12 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/lua-luafilesystem/package.py b/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
index 14278bbe72..a61b9dd675 100644
--- a/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
+++ b/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
@@ -27,11 +27,13 @@ from spack import *
class LuaLuafilesystem(Package):
"""
- LuaFileSystem is a Lua library developed to complement the set of functions related to file
- systems offered by the standard Lua distribution.
+ LuaFileSystem is a Lua library developed to complement the set of
+ functions related to file systems offered by the standard Lua distribution.
- LuaFileSystem offers a portable way to access the underlying directory structure and file attributes. LuaFileSystem
- is free software and uses the same license as Lua 5.1
+ LuaFileSystem offers a portable way to access the underlying directory
+ structure and file attributes.
+
+ LuaFileSystem is free software and uses the same license as Lua 5.1
"""
homepage = 'http://keplerproject.github.io/luafilesystem'
url = 'https://github.com/keplerproject/luafilesystem/archive/v_1_6_3.tar.gz'
@@ -41,6 +43,9 @@ class LuaLuafilesystem(Package):
extends('lua')
def install(self, spec, prefix):
- version = self.spec.version
- rockspec_format = join_path(self.stage.path, 'luafilesystem-v_{version.underscored}', 'rockspecs', 'luafilesystem-{version.dotted}-1.rockspec')
- luarocks('--tree=' + prefix, 'install', rockspec_format.format(version=self.spec.version)) \ No newline at end of file
+ rockspec_fmt = join_path(self.stage.path,
+ 'luafilesystem-v_{version.underscored}',
+ 'rockspecs',
+ 'luafilesystem-{version.dotted}-1.rockspec')
+ luarocks('--tree=' + prefix, 'install',
+ rockspec_fmt.format(version=self.spec.version))