summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
diff options
context:
space:
mode:
authoralalazo <massimiliano.culpo@googlemail.com>2016-06-08 15:35:15 +0200
committeralalazo <massimiliano.culpo@googlemail.com>2016-06-08 15:35:15 +0200
commitf4a39457de662376b5f9da300a06e2dff91b1aeb (patch)
tree0f636ac58ec2c0c6b8f112c0c19dbdf0c2e80402 /var/spack/repos/builtin/packages/lua-luafilesystem/package.py
parent30e8e77fb60b06535b49d54db62781299f555a8d (diff)
downloadspack-f4a39457de662376b5f9da300a06e2dff91b1aeb.tar.gz
spack-f4a39457de662376b5f9da300a06e2dff91b1aeb.tar.bz2
spack-f4a39457de662376b5f9da300a06e2dff91b1aeb.tar.xz
spack-f4a39457de662376b5f9da300a06e2dff91b1aeb.zip
lmod : updated package and dependencies
Diffstat (limited to 'var/spack/repos/builtin/packages/lua-luafilesystem/package.py')
-rw-r--r--var/spack/repos/builtin/packages/lua-luafilesystem/package.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/lua-luafilesystem/package.py b/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
new file mode 100644
index 0000000000..14278bbe72
--- /dev/null
+++ b/var/spack/repos/builtin/packages/lua-luafilesystem/package.py
@@ -0,0 +1,46 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class LuaLuafilesystem(Package):
+ """
+ LuaFileSystem is a Lua library developed to complement the set of functions related to file
+ systems offered by the standard Lua distribution.
+
+ LuaFileSystem offers a portable way to access the underlying directory structure and file attributes. LuaFileSystem
+ is free software and uses the same license as Lua 5.1
+ """
+ homepage = 'http://keplerproject.github.io/luafilesystem'
+ url = 'https://github.com/keplerproject/luafilesystem/archive/v_1_6_3.tar.gz'
+
+ version('1_6_3', 'd0552c7e5a082f5bb2865af63fb9dc95')
+
+ extends('lua')
+
+ def install(self, spec, prefix):
+ version = self.spec.version
+ rockspec_format = join_path(self.stage.path, 'luafilesystem-v_{version.underscored}', 'rockspecs', 'luafilesystem-{version.dotted}-1.rockspec')
+ luarocks('--tree=' + prefix, 'install', rockspec_format.format(version=self.spec.version)) \ No newline at end of file