summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/nvcomp/package.py
diff options
context:
space:
mode:
authorRobert Underwood <robertu94@users.noreply.github.com>2022-10-17 15:30:54 -0400
committerGitHub <noreply@github.com>2022-10-17 13:30:54 -0600
commitda6aeaad44e434da5563d32f2fa9900de362b2ed (patch)
tree49c7bc8654d82f1a80d0edbfb5f726b3dc354a01 /var/spack/repos/builtin/packages/nvcomp/package.py
parentfb090a69f4ead786c5b0e016f402bb4d782ab313 (diff)
downloadspack-da6aeaad44e434da5563d32f2fa9900de362b2ed.tar.gz
spack-da6aeaad44e434da5563d32f2fa9900de362b2ed.tar.bz2
spack-da6aeaad44e434da5563d32f2fa9900de362b2ed.tar.xz
spack-da6aeaad44e434da5563d32f2fa9900de362b2ed.zip
Initial contribution of LibPressio ecosystem (#32630)
* Add libpressio and dependencies; some of these packages are maintained as forks of the original repositories and in those cases the docstring mentions this. * Add optional dependency in adios2 on libpressio * cub package: set CUB_DIR environment variable for dependent installations * Clear R_HOME/R_ENVIRON before Spack installation (avoid sources outside of Spack from affecting the installation in Spack) * Rename dlib to dorian3d-dlib and update dependents; add new dlib implementation. Pending an official policy on how to handle packages with short names, reviewer unilaterally decided that the rename was acceptable given that the new Spack dlib package is referenced more widely (by orders of magnitude) than the original Co-authored-by: Samuel Li <shaomeng@users.noreply.github.com>
Diffstat (limited to 'var/spack/repos/builtin/packages/nvcomp/package.py')
-rw-r--r--var/spack/repos/builtin/packages/nvcomp/package.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/nvcomp/package.py b/var/spack/repos/builtin/packages/nvcomp/package.py
new file mode 100644
index 0000000000..353802225d
--- /dev/null
+++ b/var/spack/repos/builtin/packages/nvcomp/package.py
@@ -0,0 +1,34 @@
+# Copyright 2013-2022 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack.package import *
+
+
+class Nvcomp(CMakePackage, CudaPackage):
+ """Last open source release of A library for fast lossless compression
+ /decompression on NVIDIA GPUs
+
+ forked from: https://github.com/NVIDIA/nvcomp after NVIDIA made this closed source
+ """
+
+ homepage = "https://github.com/NVIDIA/nvcomp"
+ url = "https://github.com/NVIDIA/nvcomp/archive/refs/tags/v2.0.2.tar.gz"
+
+ # pinned to the last open source release+a few minor patches
+ git = "https://github.com/robertu94/nvcomp"
+
+ maintainers = ["robertu94"]
+
+ version("2.2.0", commit="3737f6e5028ed1887b0023ad0fc033e139d57574")
+ version("2.0.2", commit="5d5c194f3449486d989057f632d10954b8d11d75")
+
+ depends_on("cuda")
+ conflicts("~cuda")
+
+ def cmake_args(self):
+ args = ["-DBUILD_EXAMPLES=OFF", "-DBUILD_BENCHMARKS=OFF"]
+ cuda_arch_list = self.spec.variants["cuda_arch"].value
+ args.append("CMAKE_CUDA_ARCHITECTURES={0}".format(";".join(cuda_arch_list)))
+ return args