summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-biopython/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2016-01-17 19:42:28 -0800
committerTodd Gamblin <tgamblin@llnl.gov>2016-01-19 01:16:08 -0800
commit8d6342c53d91f302204d0bbb54f06978a6de26a7 (patch)
tree8848c00c94c5c87bd8c6fb4882e4362920d7096e /var/spack/repos/builtin/packages/py-biopython/package.py
parentd802165e039a3661831e84ecbdd31f1c4107d39d (diff)
parent97b492756acce93dbd5f1c305504f07df7582ba0 (diff)
downloadspack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.gz
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.bz2
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.xz
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.zip
Merge branch 'mplegendre-multi_pkgsrc_roots' into develop
- This moves var/spack/packages to var/spack/repos/builtin/packages. - Packages that did not exist in the source branch, or were changed in develop, were moved into var/spack/repos/builtin/packages as part of the integration. Conflicts: lib/spack/spack/test/unit_install.py var/spack/repos/builtin/packages/clang/package.py
Diffstat (limited to 'var/spack/repos/builtin/packages/py-biopython/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-biopython/package.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-biopython/package.py b/var/spack/repos/builtin/packages/py-biopython/package.py
new file mode 100644
index 0000000000..8ecaf48626
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-biopython/package.py
@@ -0,0 +1,15 @@
+from spack import *
+
+class PyBiopython(Package):
+ """It is a distributed collaborative effort to develop Python libraries and applications which address the needs of current and future work in bioinformatics."""
+ homepage = "http://biopython.org/wiki/Main_Page"
+ url = "http://biopython.org/DIST/biopython-1.65.tar.gz"
+
+ version('1.65', '143e7861ade85c0a8b5e2bbdd1da1f67')
+
+ extends('python')
+ depends_on('py-mx')
+ depends_on('py-numpy')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)